[RELEASE] Door lock code/lock user management (create, delete and schedule codes) with automatic lock/unlock, custom user actions and SHM integration

smartapp_alerts
dth_locks
smartapp_security
smartapp_locks
rboyapps

(Prowl) #1455

Same here…
log shows this when I Rey and open settings on my phone

Clear

14:57:40: error org.codehaus.groovy.runtime.typehandling.GroovyCastException: Cannot cast object ‘null’ with class ‘null’ to class ‘int’. Try ‘java.lang.Integer’ instead

Still operates from switches etc though - just th


(Rick R.) #1456

I tracked mine down to a bad Schlage Connect lock.

A little background - I bought two Schlage Connects a year or so ago, and one of them would drain the battery pack in a month while the other was still on the first set of batteries after a year.

I called Schlage, and they had me give them the firmware number on the lock that awas draining batteries, and told me it was a known issue with that firmware so they would send me a new lock free of charge. They said I didn’t have to return the malfunctioning lock, just keep it for parts.

Long story short, I installed that lock on the back door in our kitchen since I had it laying around and that door isn’t used much, so no big deal if the battery drains since it wouldn’t be doing much motorized operations anyway.

Once I took that lock out the lock manager version 6.0.1 worked fine. There were a couple of avenues I tried to confirm it was indeed that lock, so there’s a number of techniques you could try to get the lock manager working again:

  1. Downgrade the lock manager smartapp to a previous version (this worked for me since I kept a copy of the old code) and then remove the lock having a problem, then upgrade the smartapp.

  2. Or you can delete the smartapp from the IDE, add it back (with 6.0.1 code), publish and install, and then add one lock at a time. For me, when I added the bad lock to the SmartApp it jumped to an error screen and wouldn’t save. It would allow me to go back and remove the problem lock. Once I narrowed down what lock was causing the problem I added all the other locks and it was fine. So I ordered a new lock to replace the old one.

  3. Exclude the bad lock (if you know which one it is), acknowledge the warnings that it will affect various smartapps and routines depending on your setup, and the lock manager app will work.

So at least in my case it appears that a bad lock was causing my issues. Everything is working here and I have a new lock on the way. Hope this makes sense, let me know if any question I can help answer.


(www.rboyapps.com - Make your home your butler!) #1457

If you’re using the Enhanced ZWave lock device handler you have to upgrade to version 04.00.00 and click on Refresh or Configure and Save in your device page for the changes to take effect. Please see the post on the enhanced device handlers page.

EDIT: Updated the app to continue support for the old device handlers and avoid this error (version 06.01.01)


(Cristofer Johnson) #1458

If i switch from your device handler to stock will everything still work?


#1459

Hi, Thank you for fixing the Audio On/Off now its fixed.

The Code Entry On/OFF still doesn’t do anything for my Yale keyfree. I couldn’t turn off the keypad entry.

Thanks


(www.rboyapps.com - Make your home your butler!) #1460

That’s a function of the device handler. Likely your lock model doesn’t support privacy mode.

If you want you can PM me or email our support the logs from your IDE Live Logging when you toggle the tile and we can take a look at it.


(Ian Cowe) #1461

Hi,
I’m trying to install the User Unlock/Lock Door Notification and actions smartapp with my Yale conexis L1. It’s using the version 4 universal enhanced zwave device handler, When i try to add the smart app i am able to select the lock, however the next screen is blank other than the text “user door unlock/lock notifications and actions v04.00.02” and when i press next again i get an “error saving unnamed page. please contact smartapp developer”. I’ve checked the logs and get these messages:

acfc42b0-8e51-4589-83c9-0d9821f41825 ‎19‎:‎23‎:‎24: error org.codehaus.groovy.runtime.typehandling.GroovyCastException: Cannot cast object ‘null’ with class ‘null’ to class ‘int’. Try ‘java.lang.Integer’ instead
acfc42b0-8e51-4589-83c9-0d9821f41825 ‎19‎:‎23‎:‎24: trace [detailedNotifications:false, disableAllNotify:false, disableUpdateNotifications:false, locks:[Front Door Yale Conexis L1]]
acfc42b0-8e51-4589-83c9-0d9821f41825 ‎19‎:‎23‎:‎21: trace [:]

grateful for any ideas on how to resolve this.

thanks


(www.rboyapps.com - Make your home your butler!) #1462

This error is caused because your v4 device handler hasn’t initialized itself, after installing it you need to click on the configure (gear) button and then click Save to initialize the device handler.

Anyways, we’ve put a patch to ignore this error in version 06.01.01 of the SmartApp. You can reinitialize your device handler (which is anyways required to use all it’s features) or update to the latest version of the SmartApp.


(Kevin Sime) #1463

Seeing odd issue with the latest DH (v 04.00.00) update.

After installing, phone shows correct app and DH versions but then the Device Events List on the IDE keeps reporting and toggling between 03.05.01 and 04.00.00 every 4 minutes. Why would it do that ?


(www.rboyapps.com - Make your home your butler!) #1464

Sounds like the platform is caching the old code and seems to be switching between running it and the new code. Usually fixes itself or you can try to switch the DH’s and then revert it or republish it, idea being to force the platform to purge it’s cache. If it continues to happen let ST support know so they can investigate it.


(Kevin Sime) #1465

After 5 hrs of it toggling between the two versions, it stabilised … but at v 03.05.01 ! I’ll try to republish v 4, failing that will contact ST support. Thanks.

UPDATE : Republished ver 04.00.00 and been stable for last 20 mins. Looks sorted.


(Jimmy) #1466

i’m getting a lot of repeated commands to set lock codes using the default device handler. Like every 5 minutes.


(Ian Cowe) #1467

just to follow up on this, i had already initialized the device handler, though i tried again and still have the same issue. one thing to note is as i’m using a Yale Conexis L1 i need to use the smartapp that imports existing users rather than the one that lets you register them in smartapps. I tried the full version and that actually works without error but obviously isn’t usable with my lock. I noticed that although there is a new version of the full smartapp that was released yesterday with the bug fix you mentioned, the other smartapp is still dated from a few days ago.

Grateful for any assistance.

thanks


(www.rboyapps.com - Make your home your butler!) #1468

Your device handler database is out of sync with the lock. Run the Clear Codes procedure on our website and it should resolve it.


(www.rboyapps.com - Make your home your butler!) #1469

Are you referring to this SmartApp which allows you to use the existing users programmed into the lock to take actions?

If so then yesterday’s patch has also been applied to this SmartApp and you can download the updated version.


#1470

After Updating to v06.01.00 and v04.00.00 of the Device Handler, the DeleteCodes for Expired Codes does not seam to be working. The Notifications Message and Activity Feed on ST advises

  • Confirmed Guest user 8 was deleted from Yale Lock
  • Requesting Yale Lock to delete user 8 Guest
  • Yale Lock User 8 Guest code expired on Sun Jan 21 2018 14:00 GMT

This was as before when it was deleting expired users, but when I go back in the Automation and in the SmartApps and navigate through, I see the ‘Deleted’ user is still there. This is happening with multiple users.

Any ideas what to do ?

Many thanks


(Jimmy) #1471

Thanks, that straightened it out. Any way you can have the Slot # Name in your app map to the Code Name attribute in Smart Locks?

Right now you send this:

Renaming in Smart Locks sends this:


#1472

After updating all code for SA and DH (using Universal Z-Wave), and adding Smart Locks back in, the Dashboard page for Smart Locks never updates. If I unlock a lock, or unlock both locks from Smart Locks and go back to Dashboard, it never changes from “All locked”. I have removed Smart Locks and reinstalled several times. I know another person reported this in one of the other threads. See screenshots:

No matter what the locks are set to, the main Dashboard screen never updates.

EDIT: If you uninstall Smart Locks and then reinstall, whatever the status is of all locks combined at the time of install, that is what displays in the Dashboard screen and remains that way, no matter what status changes occur on the locks.


[RELEASE] Universal Enhanced Z-Wave Lock, Schlage Lock, Yale Lock, Kwikset Lock, IDLock, DanaLock, August Pro and Samsung Lock Device Handler with Alarm Control, Notification, RFID, Door Sensor and advanced features
(Ian Cowe) #1473

That fixed my problem, thanks!


(www.rboyapps.com - Make your home your butler!) #1474

It already does that, if you’re using the new stock device handler or v4 of the custom handler it will send the lock names so that it will sync up with SmartLocks.