[RELEASE] Dome Siren (Official)

dth_siren
dth_security
dth_alerts

(Jimmy) #184

Login to https://account.smartthings.com (where you installed the device handler), choose the devices tab, and click on the device name


(Kevin) #185

Make sure you’re using the classic SmartThings app.


#187

I had this all set up correctly but then made the mistake of disconnecting the siren. Now that I try to get it set back up I can’t get all of the extra sound and chime options. Any idea how to reset the device and device handler so I can start from scratch or what is the best way to go about this?


(Jimmy) #188

You just need to login to the ide and change the device type assigned to the device.


#189

Thanks for the reply. Can you be more specific ? Change from what to what?


(Jimmy) #190

Login to the ide, go to the devices section, click on your devices name. Click edit. Change the type from z-wave siren to Dome siren (which will be at the bottom of the list).


#191

Thank you very much!!


#192

Hi,

I’m having the same issues. I deleted and re-added the handler and device but still am getting the on/off siren screen. How were you able to finally fix this? You said “I knew I’d find it AFTER posting…just a few posts up is a screenshot of the Device Settings…my device type defaulted to Z-Wave siren. Changed to Dome Siren and all good now.” But i’m not sure how to do that. Thanks!


#193

Ok got it after reading the last few posts. Go to https://account.smartthings.com - then my devices -> under display name click on the “dome siren” - click on edit -> and under ‘type’ click on ‘dome siren’ -> press update button and that should be it!


(Kevin) #194

If you installed the handler before adding the device then you shouldn’t have to manually change the device type.

If you had the DTH already installed and it didn’t identify it correctly, please open the device in the IDE, copy the text next to Raw Description, and then post it so I can add the new fingerprint to the DTH.


#195

My solution:
Like a few above, I could not get anything but the option to activate the alarm. Under “My Devices” there were no devices listed.

I had to select “My Locations” and then choose the name I gave it (“Home” in my case), and then go through the self publish steps, then it was listed under “My Devices”. Finally, I could change the type from “z-wave siren” to “dome siren”. Dome Siren was the option at the very bottom of the list when editing it. After that, everything worked.

tl; dr: if no devices show up, choose your location and then choose “my devices”


(Ryan) #196

I am trying to add a trigger using either SHM or “Speaker Companion” however the chime/siren never shows up as a valid audio device. I have the custom “Dome Siren” device handler installed and configured for the connected Dome Chime device…am I missing something simple?


#197

Is the custom Device Handler selected as the device type in the Dome Siren in the SmartThings IDE?


(Kevin) #198

Are you using the “Classic” SmartThings mobile app?


(Ryan) #199

Yes, I am on the classic app. If you tap on one of the alarm, bell, or chime tiles, should the dome make a sound? The tiles appear to be non-responsive to me.


(Kevin) #200

Yes the tiles should make sound when you tap them. You might want to try removing the device and factory resetting it.


(Ryan) #201

Thank you…I will give that a try. I installed the device handler from the git-hub repo, and I am 99% sure that I did it right…it shows up with you as the author and pulled in the correct “Dome Siren” title…is there anything I could have done wrong during that process?

Thanks for all the help and all of the dev work btw!


(Ryan) #202

It looks like things are working better…I had to delete the device and the device handler and start all over. Is there any reason that the device handler is listed in black italics, and my other device handlers are green and non-italic?


(Michael Davis) #203

Hey Kevin,

I used this Dome Siren handler you built for a Wink Siren/Chime. It works great except I try to add an automation (trying to get it to just chime when someone triggers a motion detector at the front door), it only has on/off available and not any of the chime tone options (or siren options for that matter). Is there something that can be added to the handler so the device options show up in automation correctly instead of just on/off?


(Kevin) #204

You need to use the SmartThings Classic Mobile App.