[RELEASE] Dome Mouser (Official)

Why does mine keep tripping? I bought 4 and they all trip regularly without any mice being caught.

There’s a 2 second delay so try using bait that the mouse can’t quickly grab and run off with.

Wondering if anyone can help me. I have the smartthings adt hub that I’m trying to us a dome mouser with. I can’t seem to figure out how to get notifications.

You need to install the custom handler first. Then you can use Smsrt Home Monitor custom in the classic app for an alert.

dont know how to do that.


tried that. I guess Im doing something wrong.

After installing and publishing the code, did you edit the device in the IDE and change the Type field to Dome Mouser?

1 Like

yes, I did. Its odd. When I first paired the mouser, two devices came up. A motion and a contact sensor. I removed both and tried again. Still can’t get it to work.

I’ve never seen that happen before with any device…

Are you using the classic mobile app?

yes I have

You could try removing all instances of the device, rebooting your hub, factory resetting the device (instructions should be manual), and then try joining it again.

Try re-publishing the device handler too.

I think my mistake is with the publishing. I am NOT very literate with this stuff.


first of all, thanks for writing this device handler and making it available.
I was able to connect the Mouser to Smartthings and can see status in the old app. However in the new app I see

  • checking status on the tile in the main view
  • a section labeled “pest control” showing a crossed out cloud symbol
  • the battery percentage

The change history of the device handler suggests that it was updated for the new app. Any suggestions on how to get this working in the new app?


At one point all devices required a vid in order for them to open in the new mobile app which is what you’re seeing in the change logs, but they’ve made a lot of changes since then and I’ve found that a lot of the vids now break the handlers.

If you delete vid: “generic-motion” on line 44 and the comma on the line above it, that might solve the problem.

The new mobile app has a really bad caching issue with that metadata so you might be better off modifying the name on line 41, creating a new handler for it in the IDE, and then manually change the device’s Type field in the IDE to that new handler.

SmarThings finally released the documentation for custom capabilities in the new mobile app, which will allow me to customize the UI in the new mobile app for this device, but it’s poorly documented, not fully supported by the apps, and not completely stable so I won’t be updating any of my handlers for at least a couple of months.


Thanks for the suggestion.
I copied the code and created a new device handler, renamed it “Dome Mouser - NEW” and deleted the vid: statement and comma in the line before.
I saved and published it, then edited the “Type” field in my mouse trap device to use the newly created handler.
I updated the wake up interval to 2 hours in the new app, but didn’t seem update data (in the device list it still showed the last activity as more than 2 hrs ago.
I waited until after 12 hrs were done, the device list now shows a recent update.

Unfortunately the new app still shows the same issue as before.

Any other suggestions I could try?

Thanks for your help!


Try the built-in z-wave mouse trap handler…

Thanks, should have thought of that.
It now shows up as an armed trap in the new SmartThings app.

If you have time, would appreciate to understand what the difference between the generic Z-wave device handler and your custom device handler is. I am using the motion sensor from the custom device handler in an automation.



I’ve never messed around with the built-in handler so I’m not sure what the differences are, but I suspect it doesn’t support all the settings and uses different capabilities to indicate armed/disarmed and that it’s been tripped…