[RELEASE] Dome Leak Sensor (Official)

This is the Official device handler for the Dome Leak Sensor (Model: DMWS1)

There are multiple settings that allow you to customize the alarm and reminders:

  • Enable/Disable Audible Alarm: Allows you to disable the audible alarm and just flash the red LED when it detects water.

  • Initial Alarm Duration: The amount of time the audible alarm and/or LED flashes when it initially detects water.

  • Reminder Alarm Duration: The amount of time the audible alarm and/or LED flashes as a reminder.

  • Reminder Interval: How long to wait between reminder alarms.

  • Total Alarm Duration: When the sensor remains wet, how long should it send reminders for.

This device sleeps so after updating the settings you have to wake it up by pressing the button inside for about 1/2 second. If you’ve successfully woken the device up, the red LED will flash once.


        

    


10 Likes

For those wondering, this handler does seem to work with the Neo Coolcam sensor that looks the same as the Dome unit. Even the parameter settings map correctly.

I realize this was posted over a year ago, but wonder if you are still using the CoolCam Leak Detectors? I did see the note about the Dome DH and have installed it. But I don’t see that the batter level is updating at all. did this function work correctly for ou?

BTW, the vendor claims that they are working with SmartThings to have this device included as a certified device that will be configured correctly on pairing with no special DH needed.

Thanks,

Bill Dunn

I’ve only had it 10 days, so still waiting to see if battery updates. But based on the manual that came with it and the quick browse through the device handler I took, it should.

Well, I’m using the Dome DH above (which does indeed indicate that’s a supported feature) and even though I have the battery update setting at 8 hours, nothing coming through after 2 days of waiting. the CoolCam folks insist they are seeking cert with Smartthings so it will be addressed without need for a DH. I may just try the "generic Zwave Leak detector setting on the hub management pages.

Bill

Is the battery tile empty or are you just not seeing battery events in the Recently tab?

Did you wake the device up after changing the “Minimum Check in Interval”? Does the “Settings Updated” tile show a recent date?

Dome and a lot of other companies have been trying to get ST to certify them and publish their DTHs for over a year and ST has been completely unresponsive so CoolCam’s not going to get anywhere with them.

That will most likely change once ST has migrated to their new platform, but they haven’t even finished developing the hub connected devices section of it yet so that’s not going to happen any time soon.

SmartThings suppresses duplicate events by default and the DTH doesn’t override that so you’re only going to see battery events if the battery level changes.

Example:

1 Like

Kevin …

Thanks for the response. In the ST app, I do have the battery tile. It’s shown 72% from the install date. Recent events tab just shows dry/wet reports that listed when I tested the device. Nothing about battery. I installed a new battery, hit the button 1 time, LED flashed once so I’d assume the wake-up successful.

I went into my Hub management screen like you have shown in your post and I don’t have anything that even looks similar to your listing.

Here’s the config page: I’'ll admit that I’m pretty new to this system.

Name CoolCam Leak Detector
Label NEO Leak Detector
Type Dome Leak Sensor
Version Draft
Device Network Id 16
Status ONLINE
Hub Harpers Ferry Hub
Last Activity At 2018-04-02 8:19 AM EDT
Date Created 2018-03-31 2:50 PM EDT
Last Updated 2018-04-02 8:19 AM EDT
Data
MSR: 0258-0003-0085
Raw Description zw:S type:0701 mfr:0258 prod:0003 model:0085 ver:2.54 zwv:4.05 lib:06 cc:5E,86,72,5A,73,80,71,30,85,59,84,70 role:06 ff:8C05 ui:8C05
Current States
battery: 72 %
water: dry
checkInterval: 86520
lastCheckin: 04/02/2018 08:19:36 AM
Preferences (edit)
Name Type Value
audibleAlarmEnabled enum Enabled (Default)
batteryReportingInterval enum 3 Hours
debugOutput bool true
initialAlarmDuration enum 1 Minute (Default)
reminderAlarmDuration enum 5 Seconds (Default)
reminderAlarmInterval enum 1 Minute (Default)
totalAlarmDuration enum 2 Hours (Default)
wakeUpInterval enum 12 Hours (Default)
Execution Location Cloud
Events List Events
In Use By
Smart Home Monitor / Leaks
Leaks / Leaks/Alert with Sirens (Alert with Sirens)
Harpers Ferry Home (Simple Device Viewer)

My events page does show that the unit is talking back and updating but I don’t have any battery data.

I think I’ll just switch to the Zwave generic handler. Just hate having a device that is suppossed to do something and doesn’t.

Bill Dunn

How long have you had it connected? It may not have had a change in battery % yet to send to the hub.

Jimmy… Three days. I think I’m gonna take a different route. It’s not that battery level is a killer for me but would be helpful in knowing when to replace rather than waiting for a total failure to report leak.

Bill

it’s not unusual with some devices to go months without a battery level change.

Hello… I am really looking forward to using this, but once I add it to “My Device Handlers” I see no way of seeing it in the Smartthings App. This was last updated in April it seems… but not sure if I’m doing something wrong, or if maybe things don’t work anymore.

Any help would be appreciated.

After you’ve added it to “My Device Handlers” and published it, that handler should automatically get assigned to the device when you add the device through the mobile app.

If for some reason SmartThings doesn’t assign it the custom handler or you added the device before installing the handler then you can open the device in the IDE, click edit, and change the “Type” field to the custom handler which will be at the very bottom of the list.

Custom handlers don’t execute locally and the built-in handler most likely does so you’re probably better off only using my handler to change the settings. After you’ve saved the changes you’ll need to wake the device up and verify that it received the changes before changing the type back to the built-in handler.

How do you reset the device after an alarm? Plugged in the external sensor that triggered an alarm . Cleared alarm in shm. Woke device. Device still indicates wet .

Tapping the refresh tile and then waking the device up might refresh the state or taking the batteries out for 10 seconds, but that usually isn’t necessary.

If you don’t detach the sensor after it gets wet then it should automatically report when it’s dry.

If there was any sediment in the water that triggered it then you might need to use a paper towel or something to wipe the sensor off.

If all else fails, trigger it again. You can easily trigger it when it’s not in the cradle by using your fingers to push in the 3 contacts on the bottom of the device.

Tried the above. Nothing c)eared the alarm. I excluded and then added back in and alarm cleared.