[RELEASE] Device Monitor - Get Notified if Devices Stop Reporting

Great Thanks!

Updated, enabled Push and forced a Device Status and only received one notification.

Thank You for such a quick fix!

On a side not what is the contact book? I thought it went away and do not have it under my options anymore.

It is just an easy way to configure notifications in SmartThings. I’ve had it on my main account since it was released. I set up a second account a few months ago and think it has been setup with it as well.


2 Likes

Thanks Eric!

I do not have that, did some digging and there is a hack to get them back (allegedly) Tried that and am able to get to and add contacts in the IDE if I go via graph.api. but as soon as I try it via graph-eu01-euwest1.api. it gives me Access Denied and hence does not work. Getting really pissed that Samsung deem it necessary to make these types of segregations tbh. I also have a different layout to yours which may obviously all be connected. Would be great to be able to do this though but looks like we are **** out of luck on this side of the pond yet again lol

I don’t get hub offline alerts if I loose internet access.

It is possible that SmartThings changed what happens when the hub goes offline. I will take a look.

So I have been testing the hub offline notification and it is still working for me. I had setup a new instance of the SmartApp for testing with the following settings:

  • Check at this interval: 5 (this is important as the SmartApp will not do any checks if you don’t have this configured or you have the event check selected but your devices don’t send events).

  • Minimum time: 0

  • Send push notification: No

  • Phone number: my cell

  • Send notifications if a device comes back online: Yes

  • Send notification if hub goes offline: Yes

All of these settings may not be necessary, but I just wanted to provide something for you to compare to to see if something is misconfigured.

1 Like

I didn’t have the check at this interval 5 minutes enabled. I enabled it now but I only want an alert for all of my devices every 5 minutes, I want it once a day.

Here are my settings:

If you want your devices checked only once a day, but to be notified immediately if your hub goes offline, you will need to install the SmartApp twice. Once for your devices and once for the hub.

1 Like

Just did that!! Should I select use online / offline status if available?

Hmmm, it doesn’t really matter. The hub doesn’t have the online/offline status yet. I guess you can check it in case it does in the future.

1 Like

Just looking at your screens and more a question for @erocm1231, Eric, if Contacts are enabled and you select ‘Push’ Notifications as Kamran has will it still work? I have not tested but do believe there is an issue with Push/Hub Status/Contacts. Not sure if the issue still applies as it is handled with the app but am asking as in your previous reply you set Push to ‘No’ ?

Thanks!

I tried to install this app (via simulator) but when I click on any of the menu options, the app just spins and nothing is presented. My network is pretty simple - a couple of z-wave and zigbee devices and some ST-Anything parent/child devices. Would sure like to get this up and running and any help would be appreciated.

I just set push to No because I prefer SMS. You can choose push in the app as it is handled by the SmartApp.

@digadv Any reason you are installing in the simulator? Why not install it through the SmartThings phone app. I thought the Simulator was partially broken since SmartThings released the 2.0 hub.

@erocm1231 that did it. Since I’m fairly new to smartthings, I did not know there was an issue with the simulator installation. It has worked on all of the other apps I have running. Thank you for the tip.

I have a bunch of Homeseer dimmer switches. It appears the devices do not regularly report any status. I have device monitor alerting me on a 24 hour window and a bunch of them are listed as not reporting events. Is there a way to get these switches to more actively report status?

Do you know which device handler they are using? If the device supports Health Check then you can enable the Offline/Online feature of the app. Health Check will only show offline if the device doesn’t talk to the hub within the time that is custom set by the device handler. There is a ping() function in Health Check handlers that will cause SmartThings to “ping” the device a couple times before marking it offline.

Hello,

I am attempting to monitor my “Leak Gopher” which is an electric water valve. It’s provisioned on ST and all my other smart apps can see it, etc…however, this Smart App isn’t seeing it…Any idea how to get it to populate as a device to monitor? It’s an officially supported device with ST and it is even listed as device monitored with device health…thanks

1 Like

I answered your PM, but want to post here as well that I added the “valve” capability which should allow you to choose the Leak Gopher.

Edit: I also added the “sensor” and “actuator” capabilities which should include almost every device.

4 Likes

Thanks for the update Eric!