SmartThings Community

[RELEASE] Device Monitor - Get Notified if Devices Stop Reporting

smartapp_alerts
wellness_check

(Mark) #134

Thanks Kevin, noted!

I was only using the Chime to test really although it did become Unavailable yesterday… as it is easy to remove the batteries etc. but will make sure that I do no poll it often. Mine was currently set at 12 Hrs so changed to 3 Hrs.

Thanks!


(Mark) #135

Thanks Eric, the changed seems to have sorted it, I received a notification “Device not Reporting Events:HUE BULB (SPARE)” then upon restoring power I received “Devices Delayed: 0.04 - HUE BULB (SPARE)”

I know I am probably taking the pi*s now but will ask anyway…

Is is possible to amend these messages to reflect the actual issue/status; so "Device Unavailable:… " or preferably “Device Offline:…” and “Device Back Online:…” as opposed to the “not Reporting Events” and especially the "Devices Delayed message once it is available again as this message can be confusing with regards to the fact that it may not have actually gone “Unavailable” / Offline in the first place. Thank You!

Also I forgot to mention earlier but I am also getting duplicate Push Notifications for each event. I have tried to delete the App and start again several times but it did not help, I have not admittedly removed it from the IDE though so may try that. I think I have had duplicate messages since I started to use the app just prior to posting here.

Thanks again for all your efforts!!!

Have a good one!

Mark.


(Eric M) #136

So that shouldn’t happen unless you have not specified anything in the “How long before a device is considered inactive” field. Although I will probably end up changing the behavior, you should probably fill in that option for the app. There are some devices that do not support “ONLINE” vs “OFFLINE” and this setting will be used for those devices. If you had that option set for . . . lets say 12 hours, then you would have gotten an alert that the device is online instead of the delayed alert.

As for the duplicate notifications, that is something I have not seen and don’t really see how it is possible unless there are 2 instances of the app installed. Or something selected incorrectly in the “Contacts” portion of the app? I’ve gotten a lot of use out of this app over the last year and then some and have not seen this.


(Mark) #137

Thanks Eric,

Early hours here now but I changed the How long… option to 12 Hrs. Also did a quick test and turned off the Push Notification option in the App after which I still got notified but only once but need to try this again as I was actually in the app and went to the Device Status screen which kicked off the notification I think so this may not have solved it for me. Need to sleep but will try further settings over the next few days.

Thanks again!

EDIT: Just received further notifications as actually one of my door sensors dropped offline in the last few minutes which it informed me of so great! Can also confirm that disabling the Push Notification Option in the app solved the issue of receiving duplicate notifications, not sure if is is just my install or perhaps I am misunderstanding what that option actually does.

Have a great weekend!


(Dominick Barile) #138

Is there anyone that can explain how I can do this. I really would appreciate it. Thanks.


(Eric M) #139

Here is a great resource that should help you get started:


(Eric Luttmann) #140

So I just installed the app and was getting two notifications as well, and looking in the log I see it sending both a push notification and a text message. Looking at the code, it does the following check:

    if (phoneNumber != "0") {
        log.debug("Sending text message...")
        sendSms(phoneNumber, message)
    }

Checking the Device Monitor app settings, I see that phoneNumber (in my case) is set to “”, not “0”. I suspect calling sendSms with a empty value for the phone number parameter must default to just sending a push notification, although this is just a guess. However, if I set the phoneNumber to “0”, then I only see one push notification and the log only reports a single push notification was sent.

Just my 2 cents.


(Mark) #141

Thanks! At lease it is not just me going mad! lol

@erocm1231 would it be possible to put a toggle on SMS which then prompts for Phone Number? and take into account what @ejluttmann has discovered please, when you have some spare time of course. I am sure others must be experiencing the same issue. I understand there is an easy work around by dropping ‘0’ in there so happy to live with that or just leave Push unchecked of course.

Thanks chaps!


(Eric M) #142

I just made a change that should stop notifications if the phone number field is blank. I use the contact book in SmartThings so I can’t test it. Let me know if it doesn’t work.


(Mark) #143

Great Thanks!

Updated, enabled Push and forced a Device Status and only received one notification.

Thank You for such a quick fix!

On a side not what is the contact book? I thought it went away and do not have it under my options anymore.


(Eric M) #144

It is just an easy way to configure notifications in SmartThings. I’ve had it on my main account since it was released. I set up a second account a few months ago and think it has been setup with it as well.



(Mark) #145

Thanks Eric!

I do not have that, did some digging and there is a hack to get them back (allegedly) Tried that and am able to get to and add contacts in the IDE if I go via graph.api. but as soon as I try it via graph-eu01-euwest1.api. it gives me Access Denied and hence does not work. Getting really pissed that Samsung deem it necessary to make these types of segregations tbh. I also have a different layout to yours which may obviously all be connected. Would be great to be able to do this though but looks like we are **** out of luck on this side of the pond yet again lol


(MacTechGenius) #146

I don’t get hub offline alerts if I loose internet access.


(Eric M) #147

It is possible that SmartThings changed what happens when the hub goes offline. I will take a look.


(Eric M) #148

So I have been testing the hub offline notification and it is still working for me. I had setup a new instance of the SmartApp for testing with the following settings:

  • Check at this interval: 5 (this is important as the SmartApp will not do any checks if you don’t have this configured or you have the event check selected but your devices don’t send events).

  • Minimum time: 0

  • Send push notification: No

  • Phone number: my cell

  • Send notifications if a device comes back online: Yes

  • Send notification if hub goes offline: Yes

All of these settings may not be necessary, but I just wanted to provide something for you to compare to to see if something is misconfigured.


(MacTechGenius) #149

I didn’t have the check at this interval 5 minutes enabled. I enabled it now but I only want an alert for all of my devices every 5 minutes, I want it once a day.

Here are my settings:


(Eric M) #150

If you want your devices checked only once a day, but to be notified immediately if your hub goes offline, you will need to install the SmartApp twice. Once for your devices and once for the hub.


(MacTechGenius) #151

Just did that!! Should I select use online / offline status if available?


(Eric M) #152

Hmmm, it doesn’t really matter. The hub doesn’t have the online/offline status yet. I guess you can check it in case it does in the future.


(Mark) #153

Just looking at your screens and more a question for @erocm1231, Eric, if Contacts are enabled and you select ‘Push’ Notifications as Kamran has will it still work? I have not tested but do believe there is an issue with Push/Hub Status/Contacts. Not sure if the issue still applies as it is handled with the app but am asking as in your previous reply you set Push to ‘No’ ?

Thanks!