[RELEASE] Daikin WiFi Split System v1.4.1

You should update to latest version of the app, I think

I had the same problem.
Installed the old Classic app and configured it all there. Then it started working in the new app.

Hi, just wondering if anyone got it working with airbase controller BRP15B61 on a ducted system? No zoning required as I have manual switches for zone control for now.

Many thanks

Doesn’t work on Daikin Fit unitary split systems. The heading should read “mini-split” since traditional systems are called “split” systems (sometimes “full split” or “unitary split”).

Is this working in the new app? I’m thinking of buying the wifi adapter to try it out,. From what I read it looks like not all functions are supported in the new app. And also is this still being supported

Just a thing that I’ve noticed on the new app.If you select from FAN “on” it’s the equivalent of “silence”-or quiet mode.If you select “auto” it’s the auto mode from the split.

Hey @bendews, any chance you could port this to hubitat? Thank you so much

If you look on the Hubitat forms, someone already has, if that helps.

1 Like

I just migrated to the new app and I can only see “ON” button and the temperature setting. I tried deleting one airco (I have multiple) and creating it again , but no change. I have also latest DTH 1.4.1

Everything was working fine in the old app, that is why I hated moving to the new one.
So, what can I do now? I would try to avoid deleting all my Daikin devices since then I need to reprogram all related automations.

So, in new app will it be able to control fan speed, swing on/off, silent mode, select “Fan” as one of modes? :slight_smile:

I believe but could.be wrong but many of those settings are custom & that is being worked on for the new app.

My AC works perfectly for years until yesterday. Is anyone else experiencing the same ? Did I miss something ? If I did, please inform me.


I still cant get the functionality in the new app, I only have ON/OFF switch but no modes.
I deleted and reinstalled few times but no luck

Has anyone spoken to the developer of this program to see if any modifications need to be done for the new app. I’m thinking until custom capabilities can be added it’s only standard buttons available. @jkp am I correct,?

@bendews please help us out… :slight_smile:

Any updates of this is working correctly now?

@RBoy I dont believe their is anymore development on this app. Is their anyway you can incorporate something like this into your thermostat app?

1 Like

Its a pitty, would love to be able to control my Perfera again from Smartthings. I mean, there is some controls, but its not complete as it was on the classic app. I believe it just needs some small tweaks.

@MTC0407 & Friends - If it helps, I tried the device handler from @bendews with mods by Paul Smedley this morning (see elsewhere in this thread, and kudos to them both, thank you!) and it is working for most functions on my BRP15B61 (ducted) in Australia.

I’m no dev, but a straight copy of the modified code from Paul worked. I’m using the latest ST v3 hub and Android app.

Parameters used:

  • Local IP address = the local IP of my BRP15B61 controller (192.186.x.y)
  • Port = 80 (30500 didn’t work for me)
  • Refresh time = 5
  • Display Fahrenheit = false

What works:

  • Turning the AC on and off
  • Change from heat to cool etc
  • Set the temperature


  • No zone control (= a fairly big nuance) : )
  • The ST app displays two settable temperatures - a cooling temp and a heating temp. You have to set the cooling one when cooling is active, and the heating one when heating is active. Setting the wrong one at the wrong time pauses things for a minute, then kicks up a GUI error and sets both temps to the same value. On the Daikin wall controller unit itself, there’s only one temperature that you set. So it’s as if these parameters eventually update the same setting on the unit.
  • Fan control doesn’t seem to work, so fan speed stays wherever you last had it

Once it was set up in ST, Alexa picked up the new AC device almost immediately, so my Alexa can now control the AC within the limitations above.

Hope that’s helpful.


Today the A/C has updated to firmware 3.3.9.