[RELEASE] Daikin WiFi Split System v1.4.1

Is there some good automation for Daikin ? Please post it here what I should use ? Thank you !

@bendews I am getting “java.lang.NullPointerException: Cannot invoke method minus() on null object @line 286 (convertTemp)” when trying to send a command to mine. What information do you need from me?

If I uncheck use Fahrenheit the command goes through but I get a different error:
java.lang.NumberFormatException: For input string: “-” @line 514 (parse)

Hi, I have a unit with the BRP069A43 module updated to firmware 3.3.6.
When I send the power on or off commands in the log this error appears:

1997f185-711b-4701-8acd-1636279e736e 18:23:13: debug Executing hubaction on 192.168.40.109:80/aircon/get_control_info
1997f185-711b-4701-8acd-1636279e736e 18:23:13: Debug Delay for '500'
1997f185-711b-4701-8acd-1636279e736e 18:23:13: debug Executing hubaction on 192.168.40.109:80/aircon/get_sensor_info
1997f185-711b-4701-8acd-1636279e736e 18:23:13: Debug Refreshing
1997f185-711b-4701-8acd-1636279e736e 18:23:13: debug Executing hubaction on 192.168.40.109:80/aircon/get_sensor_info
1997f185-711b-4701-8acd-1636279e736e 18:23:13: Debug Refreshing
1997f185-711b-4701-8acd-1636279e736e 18:23:00: error java.lang.NullPointerException: Cannot invoke method isNumber () on null object @line 360 ​​(updateDaikinDevice)
1997f185-711b-4701-8acd-1636279e736e 18:23:00: debug SET-ing 25.0
1997f185-711b-4701-8acd-1636279e736e 18:23:00: debug null
1997f185-711b-4701-8acd-1636279e736e 18:23:00: debug Executing 'updateEvents' with null, null and true
1997f185-711b-4701-8acd-1636279e736e 18:23:00: Debug Executing 'on'
1997f185-711b-4701-8acd-1636279e736e 18:23:00: Debug Executing 'on'
 18:22:53: info Waiting on events ...

I use STSC.

Hi Guys,
i have literally just got my smartthings hub, followed the instructions and set this up.
So this is likely to be a very noob question
The setup seemed to work fine…However…

On the SmartThings app on my android phone, when i go to the device i only seem to have one setting and that is a button for on or off. I dont get the interface shown in this post.

Am i using the wrong app, or is there a way or need to add the device to ensure that full functionality is included?

Thanks in advance for your help!

cheers
Andrew

…and answered my own question as i read up…
I need to use the classic app.

thanks :slight_smile:

Hi!

If you put the latest version of DHT you should be able to control your AC also from the new Connect App!

It should look like this:

It has less functions, but it works very well and for simple things like setting the temperature it’s just perfect!

1 Like

I am trying to add a new device, but Daikin Wifi Split System is not an option from the dropdown.

Has this been removed?

Anyone that can help?

Have you installed and published Device Handler in SmartThings IDE ?

Yes, but still no Daikin Wifi Split System. Lot of other stuff. :frowning:

I am looking to buy a hub for Xmas. Is their a device handler for Daikin Airbase BRP15B61?

I purchased it for my Australian ducted system https://www.penair.com.au/product/daikin-airbase-brp15b61/

I am excited at the awesome work you have done integrating Daikin ducted aircon into smartthings. I have just installed BRP15B61 Daikin Airbase Adapter for ducted air conditioning units in Australia.

Are you please able to please help with creating a device handler code to work with BRP15B61. They have it working on openhab. See link https://forums.whirlpool.net.au/archive/2768285

Hi @Trial_Master and @rybackisback, going by the link you have posted it should work with this integration with no modification required. What happens when you try using it with this integration?

EDIT: Sorry - I didn’t see that the BRP15B61 is a ducted system. It still looks very similar, would just need to add zone support. I would be interested to see what happens if you try utilising this device handler and seeing if it displays temperature and sets modes etc. correctly.

Hello bendews, as i mentioned i was looking to buy a hub (I have ordered one and waiting for it to arrive). There has been some movement on this, a kind fella in South Australia has modified the code http://smedley.id.au/tmp/daikin-wifi-airbase.groovy

I am happy to test both when i receive my hub. For me personally my zones are a third party product that the Daikin does not control or see. My personal requirements are turn on/off, switch mode and change temp.

Someone has tested the modified device handler (above) and it appears they have some issues https://forums.whirlpool.net.au/thread/3n45mp03?p=20

Hi @bendews, I tried using your utility with the IP address of my unit and port 80 and 30050 (this is the port I get when using the following query http://my ac unit ip address/skyfi/common/basic_info?lpw=" my out of home password). It do not get any response - it does not display the set temperature, set modes or any of the info on my controller.

Are you please able to help?
PS: I am able to control the unit via Daikin Airbase app

@Trial_Master, I think this link from @Abs https://forums.whirlpool.net.au/thread/3n45mp03?p=20 is talking about the airbase app and not the device handler code for smartthings.

Thanks @rybackisback & @Trial_Master, I’ll bring the discussion over to the Whirlpool thread, the API is very similar but as it’s not a split system and I don’t have one to test, would need support from someone who does. Also don’t want to duplicate effort if Paul is willing to continue modifying the DTH to get it all working. :smile:

1 Like

Has anyone tried this with the module BRP072A43? It’s only an incremented number at the end, A42 to A43, so I wonder if it’s just a slightly newer version, but it’s all I can find for my FTXS-LVJU unit. I haven’t ordered it yet, but would be interested in anyone’s experience with it and SmartThings (as the “Daikin Comfort Control” app has the worst reviews, I don’t want to install the module just for that).

Thanks!

I have this exact setup. The Ftxs12 with the BRP072A43 and it works great.

1 Like

Oh that’s fantastic! Can you please tell me, how much control do you have and what’s reported? Any chance you can change fan speeds, or toggle the comfort airflow or Intelligent Eye operation or louvers, and is energy usage of any sort reported?

Thanks so much!

@andschwa you will have the full capability as shown in the original post :slight_smile: Be wary that some older models do not support fan controls (and are not supported using the official app either). Fan controls include direction, speed/auto & “3D” (I.E direction sweep).

Intelligent eye toggle is not supported, as far as I know nobody has stumbled across the API binding for that and is also not supported through the app.

Hi @bendews with the help of Paul Smedley your device handler has been adapted to work with Daikin BRP15B61. Everything works but for some reason smartthings (old and new app) does not display any inside temp - it reads 0.

Where applicable the code has been changed to work with BRP15B61 as below:
replace ("/aircon/get_sensor_info") with ("/skyfi/aircon/get_sensor_info")

Ive tried http://xxx.xxx.x.xx/skyfi/aircon/get_sensor_info? and i get a response ret=OK,err=0,htemp=29,otemp=-

Daikin airbase app also displays the temp.

Are you please able to help?