SmartThings Community

[RELEASE] Daikin WiFi Split System v1.4.1

devicetype
thermostat
hubv2
dth_hvac

(Ben Dews) #61

I think it would be incredibly unlikely it would work without specific modifications :slight_smile: I can’t say for sure however as I have not seen that thermostat before.


(Artis Pagsanjan) #62

Hi @bendews,
Is it possible to automatically change the thermostat mode (cool, fan, heat) at a certain time or after certain period? Perhaps you already worked on this?

thank you for your continued efforts on this!.. much appreciated.


(Ben Dews) #63

Hey Artis,

Heat/Cool/Auto modes are part of the regular thermostat device type, which means you can use any of the available thermostat SmartApps to control those modes (look within the Smartthings App under “Climate Control” and this forum for examples).

The Dry, Fan-Only and Silent modes are custom functions, so the only way to automate them is via one of the more advanced SmartApps like WebCoRE.

Hope that answers your question!


(Ivan Maroli) #64

Hi @bendews, I tried your device handler with BRP069A41 module: I can add a device, and on IDE I can see the data gathered by the unit (temp, currmode…) but when I access on SmartThings app I can see the device added but not working, clicking on it I get “Impossible to connect to the device. Check the device and retry”. Since data are gathered I think that IP is correct, and also the other parameters… Not sure I did everything in the right way (I’m pretty new in SmartThings) but I don’t know what to try.

Thanks!


(bobbygraph@gmail.com) #65

Hi,

I’m about to acquire a Daikin air conditioner and it comes with the BRP072A43 adapter.

Is this a new version of the A42 or is it completely something else? do you think it’s compatible?

Another possible option, is the ENVi thermostat compatible?

Thank you


(Ben Dews) #66

Hi Bobby,

Based on what I can see in this Home-Assistant thread the BRP072A43 should be compatible via the same API, depending on firmware version (latest firmware seems to be best).

The Envi thermostat is not compatible :slight_smile:


(David) #67

I am currently able to turn off the AC with Google Home and Alexa with voice commands.

But is there a way to turn on the AC via voice commands?


(Ben Dews) #68

Hi @DLY,

Unfortunately seems to be a limitation with both assistants (or perhaps the way SmartThings integrates with them) but you need to specify a function, I.E “Hey Google, set the Bedroom A/C to (Cool/Auto/Heat) Mode”.

Hope that helps!


(David) #69

Thank you so much! It’s precisely what I want!


(Ben Dews) #70

Great to hear! :smiley:


(Dominick Barile) #71

The wifi adapter that ends with 42, is that a European model? The model.i came across ends with 43.


(Steven Kearney) #72

Hi

I’ve been using this for several months and it’s been working great, until I stupidly accepted a firmware update to the daikin controller, it’s now on version 1.2.51, and the handler is broken :weary:

I’ve looked at the code and tried to debug as best I can, I am able to call the daikin over http get requests and it works ok, but when called from within smartthings, nothing, it’s as if the response is empty.

Any ideas on where to look, or even how to roll back the daikin firmware?

Thanks


(Ionut Savu) #73

I’m having the same issue as Steven_Kearney unfortunately. Hope the developer made the same mistake in updating the firmware as we did and he takes a look at the code :slight_smile:


(Ben Dews) #74

It looks like the firmware change has been discussed here: https://community.athom.com/t/daikin-ai/158/16

I’ll have a look in to it and see what changes are required, fingers crossed it’s not broken for good :slight_smile: My adapters don’t have any available updates!


(Ionut Savu) #75

Thanks! :slight_smile: Hope you manage to fix it!


(Steven Kearney) #76

Let me know if I can do anything to help


#77

Unfortunately this does not work with Pioneer Minisplits. I can at least control it through Google Home.


#78

I am coming to this device type for the first time and am a newbie at all this. I had already upgraded my controllers to the 1.2.51 firmware…which I guess means the handler is broken for me. @Steven_Kearney – what is the behavior of the handler now vs. when it was working for you. I am wondering if I’ve even set it up correctly. What failing behavior should I be witnessing?

Thanks!


(Ionut Savu) #79

Simply put it doesn’t do anything anymore: it does not reflect any changes of the AC that might have been done through the daikin app or the remote and whatever you do to it in smartthings(raise temp., lower fan, change mode, etc) it doesn’t send any commands to the AC, it does nothing


#82

For all people having issues with Daikin B-type wifi dongle, replace:

private apiGet(def apiCommand) {
log.debug "Executing hubaction on " + getHostAddress() + apiCommand
sendEvent(name: “hubactionMode”, value: “local”)

def hubAction = new physicalgraph.device.HubAction(
    method: "GET",
    path: apiCommand,
    headers: [HOST:getHostAddress()]
)

return hubAction

by:

private apiGet(def apiCommand) {
log.debug "Executing hubaction on " + getHostAddress() + apiCommand
sendEvent(name: “hubactionMode”, value: “local”)

def hubAction = new physicalgraph.device.HubAction(
    method: "GET",
    path: apiCommand,
    headers: [Host: getHostAddress()]
)

return hubAction