SmartThings Community

[RELEASE] Daikin WiFi Split System v1.4.1

devicetype
thermostat
hubv2
dth_hvac

(Robertino Hermansson) #21

@bendews Refresh button doesn’t seem to help either no. I can share some logs if you want. @Danne_85 if you use the Daikin Controller App it has the IP information you need.


(Daniel Åslund) #22

Thx! i´ll have a look on that :slight_smile:


(Daniel Åslund) #23

Mayby im dumb or just a noob, but i can´t find “Daikin Wifi split system” in the Type dropdown menu, is there anything else i can use in the dropdown?


(Robertino Hermansson) #24

Have you installed the Device handler correctly so it is published as well?


(Daniel Åslund) #25


I´m creating the device now but in the device list there is no Daikin wifi split…I clicked on my devices - create new device. maybe im att the wrong place. Sorry for dumb questions but im really new to this.


(Davor Dooley) #26

This is much better now! Temperature is updated and visible in Daikin app with current mode. What I still don’t see is changes made through Daikin app or remote controller.


(Daniel Åslund) #27

Now i understand why i can´t find it, i have to copy the device handler first of course :stuck_out_tongue:


(Daniel Åslund) #28

It works! Awsome!

I have a question, my inside temp and outside temp seems to be stucked on 20 degrees. I have tried to update but it doesn´t change.
If I look in to the Daikin app the inside temp is 22 degrees and the outside temp is 0 degrees.


(Davor Dooley) #29

Hi again!

I see false reading for outside temperature, in app it is unavailable. Maybe it will be ok when it updates in app, too.
Also, would it be possible to change status color to grey when device is off, red for heating, yellow auto mode etc…!
Might be more user friendly.


(D Gjorgjievski) #30

Hi @bendews

Just an update, I have 3 x BRP069A42 installed on 3 FVXS 35F standing units and 6 x BRP069A43 installed on FTXS20G wall mounted units (the last ones are not officially supported by Daikin but I can assure you they work :slight_smile: ) with firmware revision 1.2.48.
As a matter of fact both models use WiFi module with a model number BPR069B41, so for me it is not clear where the difference in the model is except that the model ending with 43 had some additional printed circuit boards that were actually not necessary for my wall models.

DTH works but with issues as explained above:
-outside temperature is frozen at 20°C

  • there is no update when somebody changes the settings via remote control or daikin app
  • personally I find polling once every 5 minutes too long

Below are result http poll on the unit

/common/basic_info
ret=OK,type=aircon,reg=eu,dst=1,ver=1_2_48,rev=7A61A5D,pow=1,err=0,location=0,name … (i deleted the sensitive data)

/aircon/get_sensor_info
ret=OK,htemp=20.5,hhum=-,otemp=2.5,err=0,cmpfreq=39

/aircon/get_control_info
ret=OK,pow=1,mode=4,adv=,stemp=18.0,shum=0,dt1=25.0,dt2=M,dt3=25.0,dt4=18.0,dt5=18.0,dt7=25.0,dh1=AUTO,dh2=50,dh3=0,dh4=0,dh5=0,dh7=AUTO,dhh=50,b_mode=4,b_stemp=18.0,b_shum=0,alert=255,f_rate=A,f_dir=0,b_f_rate=A,b_f_dir=0,dfr1=5,dfr2=5,dfr3=5,dfr4=A,dfr5=A,dfr6=5,dfr7=5,dfrh=5,dfd1=0,dfd2=0,dfd3=0,dfd4=0,dfd5=0,dfd6=0,dfd7=0,dfdh=0


(Artis Pagsanjan) #31

@bendews, thanks much!.. you are correct, i just have to use the correct command phrase, it is working now.
As v1.2, the temp slider & outside temp are now working like a charm!.. great works there!!!..


(D Gjorgjievski) #32

Hi

I just realised one more issue. I made routine to switch off one unit that is previously running in heating mode and i notice that the dth changes the mode to cool so when the unit was restated in the morning i got a conflict with other units on same outside unit. Is it possible to keep the operation mode?

Log when the off routine is executed

debug Delay for '500’
dfe39535-26b5-4c6a-b2c8-dcc073738643 06:20:43: debug Executing hubaction on 192.168.1.242:80/aircon/get_control_info
dfe39535-26b5-4c6a-b2c8-dcc073738643 06:20:43: debug Delay for '500’
dfe39535-26b5-4c6a-b2c8-dcc073738643 06:20:43: debug Executing hubaction on 192.168.1.242:80/aircon/set_control_info?pow=0&mode=3&stemp=20.0&f_rate=A&f_dir=3&shum=0
dfe39535-26b5-4c6a-b2c8-dcc073738643 06:20:43: debug 3

Log when the unit is started

debug Executing hubaction on 192.168.1.242:80/aircon/get_control_info
dfe39535-26b5-4c6a-b2c8-dcc073738643 06:27:59: debug Delay for '500’
dfe39535-26b5-4c6a-b2c8-dcc073738643 06:27:59: debug Executing hubaction on 192.168.1.242:80/aircon/set_control_info?pow=1&mode=3&stemp=20.0&f_rate=A&f_dir=3&shum=0
dfe39535-26b5-4c6a-b2c8-dcc073738643 06:27:59:


(Davor Dooley) #33

Hi!

I have created webcore piston that turns on A/C into dry mode when some conditions are met. Unit starts as configured, but it doens’t turn off after desired time (1 minute).

SmartThings live log:
129be529-125c-4017-aeb2-8f716b8023e0 10:33:59: debug Executing hubaction on 192.168.178.55:80/aircon/get_control_info
129be529-125c-4017-aeb2-8f716b8023e0 10:33:59: debug Delay for ‘500’
129be529-125c-4017-aeb2-8f716b8023e0 10:33:59: debug Executing hubaction on 192.168.178.55:80/aircon/get_sensor_info
129be529-125c-4017-aeb2-8f716b8023e0 10:33:59: debug Refreshing
129be529-125c-4017-aeb2-8f716b8023e0 10:33:00: debug Executing hubaction on 192.168.178.55:80/aircon/get_sensor_info
129be529-125c-4017-aeb2-8f716b8023e0 10:33:00: debug Delay for ‘500’
129be529-125c-4017-aeb2-8f716b8023e0 10:33:00: debug Executing hubaction on 192.168.178.55:80/aircon/get_control_info
129be529-125c-4017-aeb2-8f716b8023e0 10:33:00: debug Delay for ‘500’
129be529-125c-4017-aeb2-8f716b8023e0 10:33:00: debug Executing hubaction on 192.168.178.55:80/aircon/set_control_info?pow=1&mode=2&stemp=26&f_rate=4&f_dir=0&shum=0
129be529-125c-4017-aeb2-8f716b8023e0 10:33:00: debug 0
129be529-125c-4017-aeb2-8f716b8023e0 10:32:59: debug Executing ‘updateEvents’ with dry, null and true
129be529-125c-4017-aeb2-8f716b8023e0 10:32:59: debug Executing ‘dry’

Piston:

Piston trace:
08. 01. 2018. 10:33:59 +101ms
+1ms ╔Received event [Stan BP1].time = 1515404040972 with a delay of -1871ms
+162ms ║RunTime Analysis CS > 17ms > PS > 58ms > PE > 87ms > CE
+165ms ║Runtime (38280 bytes) successfully initialized in 58ms (v0.2.101.20171227) (162ms)
+166ms ║╔Execution stage started
+312ms ║║Executed physical command [Daikin_AC_Living_Room].refresh() (132ms)
+313ms ║║Executed [Daikin_AC_Living_Room].refresh (133ms)
+341ms ║║Executed virtual command [Daikin_AC_Living_Room, Klima].sendPushNotification (22ms)
+381ms ║║Executed physical command [Klima].offPhysical() (38ms)
+382ms ║║Executed [Klima].offPhysical (40ms)
+385ms ║╚Execution stage complete. (220ms)
+387ms ║Setting up scheduled job for Tue, Jan 9 2018 @ 10:33:00 AM CET (in 86340.513s)
+394ms ╚Event processed successfully (394ms)


(Davor Dooley) #34

I have canged this piston and now using “Turn off”, so it works now. :slight_smile:


(Ben Dews) #35

Hi Davor,
You need to use the Switch type on/off functions. onPhysical() and offPhysical() look like custom functions :slight_smile:

See below:


(Davor Dooley) #36

That’s correct! It’s amazing how much you did in just a few days!


(Daniel Åslund) #37

Is there i way i Can get outside and insider temp to workshop for now it’s just stucken at 20 degrees.
Anyway a Great jobbar!


(D Gjorgjievski) #38

Did anyone else experience the same issue when switching off airco that was in heating mode via smart app and switching it back on via smart app it changes the mode to cool?

For example I made smart app to switch off a unt if the room window is open and switch it back on when it is closed.

I looked in the code yesterday and I tried to modify the default settings (everywhere where it was set to cool I changed it to heat or where the default mode was set to 3 I changed it to 4), but still no success


(Ben Dews) #39

HI @D_Gjorgjievski, I am looking in to this. I was not able to replicate the issue to start with but I can now, so a fix is coming.

Apologies for it defaulting to cool as well, don’t have to use the heat mode much in Australia :smile: Future versions will also remove as many default values and temperatures as possible to prevent confusion.


(D Gjorgjievski) #40

Thanks,
I can understand that :slight_smile:.
As I hear on the news the temperature there is about 50 degrees Celsius warmer than here.