[RELEASE] D-Link Camera Manager (Connect) [Requires Classic App]

That is very strange, not sure how to fix that. The streaming video is direct from the camera to the phone, it doesn’t hit the hub at all. Sounds like something is preventing your phone from hitting the external IP while on the local network. Can you get the stream working using your external IP in VLC?

I appreciate the help. However I can’t get to the advanced settings. No matter what browser I try it keeps blocking me. Something about a Certificate. Could I possibly send you some screenshots?
Thanks

That’s beyond me, sounds like something you need to go to D-Link support about.

Could be you are trying to access via https and you don’t have a valid security certificate. Can you either go to advanced and accept the invalid certificate (Continue anyways) or try using http instead of https?

Is there a way when a camera detects a PIR Motion event that it can trigger a motion event in ST?

Unfortunately not, this is currently a one way integration. SmartThings can send commands to the camera but not the other way around.

:frowning: So I guess the only way would be to set up email notification within the camera and use IFTTT.com, to trigger a virtual motion sensor?

Correct but there will be a significant delay.

Could you share the config for 5222L, I was not able to get it working

Thanks

Did you manage to get the DCS-936L working?

Unfortunately, no.

1 Like

@blebson is it possible to get support? The 936L is a perfect fit for me and has good pricing in my region, would love if I could integrate it :slight_smile: I could assist in any way I can (if/when I get it)

There is probably a way to get it to work but I don’t have one to test. If you get one you can try installing it with the DCS-934L or DCS-942L DTH and see if it works or not.

Hi. I’ve tried downloading the manager but it won’t show up in my Smart apps. Ive followed the install to these letter. It says it’s published ok but just doesn’t appear. If I try to connect manually via ST it won’t even find my 5222. Has anyone managed to get any d-link cameras working in the UK with ST?

Are you sure you installed the SmartApps and all Device Handlers in the proper IDE?

Hi Ben. Yes. All done exactly as per instructions. I only have one account as well. What do you think I could be doing wrong.

Can someone please help me to get this working? I understand the instructions but things don’t match when I try. I updated smartapps and device handler but nothing. Please?!

When I use the DDNS service I can see the image, but I am not able to use the buttons. It shows a problem when try to parse the domain to a numeric value (I think). I received this error:
“java.lang.NumberFormatException: For input string: “blancofran” @ line 542”
(“blancofran” is the first part of my sub domain).

The line 542 is this:

String hex = ipAddress.tokenize( '.' ).collect {  String.format( '%02x', it.toInteger() ) }.join()

Have you any advice to avoid this error and be able to use the buttons?

Note: When I configured and used the camera with internal IP address from my local network, I was able to use all buttons.

Thanks in advance

Buttons only use internal IP addresses.

Both 935L and 934L seem to work for the 936L. Not sure what difference I should see.