[RELEASE] D-Link Camera Manager (Connect) [Requires Classic App]

I’ve installed this app but can’t use it, it seems. If i go into smart apps, it lets me configure it. I can add the camera to my “things” but I only get the screen, a reload and reboot button. Is there something else I need to do?

It sounds like you installed the actual default D-Link integration, not my custom devicetype. You should install mine by going to the ‘SmartApps’ tab in the marketplace and going down to ‘My Apps’

I am confident that is not correct. I have previously installed the D-Link integration Smart-app. Do I need to remove this before installing/configuring yours?

See screenies of current setup:

I agree. Anyway, I went through your code for the 5222 and modified the NightVision settings to perform the Privacy mode toggle instead and it works great. What’s really FUNNY about DLink is that on the newer model camera (5029L), the /config/led.cgi is available, but the /config/privacy.cgi is not. Who cares if I can turn the LED on an off. I even took a shot at /config/privacy%20control.cgi and still got nothing. Anyway, what I really want DLink to do is put the Privacy mode CGI on the newer model camera too. Come on DLINK!

1 Like

Do you have a device named ‘chicken coop’ in your device list?

##Post Update:

All of the D-Link cameras supported by this SmartApp are now directly compatible with CoRE!

1 Like

I had my own created connection to the camera using the d-link smartapp which had the same name. I have since removed the camera and then added the info in this app. I got the same result. I then tried to install the camera first, then set up your app and I get the same result. Am I looking in the wrong place to access this?

The camera created by this SmartApp should be named “Chicken Coop” and will show up in your ‘Things’ view.


Is there any way I can set my camera to store the recordings on my local server?

I notice that there is an optional field for file store, but what variables am I able to use? I would need to insert username & password surely to access file store on the server?


I’ve successfully installed a few custom device types & smartapps by the copy/paste method. This is my first attempt at using the Github method. I’m signed up for Github, but I can’t figure out this first step.

Any help would be appreciated, maybe just another link that I could study.

1 Like

That depends what camera you are using. Also, where are you seeing the file store variable?

Seem to be having a problem getting a video stream from my DCS 942l camera. Logs show Start() but nothing after that.
All the tiles are working and updating in the log. Using the camera ip and port 80. also using the same password and username as the camera. cant get any video with rtsp://USERNAME:PASSWORD@ in VLC either. Any ideas ?

Your port should be 554 for RTSP cameras (like the 942L)

Thanks for the heads up. Working now in VLC . So the camera port should be 80 and the video port should be 544 in your smartapp setup ?

Correct, Camera port 80, Video port 554

I’m pretty sure I did the first 11 steps correctly to get this running, but when I get to step 14:

Now, go into the SmartThings App on your phone/tablet
Go to the ‘Marketplace’ tab in the bottom right.
14. Go to the ‘SmartApps’ tab and select ‘My Apps’

I don’t see a “My Apps” option. Anybody know what I did wrong?

it’s at the bottom of the smartapp list, If you don’t see it then you probably didn’t select the “publish for me” button in the bottom right of the github repo page


I am using the DCS 942L. I see the option when I go to edit the D-Link Camera Manager (Connect) smart app under resources (optional)


Those resources are for something completely different. There currently isn’t a way with this SmartApp to store images taken on the camera in anything other than the SmartThings Cloud. Video recordings taken by the camera will automatically be stored on the Camera’s SD card.