SmartThings Community

[RELEASE] D-Link Camera Manager (Connect) - Add your D-Link IP Cameras to SmartThings! Video Streaming, Image Capture, Motion Detection and more

smartapp_cameras
dlink
dth_cameras

(Ben Lebson) #447

You need to create an event under ‘RECORDING’ that always records when ‘on’ to the SD card.


(rwelsh09) #448

Instead of having it recording always, is there a way to set it up to record on intrusions? Via door sensors or motion sensors in camera or not built into camera.


(Ben Lebson) #449

That’s what toggling the button will do it turns on or off that recording event. You just need it to be set to record always when the recording event is turned on. There’s a ‘Smart Security Camera’ SmartApp listed in the first post that will allow you to trigger it based on motion and door sensors.


(rwelsh09) #450

I’ll check out that app after I get this toggle to work. Thanks

So this is what I did:


Didn’t work, the log is identical except this:
requestId:53249057-2ce9-4d12-afc6-e8f25944bb40,


(Benji) #451

All, I’m new to Smartthings and am a complete idiot when it comes to anything overly technical.

I just purchased a Dlink 2630 L and am trying to integrate it into my Smartthings network. I’ve read through the numerous posts about the custom app and frankly just don’t have the technical background to figure out how to install the app on my system.

Can someone with a lot of patience walk this technical idiot through how to do this?

Assuming I can install the app, are there any benefits to viewing the camera feed via Smartthings versus the free D-Link app?

Many thanks.


(Juan Carlos Marin) #452

There is no real benefit for just viewing the camera feed from SmartThings other than having a single app to do it, the reality is that the D-Link App will do a better Job for this

The real benefit of integrating the camera into ST is that you can then control certain aspects of the camera through ST and related to other events happening within the ST environment (like taking a picture when a motion sensor triggers, or moving the camera to that area on a P&T Camera)

For a basic walk-though of how to install a custom App or Device in the IDE take a look at this post:
https://community.smartthings.com/t/faq-an-overview-of-using-custom-code-in-smartthings/16772


(Ben Lebson) #453

Follow the instructions on the first post. You can also refer to the following post for instructions on how to add code to SmartThings using the GitHub integration:


(Robert cunningham) #454

Do I have to add all the camera devices or can I just add the one type I have ?


(rwelsh09) #455

When there is an intrusion alert SmartThings says the camera is unavailable, they worked with the native D-Link app. Does this have anything to do with toggle that’s not working, for me? Or something else? Thank you.


(Ben Lebson) #456

If the toggles are not working then the camera is not properly set up. Also, if you set the camera up using the local IP for the video IP then you’ll only be able to view it while connected to your local network. If your want to be able to view it externally you need to use the external IP and port forward the RTSP port for the video IP and video port.


(Ben Lebson) #457

You only have to add the devices you want to use. Be sure to add all the SmartApps though.


(Benji) #458

Thank you so much!!!


(Benji) #459

Ben, thank you! I think I did it. Now if I can get My Apps to show up in Marketplace I should be set…


(Ben Lebson) #460

Glad to hear it. If you still aren’t able to get the ‘my apps’ to show up under SmartApps in the marketplace, open a ticket with SmartThings support.


(Benji) #461

Resolved… Apparently my ST account is not tied to the API server but to a new server NA02.


(Benji) #462

Ok…The app is successfully in ST.
Unfortunately, I’m not seeing any video.
I have an Ipone 6 with the latest update.
I’m trying to install the Dlink DCS-2630L which is not an option. So, I started with selecting 522L and then moved up the list. None of them seem to work.
I’m using the same IP address for both video and camera.
I’m using my dlink admin user name and password.
My video port is set to 554 while my camera port is 80
Here’s my network settings from dlink:


(Ben Lebson) #463

You should see the DCS-2630L under the ‘New Fixed D-Link Cameras’ menu.

All of the settings you’ve listed seem correct. Try using the proper DTH and see if it works for you.


(Benji) #464

Ben, found the 2630L on my second camera. Still wasn’t showing as an option for my first camera install. I deleted camera #1 and reinstalled. Both cameras are set to 2630L and I’m not getting video. When I open the camera up in ST I have black screen with a play button. When I click on the play button it tries to connect but is unsuccessful.

Any idea what the problem could be?

Also what is DTH?

What is Toggle?

Sorry to be a pain…


(Ben Lebson) #465

No worries. Are you on the same local network on your phone and camera while testing? Also, if you click on the button that looks like a camera lense do you have a picture show up?


(Benji) #466

No, I’m at work. But it wasn’t working last night while on my home network where the cameras are installed. Will try the picture.