SmartThings Community

[Release] [Closed] Google Assistant Relay V1 - Google Home Audio Notifications!

I actually removed the SmartApp and DTH from V2 and stopped supporting in halfway through V1.
My groovy knowledge is poor and I didn’t have the time to maintain it.

If anyone fancies writing a SA & DTH to open it up to SmartThings without WebCore then I’m happy to accept a pull request

1 Like

I updated from wednesday clone and now I get this error when trying to fire the server:

 pi@xpsRaspi:~/assrelay2/assistant-relay $ npm run start

> assistant-relay@2.0.0 start /home/pi/assrelay2/assistant-relay
> node server/app.js

TypeError: Cannot set property 'kevin' of undefined
    at /home/pi/assrelay2/assistant-relay/server/assistant.js:33:37
    at replenish (/home/pi/assrelay2/assistant-relay/node_modules/async/dist/async.js:1011:17)
    at /home/pi/assrelay2/assistant-relay/node_modules/async/dist/async.js:1016:9
    at Object.eachOfLimit (/home/pi/assrelay2/assistant-relay/node_modules/async/dist/async.js:1041:24)
    at Promise (/home/pi/assrelay2/assistant-relay/server/assistant.js:30:13)
    at new Promise (<anonymous>)
    at setupAssistant (/home/pi/assrelay2/assistant-relay/server/assistant.js:28:12)
    at configureUsers.then (/home/pi/assrelay2/assistant-relay/server/app.js:27:10)
    at <anonymous>
    at process._tickCallback (internal/process/next_tick.js:188:7)

Hmmm odd.

What version of node are you running?
Can you show me whats in your configurations/config.json file?

Broadcasts work fine for me and i have night mode enabled.

What firmware version are you on?

Well, I am on a Home Mini and the firmware is 124602. But did broadcast just stop for you suddenly? This might be a silly question but you do have the max night volume above zero, correct? And you don’t have Do Not Disturb enabled for Night Mode? That will prevent all broadcasts.

node is 5.5.1

config file is :

{
  "language": "fr-CA",
  "users": {
    "kevin": {
      "keyFilePath": "/home/pi/assrelay2/assistant-relay/server/configurations/secrets/kevin.json",
      "savedTokensPath": "/home/pi/assrelay2/assistant-relay/server/configurations/tokens/kevin-tokens.json"
    }
  },
  "port": "3001"
}

I’'m running on port 3001 cause port 3000 is used for v1 which is still in use.

I have tried lots of combinations of settings even up to factory resetting a mini and full home. The only thing that makes a difference is disabling night mode.

I even tried making the current time in and out of the night mode window, but no change.

I believe it’s a firmware bug in version 1.34.130671 and have raised it with Google along with sending feedback.

Surprisingly sending feedback via Google Home is Google’s preferred way of been notified of issues.

Did you edit the config file yourself?
It’s missing the assistants field:

1 Like

Thanks, that fixed it!

I’m clueless as to what happened. It might be related to how early I cloned your repo… Or maybe I copied the old config from v1 without thinking too much. Is the language parameter still relevant? (my minis are in Canadian French).

What is the simple rate parameter for?

Yep the language is still relevant.

The sample rate is for something I’m trying to get working in terms of using pre-recorded voice to broadcast messages

1 Like

Good, I continue testing it out and reporting what I find.

Browsing http://ip:port return the following, is it to be expected atm?

Cannot GET /

Yep, it’ll only accept POST requests at the moment

1 Like

I would love to know this too

Doubtful it will work. It needs a Assistant SDK build and I dont think there is one for Synology

I just need to know why is it so hard to make a custom command or broadcast.
I still use the old method and it works.
By using webcore and stating that Google assistant relay should do
Custom broadcast.
I have never used the post method.
But how do I do this and what is that long :3000 address I use any way.
Is there a wiki.

Also does custom command work reliabl
Like tell me the weather(is there preset commands to use?)

Hello, i have problem with every versions. I had installed on raspberry pi 2 an ubuntu server 16.04. I using the last LTS version of node server and npm. I had configured all parts correctly. When i start the assistant-relay the program start correctly but i not hear any notification from google home.
I had tried to send some notification using web core with POST request but nothing. I have done more times the Oauth2 File and project but never change. I see on Api Dashboard on google site all the request and for any request i see an error on the graph. But i can’t see the type or description of errors.

Google Home is on the same subnet of nodejs server, i have disable ipv6 on router i have a fritxbox, but nothing change. I can see only the request on APi dashboard and error field set with the same number on Google API Assistant row.

I have set the language in config.json file it-IT for italian language.

Have you some ideas?
thz and bye.

I believe that the Google Assistant SDK requires a 64 bit platform to run on. Therefore, you will need a minimum of a Raspberry Pi 3 or 3B+ to run assistant-relay successfully.

At least this is what others have stated previously in this thread. I have not tried running assistant-relay on a 32 bit RPi.

1 Like

Thz. I will try using a 64 bit version, If the problem is the 32-bit enviroment I will buy an PI 3.

So after working steadily for ~9 days today Assistant Relay stopped broadcasting again for me. IPv6 still turned off for the whole LAN. Turning off Night Mode seems to have brought it back… Even though I have NOT at any point had the “Do not disturb” option of Night Mode turned off and my GHM was failing to broadcast while outside the hours I had set for Night Mode.

I am on GHM firmware 1.34.130671.

Seems like a bug in Google’s stuff, not Assistant Relay, but still thought I’d post about it in case anyone else encounters similar symptoms.