SmartThings Community

[Release] [Closed] Google Assistant Relay V1 - Google Home Audio Notifications!

tts
requires_server
project_alerts
project_voice
googlehome
(Kate H) #1074

Thus far in every interaction I’ve had with Google Assistant support they’ve made a point of trying to tell me “Hey Google, send feedback” was the best way to make sure my feedback actually gets heard. Though truth be told I’ve never fully believed them on this.

0 Likes

#1075

Me either, since I did that several times and never even got a stock email reply.

0 Likes

(Brennan) #1076

Amazing work @Ryan780 !!

That’s fixed the problem for me as well.

P.S. I’ve forgotten, but is there a way to change the amount of time between broadcasts?

Example: I have the assistant relay tied to a motion sensor, when the motion detects motion, it sends a broadcast to the google home.
Well I have one of these at my front office door, which can go off quite frequently, so say, if motion senses something more than once within say a 10 minute period, only send the command to the relay once?

0 Likes

#1077

What are you sending the notification from? WebCore?

0 Likes

(Brennan) #1078

Yes, from webCore

0 Likes

(Jonathan Rider) #1079

Ryan, you are a legend! Did this last night and everything is working perfectly now!

Now I just need to work out how to add the converse=true command to WebCore to make it talk talk to me…

1 Like

#1080

If they are all from the same piston you can set it to never cancel task and also add a wait at the end. If you need specific help you can post a snapshot of the piston over on the webcore forum.

1 Like

#1081

I have three Google Homes and 1 mini. Today broadcasts through any method were only coming through the mini. I’m in the UK and the three Google Homes were purchased from the US back in 2016.

I tried rebooting them to no avail. Factory resetting them by holding the microphone button for 15 seconds has resolved the issue.

No idea what the cause was but at least it was a quick solution.

2 Likes

#1082

I thought it was just me. Only my minis are broadcasting.

0 Likes

#1083

I spoke too soon. I’ve lost all broadcasting today. I use Google WiFi and don’t know if it uses IPv6 internally if it is switched off for the WAN side. I assume it’s not active.

0 Likes

#1084

I think Ryan meant we need to disable ipv6 on the internal network, not the external interface.

Atleast for me, that was the case. Had ipv6 turned off on just the pi and they worked flakily for a few days, disabled it completely on the internal network including dhcp settings after Ryan’s discovery and now broadcasts work flawlessly all the time. I cannot disable ipv6 on the external interface anyways, no control over it. Remember to reboot the Google home devices and your pi/pc/etc after changing these settings.

0 Likes

#1085

Yeah Google Home has no such option. The only option literally says “Enable or disable IPv6” but as my ISP doesn’t support it Google WiFi errors and disables it again.

I don’t know if it’s using it internally though. All my devices have IPv6 addresses (I can’t see an IPv6 address from the Google Home app) but that might be self-assigned.

Broadcast isn’t working from Google Assistant or even the other Google Homes. It’s completely down for me.

0 Likes

(Greg) #1086

Just so everyone is aware, I am slowly working on a version 2.0 of Assistant Relay.

For the most part, its not much different for you guys at the moment, lots of refactoring in the code and i’d still suggest everyone stays on version 1.0.

If you want to test or help me build it, the V2 branch is on Github.

3 Likes

#1087

Awesome. I’ll take a look.

FYI there seems to be a bug either in the version of Google Home (130671) or somewhere in the cloud which stops broadcasts working if you have Night mode enabled in any form.

0 Likes

(Tommy Strømme) #1088

I successfully got this setup and working yesterday. Really happy with the way I can send broadcast from curl and from webcore.
My goal is to include this into an alarm system and let my six Google Homes notify “the burglar” that the authorities are on their way combined with flashing lights etc. That part works fine. However I also would like to let Beastie Boys Sabotage sound on full volume in the house aftewards and I’ve tried to scroll and search through the entire thread to find a workaround or a solution to to this. I understand the API does not allow to do it direclty, but is there another workaround that I have missed?

0 Likes

(Greg) #1089

Unfortunately there isn’t a way to play audio yet :frowning:

The best thing I can suggest would be to use something like the cast smartapp, and incorporate that into the piston too

0 Likes

(Kebel87) #1090

LOL! Considering how GH are always desynchronized, it would be a very good deterrent.

4 Likes

(Tommy Strømme) #1091

But the cast SmartApp… before I start on another endavour of setting up that one too… can I send audio to only ChromeCast devices or can I send to groups (which consists of both Google Homes and ChromeCast audio devices)? It would be really nice if Google could include music playback (also radio) in the API. Where do we push for this?

0 Likes

(Andrew) #1092

does anyone actually have this working on Synology?

0 Likes

#1093

The cast API will enable you to select individual GH’s / Chromecast Audio or if you have them grouped, it can also play on grouped GH’s. Basically the cast api will detect all GH, mini, Chromecast device on your network.

I have pretty much the same setup where the relay notifies the intruder and then the cast api blares out an mp3.

Another plus side of using both side by side - you can control the volume for the GH’s (cast api enables control of volume).

0 Likes