SmartThings Community

[Release] [Closed] Google Assistant Relay V1 - Google Home Audio Notifications!

tts
requires_server
project_alerts
project_voice
googlehome
#1053

Same error while running index.js for the first time. This time I didn’t even update Raspbian, just installed v8.11.3 of node and assistant relay. thats all.

(node:1423) UnhandledPromiseRejectionWarning: Error: Exited with code 3
    at ChildProcess.cp.once.code (/home/pi/assistant-relay/node_modules/opn/index.js:84:13)
    at Object.onceWrapper (events.js:317:30)
    at emitTwo (events.js:126:13)
    at ChildProcess.emit (events.js:214:7)
    at maybeClose (internal/child_process.js:925:16)
    at Socket.stream.socket.on (internal/child_process.js:346:11)
    at emitOne (events.js:116:13)
    at Socket.emit (events.js:211:7)
    at Pipe._handle.close [as _onclose] (net.js:557:12)
(node:1423) UnhandledPromiseRejectionWarning: Unhandled promise rejection. This error originated either by throwing inside of an async function without a catch block, or by rejecting a promise which was not handled with .catch(). (rejection id: 1)
(node:1423) [DEP0018] DeprecationWarning: Unhandled promise rejections are deprecated. In the future, promise rejections that are not handled will terminate the Node.js process with a non-zero exit code.
(Kate H) #1054

Hi,

Trying this on my Raspberry Pi 3 B+ with node v8.11.3, I seem to be having the same issue several other users have reported where the broadcasts (including the “Assistant Relay is now setup and running” broadcast that goes out automatically when relay launches) show up in My Activity but no sound actually comes out of my Home Mini speaker.

I’ve tried toggling the Firmware Preview Program off and rebooting the speaker several times, doesn’t seem to have made a difference.

Should mention the Google Account I have my speaker connected to is a G Suite account. Could that be the issue? Broadcast commands sent from my tablet on the same account do generate sound without issue…

(Charles) #1055

Mine is also and it, mostly, works. I haven’t really scrutinized it closely, but I think it usually works but not all of the devices (1×GH, 4×minis) seem to go and it’s random which ones speak. “My Activity” always shows all the broadcasts.

(Kate H) #1056

Lucky you. Consistently no audio on my one device.

I bought this thing when they were $25 last Christmas because I kinda categorically hate Amazon but generally love Google’s products and I’m kinda holding off on buying more of them until it stops feeling like a frustratingly buggy device… Since the broadcasts are consistently showing up in My Activity this feels like it’s most likely yet another bug on Google’s side. :frowning:

#1057

I agree. I wish there was a way to get the stock firmware back to the device because I also had the preview firmware on my device as well.

(Brennan) #1058

This program is great when it works. I know its nothing on @ghesp 's end. But I don’t really want to put the time or effort into using a different program or set up… I’d rather just wait until google sorts this problem out on their end.

(Greg) #1059

If anyone is having issues with Google Home not responding, then your best bet is to put your details here:

Make sure that it is logging the data in My Activity or the Relay is working first though

1 Like
(Kees De Kraker) #1060

I m running a headless RPi on Stretch. The setup went fine, but I am unable to open the URL when starting the relay node for the first time. I am a NOOB when it comes down to Linux and SSH. Any ideas on how to perform the last step from the tutorial??

(Greg) #1061

I can’t remember now, but it shows the link in the terminal I believe? If so, just copy and paste it into a browser, get the code and paste it back into the terminal

(Kees De Kraker) #1062

Thast the thing. It’s keep coming back with an error (500) when I try to open the URL.

(Kees De Kraker) #1063

Feel really stupid now. Somehow I forgot to add the client to the Google API. After adding a client, all when well.

Setup is working 100% correct!

Many thanks for your quick reply and developing Assistent Relay!

1 Like
(Kate H) #1065

Tried it tonight and suddenly it works without any changes on my end from how I previously had it set up. Shifted all the notifications I had set up using the audio cast protocol to use this instead. Thank you! :slight_smile:

1 Like
(Kate H) #1066

Aaaaand 6 hours later I’m back to “broadcasts show up in My Activity” but Google Home makes no sound." :frowning:

#1067

FOR ANYONE HAVING PROBLEMS WITH NO BROADCASTS!!!
I have not been able to get broadcast to work for weeks. I have tried everything. They show up in my google activity and custom commands work but i get nothing broadcast from my google homes. Well, I just got it to work. I went into my router and disabled IPV6 and voila…everything worked. It appears that google was looking at the IP address and assumed they were not in the same location. So, the broadcasts wouldn’t play on my devices. But it is working now 100% of the time.

5 Likes
(Dan) #1068

Nice find Ryan!!!

#1069

:thinking:

(Bryan) #1070

GENIUS! Thank you so much for figuring this out!

#1071

I also found a really great tool for installing node on your Raspberry Pi. One command and BINGO…done. I’ll be updating my wiki with this one. Best part, it allows you to install any version of Node you want.

3 Likes
(Kate H) #1072

Okay Google needs to hire you. Figuring out their bugs for them like this. I’m thinking the Google Home in general would be a considerably less frustrating device if they had someone like you on the team!

Can I assume you’ve communicated this to their team on the other thread so they can fix their SDK’s IPv6 awareness?

#1073

I’ve posted under the GitHub repo that was being tracked but if you know of somewhere else I should post it, let me know.