SmartThings Community

[Release] [Closed] Google Assistant Relay V1 - Google Home Audio Notifications!

tts
requires_server
project_alerts
project_voice
googlehome
#796

Nope. Nothing yet.

#797

Aaarrrrgh… Thanks

#798

Mine stopped working too, as other mentioned above, I can see the commands running but just no feedback from the GH

(Brennan) #799

Yes, I haven’t changed my set up in over a month and suddenly it stopped working as well. Very odd.

(Luis Villaran) #800

Same issue. Custom commands are still working, but I get no audio feedback. Broadcasts are plainly not working.

#801

I have some more news…I tried creating a new Oauth file for a different user. Linked that user to my GH and rebuild my config for the relay. Same result. Relay accepted the command but no audio feedback was given.

I have switched back to cast-web. For now it is the only solution I am aware of for audio alerts. Luckily I only have like 6 pistons in WebCore that I had to update to use the Speak command instead of the assistant relay links. Cast-web is still working currently.

Also, I tried updating to node 10.1.0 (the latest). That didn’t work at all as assistant relay wouldn’t even start. I am getting some odd security warnings when I try and install the relay software. I’m going to look in to those. Also, when I go into the google cloud console, i see that 100% of my relay requests are producing an error I didn’t know I was getting. It appears that they are error type 499. Still can’t find what that means. Can anyone else go into your google cloud console and confirm if you’re seeing the same thing with 100% of your requests getting an error. Go to console.cloud.google.com and if you’re not automatically redirected to it, enter your project. Then click on API’s & Services - Dashboard. Should look like this:

4 Likes
(Eric) #802

The last 30 days and it was working up until yesterday.

#803

that makes me think something was broken the whole time with that solution…it just was working accidentally. Hopefully @ghesp will come up with something.

(Chris Lamberth) #804

I’m having the same problem. Worked fine for months and I noticed today that the audible alerts stopped working.

(Kyle) #805

I am also having the same problem as everyone else. Been working perfectly for many months, but just stopped yesterday. Assuming Google may have changed something?

#806

Add me to the list! Was working beautifully on my Pi for some time. Now nothing works! Hope this gets resolved!

#807

+1 here. It’s been rock solid for months and now it’s down :frowning:

(Adas4190) #808

Same here :frowning:

(MacTechGenius) #809

Stopped working for me as well

(Sandred69) #810

The problem seems to be Google Assistant is rejecting the request to broadcast. You can notice it in “my activity” in Google home app.

(Eran Salomon) #811

Same here, I had it all working with the older release for a few months now but all of a sudden yesterday it stopped working without anyone touching it.
I get the same screen where it all runs as expected but no announcements coming out from the Google home.
image
I did try to run the npm install but getting error there is no start command

(Eran Salomon) #812

I also tried to follow again from the beginning the installation but I see now that the SDK process is completely different and all the commands are for Linux based system only … :frowning:
Am I missing anything or Google changed the process completly and it cannot run on Windows host any longer?

(Eran Salomon) #813

I’m using Windows machines but so far no luck - tried to reinstall on 2 different machines all results with errors all over the place complaining about Python not exist (Although it is installed on both machines with variables set etc.). The old Google relay that was working before still run but I initiate it not sound comes from any of the GHs (The usual “Relay Assistant is running”) or any other set notifications.
Its really seems like someone changed something somewhere - maybe Google?

(Greg) #814

Hey all,

On holiday at the moment so can’t check, back next week.

My assumption here is that Google have done something, probably disabled the broadcast command from the SDK for some reason.

I did notice that the library I’m using has been updated, so could be that too.

Will investigate when I’m back.

1 Like
(Adas4190) #815

I can confirm that my Gassistpi project has also stopped working. I mean it’s broadcast ability is no longer working so it might be disabled by google.