SmartThings Community

[Release] [Closed] Google Assistant Relay V1 - Google Home Audio Notifications!

tts
requires_server
project_alerts
project_voice
googlehome
(Dana ) #174

Updated to new DTH and downloaded zip of the project from your github and updated, edited config for my info. and BOOM - all is working, including customBroadcast w/out user parameter.

Fantastic - thanks very much @ghesp & @hmin03 for working this out.

Off to update my pistons… :slight_smile:

#175

Did anyone have been able to make it work in other language?

@ghesp do you plan on having assistant relay able to send commands as if we spoke to it? Like play x using YouTube on y device?

(Eddy) #176

Woo just finished installing it on my pi, was quite a ride
Gotta find a way to broadcast to a single google home, right now it triggers all my devices

Now lets see if i can get this on webcore

(Eddy) #177

Ok so just had a little chat with google rep, the broadcast command will trigger all google home devices under your account, no way around this
THey told me that the “intercom” feature MIGHT be the solution for this, but its all speculation at this point
OH well!

(Dana ) #178

NVM
10 char

#179

I actually use this for individual home notifications (for speaker groups as well). I’ll use that until this is at release level (just in case pistons have to be redone at some point :wink: @Danabw) .

1 Like
(Eddy) #180

TTS using what exactly?

#181

Not sure if you’re replying to me, but the linked cast-web SmartApp uses ST TTS from what I can tell.

(Dana ) #182

LOL…zing! :smiley:

Thank goodness the wife is in the garage obsessing over some shelves she’s staining…busy time for me.

Only problem w/that cast service is that I have to leave another device (the device connected to the chromecast) on all the time, right?

(Greg) #183

Use the custom command to send whatever you want to the assistant. A lot isn’t supported by the SDK though like music playing etc. Nothing I can do about that, only option is it use one of the Chromecast work arounds

#184

Yeah, but for notifications, your Google Homes are cast targets too. They’re on anyways! The drawback here is that there’s no reliable way to resume anything if something was already playing. Also, it’s not using the GA TTS, but rather the ST TTS which doesn’t sound quite as nice.

(Dana ) #185

Ah, thanks, didn’t think about the GH’s as I am relying on @ghesp/Greg’s relay full time now!
(And yes, paid the “pre-release tax” updating my pistons, but only took me about 10 minutes. :smiley:

#186

@ghesp

Just wanted to let you know that this is awesome! I’ve installed NodeJS on a Windows Server after trying to install on a Synology NAS and getting make errors (It’s not a fully fledged linux OS after all) and it worked first time.

My only question is whether the first broadcast letting me know that the relay is functional can be disabled? Ideally via the command line. These Windows Servers have to reboot monthly to apply updates, which is typically at 3am My wife wont be amused by been woken up by the broadcast :smile:

Thanks for work you’ve done so far!

(Greg) #187

I can probably build it in, however if you look.at the index.js file, you will see down the bottom of the file the command that triggers the initial broadcast.

Just comment it out :slight_smile:

#188

I skimmed through it earlier and missed that. That’s easy enough. Thanks!

(Ryan Murphy) #189

Has anyone got this running on Docker yet? :slight_smile:

(Brian Spranger) #190

So I do not need to have a Linux box to use this? I can get it running on my already running Windows server?

(Dana ) #191

@JumpMaster has it on their windows server…just four posts up the thread here. :slight_smile:

(Dana ) #192

@hmin03 - I finally got my pm2 up and running and it is so nice to have the service just pop up automatically when I reboot and to be able to use pm2 list (to view the status). Thanks for mentioning this.

One thing I’m noticing when I installed pm2 using the -g parameter - I still had to add an export path statement pointing to the pm2 install folder to get the command to run - otherwise I get the annoying not found result. I ran the install form my home folder on my Pi.

Is this a common issue w/the -g command not being 100% reliable, or ?

#193

Did it install into /usr/bin?

What’s the result of…

which pm2

It should point to the installation directory. If not, I’m not sure what was different when you installed… You can probably just symlink to /usr/bin as a shortcut…