[RELEASE] cast-web v1.2.1 - Chromecast Device Handler & SmartApp

Can you help explain what those two new parameters are?

I think you can find the best explanation here: Custom Capability and CLI Developer Preview

Anyone fixed the Java errors on rpi raspbian running The gui that was mentioned in earlier posts? The application just, keeps loading. Fresh install on a rpi3b.

Anyone using sharptools with this to display album art? I reinstalled everything and now i have, to force an update each minute to get it to update or even display The album art tile. Used to be almost instant.

I’ve added the smartapp to my system, but I donøt get the option to put in the IP-address for the "cast-web-api address.

What can I do?

The fix is at post 1455.

Sorry…I haven’t used Smartthings in a while, so I can’t help.

Thanks - got it working :slight_smile:

Hi. Perhaps stupid question, but couldn’t see the answer in the intro.

To make this work, do I need to have a PC running 24/7 with that API software on?

Essentially yes- either computer / laptop but many opt for raspberry pi. I think it’s worth trying using a computer before deciding if the raspberry pi route is for you :+1:

Thank you.

All I need is to control google cast speakers by setting volume level and “Stop music” on the speakers. I’m using Spotify Connect. Nothing else.
Are you aware of other more simple solutions to do that from ST?
Or is this the only way?

I used to use a Generic DLNA play controller thing some years ago, but it stopped working in 2018 I think, and I dont know if that can control these google cast speakers.

Any way to get this to work with only ONE speaker? Currently have more than one Google Home device and everyone gets the “incoming broadcast” Thanks.

1 Like

Hey! Attempting to add the ‘Service manager’ device handler via the SmartThings IDE, however, attempting to ‘create’ from code shoots me this error. I am pasting the code directly from raw.githubusercontent. Thoughts?

“Groovy.lang.MissingMethodException: No signature of method: script_dth_metadata_875a87c7_e9c3_48eb_95af_dba5c7995e46.appSetting() is applicable for argument types: (java.lang.String) values: [api] Possible solutions: typeSetting(java.lang.String), typeSetting(java.util.Map), typeSetting(java.lang.String, java.lang.String), getSettings(), setSettings(java.lang.Object), typeSetting(java.lang.String, java.lang.String, java.util.List)”

Hi,

Sorry for the delay. Did you add the service manager on “My SmartApps”?

Did you copy > paste from here? https://raw.githubusercontent.com/vervallsweg/smartthings/master/smartapps/vervallsweg/cast-web-service-manager.src/cast-web-service-manager.groovy

Is there a way to do TTS from an external script via the API? I have some Google Apps Script code that does some smart home stuff for me and I would love to be able to make TTS notifications.

I already use the Smartthings API for turning switches on/off from Google Apps Script.

I’m using a Windows 7 install. I had it installed and running correctly doing TTS, but at least a couple of times it’s crashed with the widely reported “Uncaught Error: Device timeout” and the TTS stopped responding.

I’m now getting "API doesn’t respond. Check the log file to see the error message in the cast-web-api-desktop window. In the transparent background of this error is a spinning circle showing “Loading,” which shows up once you hit “close.” The loading message never stops. I seem to recall this happened when I first installed it, and I can’t remember how I ended up (temporarily) fixing it.

All of the failed logs, found in %AppData%\Roaming\cast-web-api-desktop\logs are zero length.

I’m not sure if this is a coincidence, but I closed the app from the tray and then re-ran it as administrator, and it worked.

1 Like

Sorry can you expand on this a bit? What did you hard wire?
I am not finding any devices on the smartthings app. The desktop app logs seem to be finding things.

Hi,
first of all sorry for the late reply.

Are you using wifi or ethernet connexion?
Try this:
1, turn off wifi and/or disconnect your eth cable.
2. on both of your adapter options (Wi-Fi and Ethernet) enable ipv6
image
3. check if devices are available now