SmartThings Community

[RELEASE] cast-web v1.2.1 - Chromecast Device Handler & SmartApp

The Service Manager is a SmartApp. You need to create a new smart app, not device handler.

Let me know if that was the issue.

Thanks for pointing that out. I’m super new to all of this and still getting the hang of this

1 Like

Has anybody implemented these GoogleTTS services into any of the ST media-rendering smartapps? (e.g. BigTalker, Speaker Notify with Sound, Media Renderer Events, ec).

If yes, can you please publish/share your repo?

There is a pure groovy implementation available here. Should be copy and paste for any other smartapp.

For v1 you can just go to the device’s setting and flip the switch, then all speak() methods will use Google TTS.

When you say V1, do you mean the beta version? I’m on 0.2 and would like to use the more natural-sounding Google Home voice. Would upgrading to the Beta give this option?

Yes and yes.

I’m planning to release v1 soon. If you want it asap, I’ll invite you to the beta group. Otherwise, will be just a couple of days away :slight_smile:

Oh ok cool, just wanted to make sure I wasn’t missing something obvious. I’ll wait until the v1 release as there’s no rush for me.

1 Like

Hey everybody,

cast-web version 1.0.0 is finally here! I’m really proud and exited to finally see the most annoying things about cast-web fixed.

This also marks the launch of the new project website:

However, a lot of things have changed in cast-web. This means upgrading is not as straight forward as you might expect. Read this article first, it should answer most of your questions.

Should you encounter any problems while updating, there’s a brand new help section on the website. Or just ask here.

Let me know what you think and have fun with version 1! :slight_smile:

1 Like

Dory - node.js / javascript’ isnt compatable with my old archos tablet i was goin to use, is there any altenatives?

Which android version is the archos tablet running? Maybe another node installer available in the playstore for your version?

im not sure (im at work) what could/should i search for on the playstore to find other installers, ive no idea what a node installer is

Ive installed it on another phone. When i do thr npm install nothing much happens just get a code : 1 / signal : 0
When i go back to start it starts then stops. The std out has a sentex error unexpected token


SyntaxError: Unexpected token )
at createScript (vm.js:56:10)
at Object.runInThisContext (vm.js:97:10)
at Module._compile (module.js:542:28)
at Object.Module._extensions…js (module.js:579:10)
at Module.load (module.js:487:32)
at tryModuleLoad (module.js:446:12)
at Function.Module._load (module.js:438:3)
at Module.runMain (module.js:604:10)
at run (bootstrap_node.js:383:7)
at startup (bootstrap_node.js:149:9)

Any ideas?

I’ve upgraded everything (nodejs app, DTH, smartapp), but can’t seem to run the node js app either. here’s my output:

pi@raspberrypi:~ $ cast-web-api
SyntaxError: Unexpected token )
at createScript (vm.js:53:10)
at Object.runInThisContext (vm.js:95:10)
at Module._compile (module.js:543:28)
at Object.Module._extensions…js (module.js:580:10)
at Module.load (module.js:488:32)
at tryModuleLoad (module.js:447:12)
at Function.Module._load (module.js:439:3)
at Module.require (module.js:498:17)
at require (internal/module.js:20:19)
at Object. (/usr/lib/node_modules/cast-web-api/bin/cast-web-api:2:20)

My bad. Somehow one line went missing when publishing to GitHub and afterwards to npm. I wasn’t even aware that I removed something :sweat_smile:

Pushed an update that fixes that one line.

just run (sudo) npm update -g and it’ll update to 1.0.2 !

Oh and @mark_cockcroft which android version was your archos tablet? Just search for node.js in the play store. Maybe theres also another way for your version of android, will check.

Ive got it running on an old phone and its given me a address which ive put in the app
Test api dosent do anything and neither dose discover. The api output looks like its finding other device on my network

Having some trouble here as well. I can’t seem to discover devices at the moment in the SmartApp.

Also, when I test to see if the cast-web-api is running (@ myip:3000), I see: cast-web-api version 0.3.0. Is the text just not updated, or is the app not updating to 1.0?

Edit: not sure why, but it took a few tries to get it to update to 1.0.2. cast-web-api started now.

Discovered 3 devices, selected all 3, hit Done, hit Next and only see a Blank screen. If I hit the save button, I get a “Error-bad state. Unable to complete page configuration” error.

Looks like a communication issue then. Can you access the api from any other device on your network? Just enter the address into the browser of any other device connected to your network.

:+1: maybe npm took some time to update.

Set the log level to 4 and try again. Open the IDE > live logging while you do it though. Post the output here if it still doesn’t work.

There’s a good chance that your devices are either added regardless of the error message or it will work just fine on the second try.

Yea on my mobile i get this page

{ "cast-web-api" : "v1.0.2" }

I tried a few times, but the SmartApp won’t get added with the error, so the devices don’t get added either. I’ll try the logging level 4 and see what I can get it to tell me.

1 Like