[RELEASE] cast-web v1.2.1 - Chromecast Device Handler & SmartApp

don´t use webcore at the moment

thanks. i will try github and webcore forums

How do you setup a preset? I have had it working great with text to voice. I have tried to get it to play an MP3 instead of voice but I don’t get any playback.

Is this what you are trying to get to work? My contact sensor 10 is a virtual switch that looks at Google calendar for work wakeup. When its open I up the volume because i’m in the shower.

Hey @Gietlt do you mind explaining how you have the virtual switch looking at Google Calendar?

Its the GCAL search. There is a search and a triger

1 Like

Great thank you

Ive hit a wall setting up presets from the generator.
My preset looks like this:

{“preset1”:[{“mediaTitle”:“DingDong”,“mediaSubtitle”:“Ding Dong”,“mediaType”:“audio/mp3”,“mediaUrl”:“http://www.soundjay.com/door/doorbell-1.mp3",“mediaStreamType”:“LIVE”,“mediaImageUrl”:""}],“preset2”:[{“mediaTitle”:"Preset 2”,“mediaSubtitle”:"",“mediaType”:"",“mediaUrl”:"",“mediaStreamType”:"",“mediaImageUrl”:""}],“preset3”:[{“mediaTitle”:“Preset 3”,“mediaSubtitle”:"",“mediaType”:"",“mediaUrl”:"",“mediaStreamType”:"",“mediaImageUrl”:""}],“preset4”:[{“mediaTitle”:“Preset 4”,“mediaSubtitle”:"",“mediaType”:"",“mediaUrl”:"",“mediaStreamType”:"",“mediaImageUrl”:""}],“preset5”:[{“mediaTitle”:“Preset 5”,“mediaSubtitle”:"",“mediaType”:"",“mediaUrl”:"",“mediaStreamType”:"",“mediaImageUrl”:""}],“preset6”:[{“mediaTitle”:“Preset 6”,“mediaSubtitle”:"",“mediaType”:"",“mediaUrl”:"",“mediaStreamType”:"",“mediaImageUrl”:""}]}

However the preset 1 isnt working. Device is a google home.
Can anyone direct me to logging or assist in creating the preset correctly, much appreciated
ps the URL is a test, ideally im looking for a hosted Door Bell sound, the plan being to integrate Ring door bell and Preset 1 via webcore

Thanks, TB

See post 905. Try using the old presets. The square brackets I think is not valid

1 Like

Working a treat now after removal of the square brackets, thank you

open the cast-web, UI, click the settings cog wheel in the bottom right, delete the host name, save, then restart cast-web. It worked for me.

What did you do to get your devices to be found?

Hi, did cast manager all of a sudden stop working for anyone else? It still finds the devices ok and tests ok in the smartthings app but none of my speakers are saying stuff anymore. Thanks!

Trying to get this working for the first time, but having problems.

I carefully followed all the installation steps, but when I click “Discover Devices” nothing happens. I get the wheel to say it’s doing something, but nothing pops up, and no error messages either. Same thing happens if I click “Test API connection”.

Based on previous posts I saw, I went to the /device page, and I see all my devices mentioned there. So clearly it can in fact find my devices… but Discover Devices still doesn’t work.

Never mind. Got it working thanks to a helpful comment further up. Had to delete the hostname in the settings, and restart the desktop app.

Hi Guys look for some help if possible.

I have followed all the steps, have everything installed DH and smartapp working. The problem i am having is there is no option for me to enter my api address in the smartapp when i launch it

I know the webapi is running on 192.168.99.114:3881 cause i get the {“castWebApi”:“v1.2.1”} when i view it in the browser.

Im running the cast-web-api-desktop app on a mac

Any ideas would be greatly appreciated

After a bit of trial and error (and looking closely at images) it seems the issue is with the “New” smartthings app.

Downloaded the classic app and all worked without a hitch. All setup and devices added. Now i can use the “new” app to configure automations etc.

Cheers

Edit : tinkered and fixed

Hi Steven,

I had the same issue and was able to workaround it by using the ST Classic app.
The new one has some rendering issues.

I’ve forked the Device Handler and Smart App and made some changes to make it work better in the new SmartThings app. Unfortunately I cannot find a way to display all the tiles that are in the classic app, and it has some refreshing issues, so have worked around this by making the handler refresh every time an action is performed. I’ve created a pull request here:

Best,
Ryan

1 Like

Hi all,

Had a bit more of a play and have got realtime data updates working between the API server and the ST app (Classic and New). Testing with spotify on my browser casting to a device, the ST apps reflects the change in some within ~1sec.

When a new cast device is added, it will try to subscribe. If you’ve already got a device added, you can force a subscribe by pressing on/off on the device in the ST apps. Also have put in a toggle on the settings to force a refresh & subscribe on button presses/actions.

Best,
Ryan

2 Likes