[RELEASE] cast-web 1.1.0 - Chromecast Device Handler & SmartApps

dth_av
requires_server
project_av
chromecast
googlehome

#762

Okay…so, if you go into the smart-app, you can re-name them. That way they won’t all have the same name. I’m not sure why they all show up with the same name, they don’t in the version that I’m using.


(Ricky Turner) #763

Well, no, not really… That’s not quite the issue.

You can see here, when you go to search for devices, it finds 12. The 3 I’ve already added date listed there…

When you go in to select devices, you can see they’re all listed. I select the 3 bedroom devices and click next…

And I get this screen, which still shows me the devices by name and their IDs…

Click save on that and it successfully updates…

But then these devices are listed everywhere on this things list and within the smart app as just cast-web-device.

And you can’t rename them by clicking those, because it crashes out on the things list, and in the smart app, only brings you to this:


So it’s not about names being the same… It seems that, though the API can hear me making requests, it is not sending information back to smart things…

And my app window gets filled with all these errors.

I do appreciate you trying to help… Hopefully there’s a solution to be had here. I feel like I’m so close.


#764

What version of the SmartApp are you using?


(Ricky Turner) #765

I’m using the one from the installation guide, which is

this.

Is there another?


(Ricky Turner) #766

OK, I’ve become obsessed…

It seems that everything is working communications-wise one way. Callbacks aren’t working.

Basically, my smartthings hub can see my web-cast api, but the web cast api doesnt seem to know who to talk back to. Right? That’s why everything on the api end of things seems to work great, recognizing all my devices, showing up in browsers, etc.

I can even type commands into the browser and control playback, volume, etc., such as typing: http://192.168.86.63:3000/device/15f3bd3a0426fa1810d0f6f1ff6c415b/volume/30 and it changes the volume. I can type http://192.168.86.63:3000/device/15f3bd3a0426fa1810d0f6f1ff6c415b/pause and it pauses. Perfectly, instantly. But even when I do this, I can see in the api console window that the callbacks it’s supposed to be sending are trying to send everything to 0.0.0.0:0.

I initially thought the problem was the api not being able to see the hub…as if outgoing traffic was allowed into the hub, but incoming was not. --But the errors on the callbacks are exactly the same whether I play/pause from the SmartThings app, from the command line on the browser, or anywhere I can trigger it.

So, it seems like the API running on my node.js (raspberry pi 3b) just isn’t talking back correctly.

Hoping this extra troubleshooting helps someone in the know with things I can try on the api end of things.

Thanks again, everyone!


(Alwas) #767

In the cast-web-api device Thing settings, did you see “Don’t sync cast-device names from API?” check box?
I would also do another Add a Thing search, just in case.


(Ricky Turner) #768

:thinking: interesting…

So, the answer is no:

That box isn’t checked.

And I had previously never tried an add things search, because upon setting up the smart app, the things just all appeared (unfunctional though they may be). But when I click add thing, even though all 13 devices were already listed, they all came up instantly in the new things list:

Unfortunately, adding them this way resulted in no change. They were there before, and they were still there. No duplicates, no new functionality. :unamused:


#769

Did you enable the setting? You would have to remove the devices and re-add them via the app.


(Ricky Turner) #770

I’ve tried it with the setting, I’ve tried it without the setting. Makes no difference.

I’ve even tried moving the ST hub, the RasPi, and one Chromecast device to their own fresh WiFi network together that they alone can access just so that there’s no possible interference with other services on the network.


#771

Sorry, dunno. I know it’s working fine for me, so I doubt it’s a software issue. The only thing I can say is to wipe everything out, including the server and start over again.


(Ricky Turner) #772

I appreciate your time and willingness to help, Ryan. Unfortunately, I have already tried starting from scratch on a new computer/completely different operating system, as outlined above.
This thing just does not like me right now! I’ve never failed to get anything (pretty extensive list and growing) up and running with ST, and I thought my pool controller was a beast!

I’m hoping that maybe the mdns stuff that’s been talked about above could be the issue, or that someone recognizes these symptoms and knows just what to look for (“oh, be sure you use this version of x, the latest version broke communications”) or some such.

Again, thanks for all the ideas.

For now, I’ll lay out the specs that could matter, if anyone else has any ideas:

  • SmartThings Link on Shield TV (hub)
  • Google WiFi with zero custom settings, only one LAN/SSID
  • RasPi 3b running Raspbian
  • Latest versions as of 1/6/19 of node.js and all API/DTH/Smart App
  • SmartThings Classic app
  • Intermediate/confident skills with IDE, scripting, Linux, etc. (far from a beginner, but not a programmer)

Thanks all to this great community! I really look forward to donating to the project, as I always do when people come together to build these awesome tools. :blush::+1:


(Muhammad Awais) #773

while following this document in point 2 couldn’t find Cast web - service manager in smartthing apps

  1. Open your SmartThings mobile app
  2. Go to: ‘Marketplace’ > ‘Smartapps’ > ‘+ My Apps’ > Cast web - service manager
  3. Enter your cast-web-api address. The API will output something looking like this http://192.168.2.105:3000/ on startup.
  4. Tap ‘Discover devices’
  5. Select your devices and click ‘Done’

anybody knows where is it ?


(mike) #774

I got this error due to my smartthings hub and pi being on different subnets.


(Jeff Lagana) #775

Yeah, I discovered the same issue, and I’ve since corrected it. I was trying to enable multicast forward which worked randomly but not always.

I’ve now got cast-web-api working in docker, I’ve also got assistant-relay working in docker. When you combine the two, with webcore you have the ability to trigger commands against the google assistant API and cast the response directly to a single google home speaker.

Example: I turn on my kitchen lights first thing in the morning M-F. Webcore sends a JSON request “Tell me about my day” to assistant-relay which proxies the command to the google assistant API and then saves the response to MP3. The URL for the MP3 is then automatically streamed the kitchen speaker using cast-web-api.

Simply put - it’s awesome.


(Ricky Turner) #776

All my devices are same subnet --.86

192.168.86.68 --Shield/hub
192.168.86.67 --RasPi


(Ricky Turner) #777

@awais786327,

Are you using the Classic app, or the new one? There aren’t smartApps in the new app.

If in the classic app, the “automation” button/tab along the bottom, and then the “SmartApps” tab up top. Then scroll to the bottom, add smartApp.

It can’t be set up in the new app, though I imagine it might have some functionality in there once it’s up and working.


(Muhammad Awais) #778

@DesignDawg i have samsung S7 and recently updated my apps so i think its new one i have because it doesn’t seems to be the option which mentioned in documents so according to it what i am suppose to do ?


(Ricky Turner) #779

@awais786327,

I’m on a Galaxy S9, and I have the classic app and can pull it up in the Google Play Store. But you have to speficially search “SmartThings Classic.” The icon is an aqua-colored ring, instead of the little star shape. You can run both concurrently.


(Muhammad Awais) #780

@DesignDawg ummm i see well i should take S9 will you please exchange with S7 haha :stuck_out_tongue: just kidding thanks for your reply i’ll do it with classic app :wink:


(Ricky Turner) #781

Hey, at this point, I’d gladly trade my phone for an older one if it meant I could get this thing working at all! :unamused:

Let us know if you can’t get the classic app…there’s bound to be a way to sideload it.