[RELEASE] cast-web 1.1.0 - Chromecast Device Handler & SmartApps

dth_av
requires_server
project_av
chromecast
googlehome

(Benji) #722

So if I understand this right, this allows me to see my Google devices as a audio device in SmartThings, to control playback and volume?

On the DRM point, just to clarify, I can still cast DRM content (such as from Spotify) to one of my Google devices and still control the playback in SmartThings, it’s just the presets in the SmartThings device page cannot be DRM content, right?

Is the SmartThings device type compatible/controllable in ActionTiles as well?


#723

Need some help:

I had everything working running the server on my Macbook Pro.

Since then, I installed the server on an Android tablet. When I check the IP from a computer it responds appropriately, but when I try and access from the ST app I get no response. This worked fine before switching to the tablet.

Is there a simple solution I’m missing?


#724

Duh, I literally did this same thing. It has been driving me crazy, haha.


#725

Google TTS? ST TTS is working but quite a few people have reported Google TTS is kaput. If Google TTS truly is working for you which language do you have selected?


#726

which container did you use from container station, jg506 or janwer? I cant get either to run on my Qnap NAS, they give me this error when attempting to start… "standard_init_linux.go:185: exec user process caused “exec format error” "


#727

Is the Google TTS what’s used as the TTS option in Webcore?


(Michael Beatty) #728

Hoping to get some help playing MP4 video feed from my cameras. I’ve got TinyCam Pro running a media server (for action tiles). Using the same URL I use in Action Tiles, I can copy/paste that into a browser window and it will play the feed. I tried using the same URL in the presets for a Chromecast device and it won’t work. Tapping on the preset, just throws a blue cast icon to the screen. Any ideas?

The url I’m using is http://XXX.XXX.XXX.XXX:8083/axis-cgi/mjpg/video.cgi?camera=2&user=myuser&pwd=mypassword


#729

Just curious–does this allow any way to send google assistant text commands to a device, a la Google Assistant on my phone?


#730

I have successfully detected my google devices

I however am not able to find these app as shown in earlier screen capture

I get these screen pages after a successfully detecting devices

!
And when i tap done, this is the screen that i get.

Did i miss anything? Im sure ive installed the IDE SMARTAPP and IDE DEVICE HANDLER.

thank you much for the inputs


#731

I have to use the native Amazon Poly TTS for Hubitat. Otherwise I can’t use Speak commands. Also, there is another change that is necessary to the driver that you have to do in order to get speak commands to individual devices work in Hubitat. Don’t think this has been merged in to the main fork for the guy that did the porting to Hubitat.


#732

No, Google TTS is only used if you go into a speaker and toggle the setting on. By default I believe SmartThings has a TTS service that is used. Actually, I don’t know who provides it but the default TTS service works.

If you go toggle Google TTS on speak commands from Webcore stop working.


#733

It might have been merged already. I wasn’t aware of any issues but I’ve had speak commands from Webcore working in SmartThings and Hubitat luckily. Just not with Google TTS. I’m assuming that since you called the Amazon Poly TTS service native that’s what it uses if Google TTS is not toggled?

That also answers @Coolsaber57 's question.


#734

Did you install the device handlers as well as the smartapps into the IDE? It feels like perhaps you missed the device handlers. Make sure all changes are published.


#735

I have. But ill double check again


#736

Yes, that’s the native Hubitat TTS service.


#737

yup device handler is there and published.


(Khaled Qari) #738

will this ever work for netflix?


#739

What do you mean “work for netflix”?


(Khaled Qari) #740

It says

  • You can only cast [DRM free content ]
    That means i cant just transfer the content to another TV?

#741

I’m sorry, I’m still not understanding the question. You can cast content, as in you can send a file to the device to be played. You can’t “cast” netflix to your Chromecast. When you do that, the Chromecast is the thing playing Netflix. You just control the content with your phone or your voice to a GH speaker. It’s not the same thing. Plus, why would you want to have ST play a video from Netflix on your Chromecast? Do you use a particular episode of a TV show as a notification or something? Why not just issue the command to your GH speaker? It’s a lot simpler than trying to use Cast-Web.