SmartThings Community

[RELEASE] cast-web 1.0.0 - Chromecast Device Handler & SmartApps

dth_av
requires_server
project_av
chromecast
googlehome

(Tobias) #681

That means the default port (3000) is already used by a different application on your computer. Either stop that program or change cast-web-api’s port with the --port=xxxx parameter. More info in the docs.


#682

Given the fact that there is another project solely dedicated to the assistant stuff I would think this would be totally okay. I use your project for TTS, presets, etc. Is there a reason you haven’t merged 1.1 to the master branch? I’m still on 1.0.2 and it crashes alllll the time. I don’t think it deals well with devices that turn off frequently (chromecast audios or chromecast videos that are attached to the power ports of amplifiers and are often not present on the LAN) that are also part of speaker groups.

Would more people be on 1.1 if the website or branch had updated installation procedures? I’m missing something because when i run 1.1.0 it doesn’t attempt to discover devices according to the output when it starts up. I gave it the DNS library dependency it wanted but maybe that’s the problem.


(Patrick Gormley) #683

Thanks,
I have the jsnode app running but no devices are found. API returns { “cast-web-api” : “v1.0.2” } if accessing from a browser and Connected OK: 200 from the smartapp.

Any ideas what could be wrong?


(Scott Bronder) #684

I was being a bozo. I figured out my issues. Thanks. Everything is working great!


(Tobias) #685

Does it list devices in your browser if you add /device/ to it?


(Tobias) #686

Yeah but if you want both you need two different api devices thanks to ST’s platform limitations.

How? Like the whole api goes down? :astonished:

Yeah I’m working on that…


(Michael Beatty) #687

Just got this up and running last night… Its an impressive addition that I’m pretty excited to dig into… but are there are other resources or documentation that I can use to give me some ideas of what all I can do and what I can accomplish? Any tutorials available? So far I’m basically just using it to do text to speech on triggers (which took me a good 15 minutes to figure out how to do).


(krglover11) #688

I’m getting the following message anytime i try to install the 3rd device handler (the service manager)

Any ideas?


(Alwas) #689

The Service Manager is a Smart App, not a Device Handler.


(Michael Beatty) #691

A couple questions. What’s the difference between “Speak text…” and “Speak”?

Also

How would you use “Speak Text and Restore” and “Speak Text and Resume”. I guess the Speak Text and Resume is somewhat self explanatory, that if anything is playing, it goes back to playing it. But what does Speak Text and Restore do?


(krglover11) #692

wow. i must have been REALLY tired the other day. Thank you lol


(Kurt) #693

Hi

I am new to the community and the world of Smart things. I had recently acquired a v3 hub and installed this great solution yesterday. I have added it successful through the classic app, but I can’t seem to use my cast devices in the new app.

I am not sure if that’s been discussed already, but I couldn’t seem to find anything.

The error I see is “can’t connect to device. Check device and try again”

Is there anything I can do to get it working?

Thanks!


(CS Goh) #694

Hi, i noticed since yesterday the Google TTS stopped working. Wondering if anyone having this issue as well. Basically, the volume change and all worked but no announcement from Google Home. Turning Google TTS off in the device settings solved it but i do prefer Google TTS.


#695

I just turned TTS on on my speakers and its working. Although I dont notice anything different when I turn it on, whats the difference?


(CS Goh) #696

Oh… Hmmm… Something on my side must be wrong. The difference for me when it was working is the accent of the voice and maybe just for me… Google TTS sounded less robotic.


(Michael Beatty) #697

I’m glad I read this… I just got cast-web up and working on Tuesday…everything was fine. Then yesterday I noticed that my bathroom speaker and living room speaker where just going “doink” and then not speaking anything… yet my son’s speaker was doing TTS just fine. Last night I decided to try and figure out what was wrong when I noticed the common theme was that the non-working speakers had Google TTS turned on, my son’s did not, it was using the default. I turned Google TTS off on the other two, and they are working find now, just not with Google’s voice.

Was this something temporary, or is something amuck?


(Jon) #698

@vervallsweg
I’m also getting a response status of 200 when I test the api, but when i hit /device
Any chance I can help test out the current mdns-lib you’re working on?


#699

Does anyone else have an issue with the device not going back to “Ready” after things disconnect?

I am trying to set up a really simple automation - my Chromecast audio is connected to a reciever, which is usually off. When it changes away from “Ready”, I want to turn the receiver on, and when it changes back, I want to turn it off.

It works fine - and much better when going from “Ready” to “Playing”, but when I stop/disconnect media, it never changes state again back to “Ready” (unless I do a refresh)… Any idea what the issue is?


#700

Yep. Kind of crappy. You ever talked to the other project members about a collaboration?

Yep. The web server goes down about twice a week. It doesn’t like broadcasts to speaker groups with missing devices if I had to guess. I’ve redone my groups to have an announce-only group though of devices that don’t turn off and it seems to be doing much better.


(Ecallegari) #701

Yes, same here. Looks like Google changed something and the TTS is not working :frowning:

for now if you turn off google tts, it uses the amazon one. you’ll need to change one line of code in the cast-web-device and force it to one of Amazon’s voices for example:

//before return playTrack( textToSpeech(phrase, true).uri, 0, 0, true )
return playTrack( textToSpeech(phrase, “salli”).uri, 0, 0, true ) //ecallegari - default to Salli