SmartThings Community

[RELEASE] cast-web 1.0.0 - Chromecast Device Handler & SmartApps

dth_av
requires_server
project_av
chromecast
googlehome

(Tobias) #618

This is because you’re not queuing the audio, you’re basically telling it to play two tracks at the same time.

Easiest fix would probably be to add a wait command with the length of the first audio file. Insert that in between audio file and your message.

Oh that’s because I messed up :joy: . cast-web-api v1.0.2 is v1.0.0, I had to increase the version number for npm to publish it.


(Ryan ) #619

Hey there, tried that to no avail. Just have silence from the wait period. Attached is the internal setup for the speaker.

I get the beep to tell me it’s recieving something but no audio message.

Tried even just a simple. If this button turns on with the main speaker speak text hello and resume.

Should I be using another method to trigger tts?


(Tobias) #620

I’m on the train back home right now. Will look into it tomorrow.

Maybe you can try using the speak() method in webCoRE? playText should do the same but, you never know :joy:


#621

If i set volume in this Smartapp will it overwrite what is in the Google Home App? The Ghome Routines are really bad (I had to setup 4 routines to set the volume at a specific time and it didn’t work).

I am trying to set the volume of the homes to 30% (WAF)


(Tobias) #622

Yes. Google Homes / Chromecasts only have one volume ‘slider’. So if you adjust the volume through cast-web you’re actually sliding the same slider you’d in your Google Home app.
However there is a bug (or maybe intended by Google) for months now that although we’re talking about the same volume ‘slider’, the values can be slightly off. There’s a detailed description here: https://github.com/vervallsweg/cast-web-api/issues/72


(Albulg) #623

The Cast-Web api appears in my list of Things… but I can’t access my speakers. It gives me a list of all my discover-able speakers and speaker groups but when I add them nothing else appears in my Things list… is there anything else I have to do? I did have to delete and re-install the device handler as before then I was getting an error notification. Everything else appears to be running ok?


(Peke) #624

Does somebody have it working with blue iris streams, that it streams a camera to a compatible chromecast?


(Albulg) #626

Managed to get it sorted. Didn’t realise there were 2 device handlers that were needed to install :blush:


#627

Im having an issue with accessing the device page. The server is set up and working correctly as I can start and stop playback of the GH Mini I added for testing from the My Things list, however whenever I click on the Device I see the loading icon then the I get returned to the list page again. Im also not able to trigger playback on the device from webcore using the following script:

Any ideas?


#628

To add to this, after reinstalling the device handlers and smart app I also only see the GH Mini device now as cast-web-device. According to the FAQ found here this is a comms error between my PI and the ST hub, but I can get at the server on port 3000 on the pi via the browser on all the devices I tested from on my network. and there is no firewall between these devices. I have also tried hitting the refresh button under the cast-web-api device and nothing changes.


(Aesgarth) #629

Can this run along side Assistant Relay, on the same raspberry pi? or am I going to run into a world of problems?

Edit: Never mind, I think I’ve worked it out for myself that it will work fine. My post was made from a too early in the morning, pre-caffeine state.


(mike) #630

Is it possible to change the accent to british?
or even better, to have same voice as google assistant?

TIA


(Aesgarth) #631

That’s in the settings for each speaker I think.

Smartthings App, select the speaker, click the little gear icon (top right of the screen) then scroll down to…

Use Google’s TTS voice? (turn this on)
And then below that
Google TTS Language.(for me this is en-GB)


(mike) #632

Thanks. I tried that but I then get nothing from that speaker.


(Tobias) #634

What’s your api version? And what SmartApp are you trying to use it with? It only supports speak() playText() = speech synthesis capability.


(mike) #635

sorry, it’s working fine now. it seems to do nothing for 5 mins or so then works fine.
Thanks


(Hans) #636

First of all, thanks for a top solution. I’m from Sweden and get a problem as soon as I use åäö. No tts at all. The assistant language is set to Swedish in the smartapp. I use “device speak text” in webcore. Am I doing something wrong or is there no support?


#638

@vervallsweg Is there anyway to get an mjpeg stream sent to the devices? I’m trying to get the show me the “Security Camera Name Here” to work with unsupported cameras using blue iris. I thought that H264 was supported and Blue Iris has an H264 stream, but I can’t get that to cast via the URL.


(J.R.) #639

That would be sweet


#640

Ok I believe I’m pretty close to getting this working. I am able to play an .m3u8 test file from apple via a manually edited preset. @vervallsweg Can you add an option in the preset configurator for application/x-mpegurl and application/dash+xml. That will add the option for HLS streams and DASH streams.