[RELEASE] cast-web 1.0.0 - Chromecast Device Handler & SmartApps

dth_av
requires_server
project_av
chromecast
googlehome

(Tobias) #248

Both of you just summed up the problem of HDMI CEC. It is a standard, however no manufacturer implements it in accordance to the standard 100%. LG wants its TVs to work with LG HDMI devices over CEC, just like Samsung focuses on its own devices. They don’t care for others, they don’t care whether it works with their own devices in a year from now.

Probably LG has some custom code to turn off their TV from their BluRay player (etc.) or maybe they just thought it was a bad idea to let a connected device turn off the TV in the first place and never implemented it.


(Matt Behnken) #249

Embarrassingly I didn’t even know what a crontab was until today, lol. I was trying to use the @reboot command on the command line instead of using a crontab in terminal or creating a daemon. Also, initially I never cloned the “FOREVER” repo since I didn’t realize it was a repo and not a terminal command. I’ve learned a ton about terminal and command line trying to get this thing going 24/7 without launching it manually every reboot on my computer and leaving my computer on 24/7. Using Dory.js Android app now on my stay at home tablet, and it’s set it and forget it.
Thanks again for setting this up.


(Ryan Worrell) #250

So I finally got around to updating all the code, got node.js working on my pi, was able to add my Google Home devices, and volume control seems to work fine but anytime BigTalker or Speaker Controller sends TTS to the home it never actually plays. Anyone else seen this issue and know what I might be missing?


(Tobias) #251

Are you running v0.2.3 of the API? If you enter the IP of the API into your browser, does it confirm v0.2.3?

Just tried it with speak() and music player capability, both works fine for me. Even volume change. And yes, resume is coming soon.


(Ryan Worrell) #252

Hmm, no I show 0.2. I installed it via “npm install cast-web-api” but perhaps I should be using git clone instead from the github link for the latest version.


(Tobias) #253

Yup I dont update the npm package right now. Will push it as soon as I figure out some stuff. The reason why i pushed it there was for people to install it globally and then just call it from the command line, without worrying about the installation location. Never really got it to work.

Just git clone ‘repo adress’, cd into the cloned repo and run npm install. If you want to update it afterwards just run git pull and your running the latest version!


(Ryan Worrell) #254

I just went ahead and deleted my folder and reinstalled from git and ran npm install. This time I am on 0.2.3 and TTS is in fact working now. Thanks for your help and thanks for all your work on this!


(Michael Salerno) #255

Having trouble updating I think. The web shows me as version 0.2.2 not 0.2.3 have even started fresh by cloning the repository again and still only getting 0.2.2. Anyone run into this?


(Tobias) #256

Stupid question: have you restarted it, after updating?

Are you running linux and started it with forever start {command}? Then you’d have to stop it with forever stop {cmd} and start it again with forever start {command}.

If that’s not the case, please post some more info like os, device.


(Michael Salerno) #257

Yes I am running it on a Pi and did stop and restart but still only seeing 0.2.2


(Tobias) #258

Run pgrep node, stop it pgrep node again, to make sure it’s totally stopped. Please pm me :slight_smile:


(Sidney Lucas) #260

I know I am missing a obvious thing. And I cant seem to find the information. Where do I edit presets?


(Tobias) #261

There should be a button in the service manager. you select the device scroll to the bottom of the page and click’Edit in browser’ it even copies the preset for you.


#263

I noticed two things with the latest cast-web-api (it may have present before, but I’ve only noticed it now after deleting and re-installing the two smartapps-

  1. I have one specific GH device and a GH speaker group that share the IP address 192.168.1.70 (the GH device is port 8009, the speaker group is port 42929). Is this typical that the speaker group will use the same IP as one of the GH devices? (I realize this probably has nothing to do with cast-web-api?)
  2. When adding 8 devices in the cast web service manager, I noticed that for each device the default device type assigned is “video” and not “audio” for every device. Shouldn’t the default be audio and not video? (For the record I have one Chromecast HDMI device, so perhaps that made it choose video for all of them?)

(Tobias) #264

Yes. This is how the cast groups are designed. All members automatically negotiate a ‘group master’. This master is the device your application is casting to and the is handling syncing everything.

This switch is basically obsolete. It is not used in the dth anymore. I didn’t remove it yet since I’m not sure if I might need it again one day :wink:


(Migt moggy) #265

Would anyone have the time to help me get this up and running using an old android phone as the server?

I have followed this guide, downloading terminux etc. I however am so new to node.js i dont really understand it or how to take your code and run it on (or should it be ‘in’?!) node.js.

helpp


(Migt moggy) #266

Hi Renuka

Would you be able to help me?

I have tried to follow https://medium.freecodecamp.org/building-a-node-js-application-on-android-part-1-termux-vim-and-node-js-dfa90c28958f to get node.js on an old android phone so i can use it as the server.

Problem is, i have absolutely no idea what to do next to get this chromecast handler to work- i’m so new to node.js :frowning:


(Matt Behnken) #267

really ANY hosted audio mp3 url can be posted into the webcore playtrack url. I use it for a cuckoo clock piston for instance, just found some cuckoo sounds online and copy pasted the link for example. Also, door chime sounds are really limited so I found some much nice ones etc…


(Matt Behnken) #268

I use the android app called Dory.js it has some nice options that are a tiny bit easier to use.


(Matt Behnken) #269

For group sync, is a requirement that you created the group in the Google home app first? Google home doesn’t group Chromecasts and Chromecast audio together. If I create a group by adding the cast web smart app, it doesn’t create a device in ST to select, nor does it cast to the whole group when I select the original device designated as the audio group in the cast web app.

Update: so I read above and I think that confirms what I was asking.