[RELEASE CANDIDATE] Jasco/GE Z-Wave Plus On/Off Switch (14291) With Double-Tap and Associations

Here is the information from IDE. If you could tell me how to take live logs, I’d be happy to do it. I have an additional one of the same switch to test on.

The supported button values are showing in the IDE, so the handler is working to add those, and you can control it in webcore. It is odd that the app won’t update with the new values. My guess is this is likely related to some sort of device caching issue with the new app, which many people have been having trouble with. Basically, that is where the app and Smartthings cloud has the wrong device presentation “stuck” somewhere. Sometimes, this flushes out on its own in a couple days. Other times, the only way is to exclude and re-add the device. Did you try assigning it to stock, then going back to the custom handler? Some also have cleared the app cache on their phone.

I could be missing something, especially since it is a slightly different Honeywell switch, but I would be pretty sure it is a presentation issue in the app itself. To look at live logs, you can go into the IDE and click “live logging”. Then go to your switch and click it up, down, double tap up, and double tap down. Then you can paste the logs here. Also, if you can click “list events”, after doing the presses, and list that here, I can double check if it is possibly some other issue.

I’m having the same issue. I had to roll back the code to the previous version because I couldn’t see the new buttons in Automations and my existing double-tap actions (button 1, button 2) in Smart Lighting stopped working.

Yeah I’m not sure why that’s happening. I have the switches and they show up in mine. Are you getting the supportButtonValues all showing? Maybe its a different hub or switch? I’m on a V3 hub and there are so many versions of this switch its hard to figure out where this is going wrong.

Yes that would be the case for anyone upgrading. The button values all changed with this update. Before there was “button 1” and “button 2”, but the new app only recognizes “button 1” and nothing else. Then it assigns different “supportedbuttonvalues” to that button one. So I had to redo the handler to move everything to button one and use supported button values of “up_2x” “down_2x” etc. Therefore, any smartlighting automation would need to be deleted and redone. That was the only way I could get it to work with the new app’s automation screen. Also, many regions do not support smart lighting and for those people, after the new app upgrade, they couldn’t use the old handler at all unless they used webcore. I added this warning to the code:

*   Button Mappings  NOTE - THIS IS A BREAKING CHANGE from prior versions and uses a single button.  
 *                    ALL prior automations will need to be re-programmed or updated when updating this DTH from old versions:
 *
 *   ACTION             BUTTON#    BUTTON ACTION
 *   Double-Tap Up        1        up_2x
 *   Double-Tap Down      1        down_2x  
 *   Double-Tap Up Hold   1        up_3x
 *   Double-Tap Down Hold 1        down_3x
 *   Double-Tap Release   1        down_4x

If you have smartlighting and all was working fine, it is best you just stick with the prior version if you don’t want to have to redo everything. I know this isn’t ideal, but I’m just working with what Smartthings is giving me with the new app.

1 Like

Just discovered the DH this weekend so this weekend I was able to switch over to this DH but not without issues. Currently I have two GE/Jasco 14292 switches with one switche is using a 12728 addon switch. I purchased both switches back in 2019 and found that my fingerprint ID was different that what was in the code. No biggie, I just added it in.

fingerprint mfr:“0063”, prod:“4952”, model: “3037”, ver: “5.22”, deviceJoinName: “GE Z-Wave Plus Toggle Switch”

First switch had no issues when I switched the new DH. The double toggle function worked just fine. The issue was with the second switch. This switch uses the addon switch. For whatever reason it would not register a double toggle. I tried deleting the device from Smarththings. Resetting the switch but still would not work. As a last ditch effort I powered off the switch at the breaker and turned it back on. Ha! It would would work. Not sure why or what was going on but something to try if others are having issues.

So now the only thing that isn’t working is my addon switch. I know the addon switch is just that. The switch just registers on or off regardless of how many toggles you do. Does anyone use the GE/Jasco Switch with an addon? Does it register a double toggle or is it simple on/off?

I have an add-on that does work with my zwave plus dimmer, but from reading older posts on here, the add-on is hit and miss whether it triggers double tap or not. It seems to be more of an issue with this on/off switch then the dimmers even. If you search this thread for “add-on”, There are several that report the main switch supports double tap, while the add on works for some and not others.

Unfortunately it’s going to be in the device firmware whether it works or not, and there’s no setting or code change that will get it working if it doesnt. I have not seen Jasco ever release firmware updates, and firmware updates with zwave devices, even if the manufacturer releases them, are not currently supported by Smartthings. Smartthings is currently beta testing zwave firmware updates, but Jasco is not on the list.

I can confirm I have the newer 46201 on/off switch with an add/on, and the add/on for that newer on/off switch does support double, and even triple tap, both at the main switch and add on. That switch uses central scene control for that which is an upgrade over older switches. I released an updated handler for that switch, more info here - [RELEASE] GE/Jasco 46201 On/Off Switch

But unfortunately, unless someone knows something i don’t, the only way to get double tap working with the add-on for the on/off switch will be upgrading to the 46201 switch. Your existing add-on would still work fine so only the one switch would need to be replaced.

1 Like

GE add ons don’t really have firmware. They don’t have radios and they aren’t smart devices. It’s the master switch that does all the thinking. unless you were referring to the firmware in the master switch.

Here’s a teardown of the add-on.

1 Like

Sorry I meant the firmware of the primary switch will dictate if the add-on can control double tap. The add-on just sends a low voltage signal back to the main switch. All the processing still happens at the main switch.

I had a non plus Jasco with no double tap, and then replaced with the new switch with double tap. Same add on as before now triggers double/triple tap without replacement of the add on.

2 Likes

That’s a bummer. It would be nice if the firmware was ungradable on these things. We really shouldn’t have to replace them if we want new features. Not sure I want to buy another one just to get this feature. I’m currently looking into other alternatives like smart replays. I have an Enerwave replay on the way. Curious to see how that works.