[RELEASE CANDIDATE] Jasco/GE Z-Wave Plus On/Off Switch (14291) With Double-Tap and Associations

Thanks for the device handler! I’ll use it to turn on all lights in our bedroom with one double tap.

Did you ever get this problem figured out? I have a room with 3 of the dimmers and have added all three to association group 3 of one switch. Single taps work the light attached to that switch. Double taps only operate the other two, not the light physiclaly attached.

Thanks.

No but I believe that’s how the association group works. It sends a
basicSet command to the other devices but not one to the device itself.
What I ended up doing was leaving the devices in the association group but
also running a routine on the button presses that turn on or off all 3
dimmers when double tapped. This way, the virtual double tapping in
SmartThings also works. The added advantage of leaving the devices in the
association group is that they respond faster when the switches are
physically double tapped.

Thanks. I ended up doing the same thing. It works okay, but the light physically attached to the switch responds slightly slower than the ones in the association group.

So after reading all the comments I am still confused,does this work with GE Zwave plus dimmer 14294 or only work with zwave plus switch 14291 ?

This thread is for On/Off switch, 14291. There is a separate thread and device handler in the link below for the dimmer 14294.

1 Like

Just installed this because I want to be able to double tap the down button on my ge z-wave plus wall switch to lock the front door. But, I cant quite figure out how. I added the device ID of the door lock and hit save. It said it was checking the health of the device and just kept spinning for over 2 minutes.

Further, just by entering the device ID, how would it know to send the lock or unlock command?

Further, watching logs, if I press the double tap button in the app, it reports. If I double tap the physical switch, nothing.

Ok, think I figured stuff out.

I was trying to get double taps to lock/unlock my zwave lock, but it looks like this wont do it. I tried adding webcore to accomplish what I want but it looks like this DTH doesnt report the doubletap command to smartthings and only sends it to another switch directly.

I was wanting double tap down to lock the front door. But, doesnt look like thats doable.

1 Like

It will work. The double tap actions show up as a button in other apps. It sounds like what you were doing was setting up associations, which is different. I don’t use WebCore but in Smart Lighting when I select the switch, it shows me two available buttons. Button 1 is double tap up/on and Button 2 is double tap down/off.

@65fastback
it took me a while but I finally have this working in WebCoRE. Initially i was unable to see the device as a button because I had already imported it into SmartThings (and WebCoRE) before changing the DTH. So I had to go in and remove the device from WebCoRE and add it back in again. Then it picked up the new capabilities of this new DTH.

Then I was able to select either the Switch trigger or the Button trigger. Button #1 is double-tap ON and Button #2 is double-tap OFF (WebCoRE shows 32 possible buttons…yikes).

Works like a dream. I didn’t even know this was a feature of these switches and now that I know it’s available it opens up a whole new set of possibilities for my home automations.

Great DTH… Even more happy with my investment in these switches now.

1 Like

I’m trying to setup some “Smart Lighting” “apps”, one for double-press up, and another for double-press down.
Unfortunately I can’t see how to set which ‘button’ they use. It lists a ‘button’ for the GE switch which responds to double-up, but I can’t see how to set that to be button 2 instead.
I can see under the API webpage, under Home->SmartApps->SmartLighting that they’re both set to button 1, but can’t work out how to change one of them. I’m new to SmartThings so I’m probably just missing something trivial.
Thanks in advance for any help.

One question… I previously installed several of these GE switches around my house and then I installed this new DTH. The NEW switches that I add are automatically using the new DTH and all is good. I know that I have to go back and change the previously installed switches to use this DTH…and I’ve been doing that.

However, when I change the previously installed switch over to use this new handler the ICON for the switch in the SmartThings apps stays to what I had previously set it to and does not change to use the new icon that is in this DTH. I’d really like to get all the icons in the SmartThings app to have the same icon (new)…how can I do this? I don’t see where I can pick this icon from any of the categories that are in the app. I’ve tried removing a switch from ST and then adding it back in again…but it just got detected as a GE switch and did not use this DTH. Granted this is getting picky…but I like the look of the light switch icon that comes with this DTH…what can I say.

I suppose I can answer my own question here…

In order to get all the icons in the ST app to be the same for the switches that I had previously installed I had to remove the switch from ST and then reset the switch back to factory settings, which is a bit of a pain as the sequence has to be done precisely and within a specific amount of time or this switch does not recognize it. But anyway, once they were reset back to the factory settings I was able to re-import them back into ST and they were then detected with this DTH and they get the correct icon.

1 Like

@nuttytree and everyone…

Here’s an update that’s probably significant. There is a newer version of this switch being sold now (I got 3 from Amazon recently and they are all the same). The new versions all are on firmware 5.22 and this DTH only knows about firmware 5.20. Here’s the actual string I’m shown from ST:

Raw Description zw:L type:1001 mfr:0063 prod:4952 model:3036 ver:5.22 zwv:4.54 lib:03 cc:5E,56,86,72,5A,85,59,73,25,27,70,2C,2B,7A role:05 ff:8700 ui:8700

Out of the box with no changes these switches are detected as the Standard Z-Wave switch. You can manually go in and change them to use this DTH…however, nothing I could do would allow me to get the double-tap feature to work. In fact they didn’t even show that they had any buttons at all. So, out of desperation I decided to dig into the DTH and I made 3 small changes and finally got this to work. The update will even get these to detect properly when installing new switches.

I’m not claiming to fully understand any of this…but based on reading this thread and looking at the DTH I made a couple changes, here they are:

I added this line, to around line 56:
fingerprint mfr:“0063”, prod:“4952”, model: “3036”, ver: “5.22”, deviceJoinName: “GE Z-Wave Plus Wall Switch”

I then changed the configure and refresh sections to modify the delay (based on reading thru here) so that they now read:

delayBetween(cmds,650)

Not sure if I needed to change both, but it seemed logical to update the configure section for adding new switches down the road.

With these changes everything is looking good and the double-tap feature is working. Just thought everyone should know in case some folks purchase the new version of these switches like I did. They can work, you just have to make some updates.

Initially added my…

zw:L type:1001 mfr:0063 prod:4952 model:3036 ver:5.20

Switches as Z-Wave Switches. Added the DTH linked in the first post via IDE. Changed my Device Type. I can DoubleTap from the app but I cannot DoubleTap on the switch itself.

I hit the up toggle twice and nothing happens. I am just looking for it to show as activity in the app/IDE before I do any configuring.

I had some that wouldn’t take right away. What I did was removed the switches from ST, then reset them to the factory settings (triple-tap up followed by triple-tap down…timing is important. LED will flash 5x when you did it right). Then I manually added them back, trying to force them to use this DTH. That seemed to work better for me. Also, up higher in this thread it talks about editing the response time which is another thing you could try. I found that for some of mine that if the switch did not add into ST using this DTH that the double-tap feature would be the one thing that didn’t work. So getting it to discover with this DTH seems to be very important.

Thanks. I removed the device and re-added it and it automatically picked up the new DTH however double taps are still not being recognized. How long do I have to wait between taps? Maybe I am not holding my tongue right.

Go into the ST IDE and look at the devices that are listed there and find the switch you just added. What does it say in the “Current States” section? Specifically, the numberOfButtons.

image

You want to see “2” there. If you’re not seeing 2 and instead it sees 0 then try pushing the double-tap button in the ST app on your phone. Sometimes I’ve seen that “wake them up”.

If that’s still not working then modify the your copy of the DTH and find the Refresh() section and change the value from 500 to something like 650 (again that is discussed in this thread). These switches apparently need to send back a lot of info and having a longer delay can assist making sure all of it makes it.

Oh…and the time between taps should be fairly quick. if you’re too slow it won’t count it as a double-tap.