[RELEASE CANDIDATE] CoRE (Community's own Rule Engine)

My github integration malfunctioned. I did not get past the ‘fork’ instructions. Now I cannot see an option to correct this. Please help.

@ady624 is there a problem with time capability right now
im installing for a friend and problems arise if i select time capability then after that it goes blank or after selecting any option.
anyone else?

Check that the timezone was properly set in the IDE

Doh! :stuck_out_tongue:
i turned off location services b/c i didnt want my phone to be messing up his presence

thanks @ady624

@ady624 are there any safe guards/rails built into CoRE? E.g. checking for infinite loops or some rate limitations? If not I think that would be a very valuable feature to have built in by default - advanced users could override them but to truly make it new user friendly and avoid accidental abuse when interacting with device handlers.

@ady624 you may want to update the thermostat capabilities section, ST has changed the Thermostat Mode enum from emergencyHeat to emergency heat

You may want to check out


1 Like

Thank you @RBoy, I don’t think they did - but I had an error in the emergencyHeat() command that was hooking up for “emergencyHeat” instead of “emergency heat” which means state restoration did not work when previous state (the one being restored) was “emergency heat”.

v0.3.16d.20170828 - RC - Fixed a problem where the value for emergencyHeat() was mistakenly set to “emergencyHeat” instead of “emergency heat” - thanks @RBoy

1 Like

Perfect bro ! Thanks ! :calendar:

If you are still using CoRE, please update to the latest version as soon as you can. Here’s what changed:

v0.3.16e.20171219 - RC - Replaced recovery safety nets using unschedule() with a much more optimized method that does not affect ST as much as unschedule() does

This is important as CoRE has been identified as a major choke point on a certain method that it uses (ST describes that as expensive in their documentation. As it turns out, it is. With ST’s help, CoRE is now able to recover from timeouts much faster and with a lot less resources than by using its own recovery safety net. You should also consider moving on to webCoRE instead, as CoRE is no longer actively maintained and only gets critical updates.

Thank you


If you still see the red UPDATE banner after updating CoRE, please update it again in your IDE. The red banner should disappear. Thank you.

The old version’s dashboard will stop working on or after March 1st 2018 and all older versions of CoRE may stop working on or after May 1st 2018. Please update to avoid any interruptions. Thank you for your understanding.

1 Like

Well, based on this not only did I update, but got brave and spent the evening moving over my remaining pistons. A couple left on pause until I know the new ones are good but one that I couldn’t master was the IFTTT executes condition. I took the URL the condition gave me and updated my IFTTT web hooks POST address and no dice. Thought it would be a slam dunk, but I am almost wondering if IFTTT is having a problem tonight. Will try again tomorrow.

Well, no change this morning. Decided time to sign up for the WC forum to get assistance. . . .and discovered blocked at work. Could do through my phone, but will just wait till I have time at home.

SSH tunnel to raspberry pi at home, “SwitchyProxy Omega” (chrome extension that makes it easy to switch proxies - though might take a bit of work if you wanted it to only apply to a single tab)

Our IT blocked a lot of sites when they installed… zscaler(?) Some for good reason, some because I think they just weren’t on the ‘whitelist’ - one of the volunteer fire department’s web sites in the area was blocked because it was “adult content” lol Had to email IT who white listed it. Probably be simpler to have your IT whitelist the site - though its a fairly simple email here, might be more of a process for you… in which case, see above ssh tunnel :wink:

1 Like

Thanks for suggestion but will likely just deal with it. I work for a giant bureaucratic machine of a company, especially in IT infrastructure, so doing anything outside the box takes monumental effort. I bet its just not classified in their system yet so hopefully will eventually just get classified correctly.

1 Like

Do you by any chance know which provider they use for classifications?

Palo Alto says it’s a Reference and Research site…

Unfortunately I don’t. I just tried to go to another blocked site (Google Keep) and it doesn’t seem to indicate who does their filtering. That being said, the webcore community site is not flat out blocked, it only becomes an issue when I try and log in or when I tried to create an account. When I clicked submit I get an unknown error but yesterday when I was trying to create my account it said error but had the name of my company listed, so I assumed it meant somewhere along the chain it was blocked. If it listed as research that would be odd to block so must be a break somewhere else in the chain.

I updated and UPDATE banner came back, so updated again and it’s still there. Will it still work after 3/1? (Note: The update option disappeared from github after the first update and I had to copy the code into the page. That worked)

@ady624 what does setTimeoutRecoveryHandler do, as in when does it call the registered method? I’m assuming it’s a ST api.

Ha ha, it’s an undocumented feature I added to ST myself - if you use it, ST calls that method if the execution times out after 20s. This way you can recover from a timeout error

1 Like

Thanks, a quick question on this. If there’s a scheduled timer setup (say repeats every 10 minutes) and it times out while executing the method, does that kill the timer in totality or just that execution and the next one will fire on schedule?