[RELEASE CANDIDATE] CoRE (Community's own Rule Engine)

5 switches. Different switches get missed. The thing that makes me think it isn’t signal flooding is that the missed light reports as already off even though it is physically on.

Oh… I guess it’s the Lutron integration. Don’t have any Cassettas, but I believe it is a polling based integration. Disable command optimizations and you should be fine then.

Leviton. Native integration using the standard Dimmer Switch device handler. I have disabled command optimizations and will see if that takes care of it.

Oh, Leviton. Is that zwave or zigbee?

They are Zwave.

@ady624 When using the custom command “deviceNotification” to send a message to my Samsung TV it doesn’t convert the global variable into the next. The speak and push notifications work fine.

Edit - Cloud Issue… http://status.smartthings.com/

@ady624 - CoRE is having issues today for me.

When trying to manually execute the following piston either via schedule or tap…

06d6b4e1-a88f-4931-9247-9e8fe59a1c9b  8:27:23 PM: trace ╔═══ Task processing took 63ms
06d6b4e1-a88f-4931-9247-9e8fe59a1c9b  8:27:23 PM: error ║░░░ ERROR: Error while executing processTasks: physicalgraph.api.StatusCodeException: Invalid http status code returned: 503 @ line 6729
06d6b4e1-a88f-4931-9247-9e8fe59a1c9b  8:27:23 PM: trace ║░░░ Rescheduling time triggers
06d6b4e1-a88f-4931-9247-9e8fe59a1c9b  8:27:23 PM: trace ╚═══ Processing tasks (v0.3.169.20170104)

Trying to “Done” out of CoRE…

7b15bf15-7df5-4d18-b70e-d4125d6a9b76  8:28:33 PM: error physicalgraph.api.StatusCodeException: Invalid http status code returned: 503 @ line 2495
7b15bf15-7df5-4d18-b70e-d4125d6a9b76  8:28:00 PM: error physicalgraph.api.StatusCodeException: Invalid http status code returned: 503 @ line 2495

Tried rebuilding and recovery request, no luck. Happening with other pistons also.

I’ve got a Xiaomi Cube - 7 buttons basically. Ideally I’d like a big single piston with 7 if/else is this even feasible?

You can use a switch statement for this. Someone above did this alread with 25 buttons or so.

See the last post was Sept 2016. Is this thing still in RC mode, or is it good to go? Wanting to install it, but not unless it’s in a stable condition?

It’s good as is but a much better web based version is being developed and in Alpha…

CoRE is very stable. You can feel free to use it. You will likely find it is far more reliable than standard ST apps.

Yes @ady624 is working on a web version that is easier to use, but it is alpha now with an early May beta date.

Thank you for the replies. I’ll look into installing it.

Hey guys - I’m using CoRE v0.3.169.20170104. It’s working fine, but I would like to upgrade to the latest stable version. But before I do that I wanted to make sure it is fully backward compatible with my existing CoRE rules. So I can just updated the device type to the latest, or do I need to be concerned about breaking something? Thanks.

Development on the new version is moving quick. It might be worth checking it out now and getting the hang of it instead of upgrading your old CoRE installation. You can run them at the same time and pause your old CoRE piston while testing your new one from webCoRE.

And here’s the assistance thread…

Here is a little video I made mostly using core. This shows a very small part of the potential of this great smartapp. thanks @ady624


I wonder if someone can help. I have 45 pistons with varying degrees of complexity that I have tuned over the last year or so. As I have added pistons, the user interface on the app has got progressively slower. I have now got to the stage where the app times out when I try to edit any piston. This means that I can’t edit or delete anything and effectively cannot change anything in CoRE.

I suspect that there’s a timeout in Smart Things that stops a Smart App if it executes for too long or seems to hang. I know what I need to do to move forward - separate out my pistons into multiple CoRE instances, but I am unable to access any of my pistons as the UI always times out. This means that I can’t access any of the logic to set up new instances. The thought of deleting CoRE and rebuilding the logic in all those pistons is too bad to contemplate.

Does anyone have any ideas - @ady264 - any help for a desparate but passionate CoRE advocate?

Yes you will need to split CoRE into multiple instances.

Have you tried accessing the pistons via the devices that they use? Go into a device in the ST app. Then hit the SmartApps tab ( the one that shows the list of all smart apps the device is used in) and open the piston from there. Try deleting it or modifying it.

Another approach is to log into the IDE, go to your Location. Then go to the bottom of the page and click the list SmartApps link.

Then click Edit

Find a CoRE piston and hit uninstall.

ST lowered the timeout interval recently. Update CoRE, it may help. Start looking into webCoRE… :wink:

1 Like

Thanks @whoismoses and @ady624. I managed to delete some pistons by accessing via the devices and now have split down to multiple instances. I’ll check out webcore!