[RELEASE CANDIDATE] CoRE (Community's own Rule Engine)

Thanks! That’s what I figured, but didn’t want to put any work into something I didn’t expect to work.

webCoRE may get some super-global variables that work across multiple instances, but I can’t guarantee it will happen.

My 5 hard-wired PCs still work. However, there were a time or two where one or two of them stopped responding to WOL commands. The fix was to disable the network adapter then enable it and then restart. This happened to 2 separate PCs.

Never could get WOL to work with Wifi adapters. For those (3), I used Iris Smart Plugs and enabled Boot on Power Restore in BIOS.

For my 2 laptops (MacAir and Dell), there is no solution that I know of.

I can also turn them off via ST, use mouse activity as a presence sensor, open up web pages, start Pandora, WMC, KODI or whatever I choose with a Tutorial I’ve done here:

This would be super cool but from my understanding, we shouldn’t have the “Slow Down” issue with webCoRE right? The reason I use multiple instances of CoRE is that after about 40 Pistons, it took forever to right new Pistons. Now each instance which have no more than 15 Pistons in each, are snappy and very responsive and rarely crash when writing or editing Pistons.

Keep like things grouped in a certain instance and make use of Virtual Switches when needing to communicate across instance (if needed).

webCoRE is largely web and offline (loads all data at edit start, no other web requests during the editing process, so editing is local and fast).

CoRE’s issue was that when opened, it goes through each child to load data about them. With many pistons, that starts to take way too long. Lesson learnt, webCoRE caches piston states for fast retrieval.

1 Like

tried installing from my phone at work with the git Hub raw code. when I paste it says to many characters or something like that. do I have to do this from a pc?

I’ve just started using core and LOVE it in fact I’m converting and writing all my routines which is a little time consuming so my question is should I stop and configure this new core?

do you need a pc or is that an option. I mainly use my phone or tablet.

and one more thing I have a shut down piston that seems to running great but I want it to trigger only when both presence sensors are gone it keeps triggering when just one of us leaves the house. here’s the piston

You may want to wait for webCoRE. Hoping to reach beta by May 1st and RC by July 1st.


I just got home and just installed webcore from my tab. I can’t get past the authentication part of the url desktop version. It ask for my location password which I put in and it just refreshes and says nothing. I’ve enabled oath token and I have the gui on my ST APP. I was able to go through the set up process to select every devise I have but can’t go further. Need I use the pc for this ? And I still need to know the logic that allows my wife to leave and not run shutdown when I’m home. Lol

You don’t necessarily need a PC but that’s the beauty of it, using all the big screen real estate. Once you finish the setup, open webCoRE from the Automations tab, then from there either open the dashboard on your phone or register a browser on your desktop. Just follow the instructions. But be aware that this is alpha and a lot of things (like time conditions) do not work yet. Ye be warned :wink:

Can I start building though without having to start over. I have pistons now that I’ve been working on.

If you’re not using time comparisons, probably yes. Timed conditions don’t work either (stays, changed, etc). It depends on what you are trying to achieve. But simple things are doable. Heck, I got complicated stuff running on webCoRE too, but I would wait until at least beta if I were you. Feel free to try it out and experiment, but expect a few things not working, they’re not bugs, it’s just that I haven’t attached all the pistons to the engine shaft yet ;))

OK I’ll wait since I’m still getting familiar with the simple basic s of core. But please tell me the logic to only allow shutdown to run IF both presence sensors have left. I’m going crazy

#define shutdown please

No motion in house for x minutes
Both presence sensors gone
Turns of pretty much everything. Goodbye/leaving the house
Turns to away to set my alarms.
If one presence is home don’t shut down.
I have 4 motion sensors so I set small time frames because I’m bound to trigger one.

That’s one of 15 pistons I’m working on for now but I’m learning. I need doggy door too from @bamarayne lol

Slowly changing from shm to full core automation. It’s getting real…

I have a CoRE piston running to turn my outdoor lights off at sunrise. These lights are all on Leviton switches. I have had periodic days where one of the lights simply doesn’t turn off in the morning. Happened again this morning. In looking at the event logs, each light that is successfully turned off shows an “APP_COMMAND” and then “DEVICE digital the switch is off.” The switch that remains on shows no event activity that morning. At the same time, the ST app reflects that switch as off even though the physical switch is clearly on. State corrects itself if I turn the light “on” (even though it is already on) and then off in the app.

I’m unclear what the event logs represent, so not clear if the absence of the APP_COMMAND for a single switch means the switch couldn’t be contacted to issue the on/off command or that the piston failed to attempt to issue the on/off command. So not clear if this is a failing piston or a device communication issue.

Thanks for any thoughts/tips on what might be happening.

If you go into advanced settings at the bottom of the piston you will see an option to disable command optimisation.
Enable it and if your light state gets out if sync it will still run the piston.
Not an answer as to why, but a way round the issue.

So, you believe the light state gets out of sync for some unknown reason, the piston runs and skips the device since ST tells CoRE it is off already. Disabling the optimization feature would send the off command anyway, to a device ST thinks is off?

Wonky, but I’ll try it. :slight_smile:

TBH I don’t know but reading your issue, this is what I think is happening.
I also disable this anyway for all my pistons to ensure they run in case there is a state mismatch.
Good luck. :slight_smile:

Grazie mille. Will give it a try.

How many lights are you trying to turn off at the same time? Is it the same light not turning off every day?

If # of devices is large, you may be flooding your radio network. You could add a wait 10s and another Turn off.

If it’s the same light maybe there is something with the radio network, does that light turn on/off consistently by hand?