[RELEASE] BI Fusion v3.0 - Adds: Blue Iris Device Type Handler, Blue Iris Camera DTH, Motion Sensing

I didn’t have a reservation or port forwarding set, but I was using the current assigned IP address. Nonetheless, I set up both and retried. No joy.
Everything’s on the same network and Use/install Blue Iris Server” is on. Firewall is set to let BlueIris in and out.
The Blue Iris app on my phone works just fine so I know the information is getting out. In fact, I can call up the BlueIris server IP in my browser on my phone and I can get in that way as well.
If it’s any help, I’m using the SmartThings WiFi mesh as my WiFi connection and that’s where I set up the reservation and port forwarding.

"
The Camera feed function is beta at best."
Understood. Disappointing, but understood.

I’m looking for a little help with a couple of problems I’m having.

I had BI Fusion set up and working well a few of weeks ago with just a couple cameras to test it out and get a feel for what I could do with it. I had then been upgrading my network (new router and switch) and upgrading/buying new cameras for around my house. Now only one of the cameras I had set up before is working (expected some problems like this), and BI Fusion is giving me a hard time updating settings.

I keep getting an “Error Saving Page” error on the top of the screen in the app when I try to save the main page after updating settings. This is (I think) leading me to not be able to update much of anything. I can’t delete cameras or the server (tried in the ST app, the BI Fusion smartapp page, and in smarthings IDE) and even though it says they were removed, nothing actually happens. I tried updating the password for the server but it won’t actually save the change. I tried fully “removing” the BI Fusion app, but I get an “An unecpected error occurred” error on the top of the page. I tried adding new cameras and it won’t save them either.

I wont pretend that I’m an expert, so any help would be appreciated, even just uninstalling so that I can start from scratch.

Thanks in advance.

@AJCam44… open your Smartthings page in an “Incognito” or “Private” browser page.

Hey sorry it started giving you issues. I’m about 99.9% positive what is going on. The BI Fusion app installs camera “devices” and updates them as you update settings, but deleting cameras can become a real mess, because it does a lot of error checks to make sure everything is installed correctly. The solution is not to actually remove or delete cameras, just change the short name and display name of the one you’d like to remove to the name of the new camera. I’ve had a lot of trouble trying to remove cameras, but renaming works.

The other thing you can try is to turn on the “Do not delete old camera devices?” switch in BI Settings>Clue Iris Camera Installation. It’ll stop trying to keep your camera device list clean and will let you save the settings as you click “done” out of them. It comes at a cost of abandoned camera devices in your device list. But once you’ve saved out of settings, you can go to those devices individually, make sure they aren’t associated with any other smartapps (because otherwise SmartThings will prevent you from removing them), and then delete them yourself. Just pay attention to your naming scheme so you don’t try delete a camera you are actually using (although if you do, and it actually lets you, you’d just have to go into BI Fusion settings and save them again, and it’ll remake the device).

Since you’re setting it all up and expanding right now, I wouldn’t try use the camera devices in any other smartapp until you get them all added, that will at least simplify the removing process if you need to.

The error in trying to remove the app is likely the same issue, it’s getting hung up trying to delete camera devices, which are likely associated with a smartapp so SmartThings fails the deletion, throwing the error you see. Turning that switch above on, saving, and then going back into delete the app and start over ought to work for you.

Last ditch efforts include going into the IDE device list and removing apps and devices there, and you can also call SmartThings and have them delete them. They can override everything, but I hope you don’t have to go that route.

Let me know if you still have issues, hope it works for you soon.

Alright, that narrows it down quite a bit, thanks! Can you make sure “Debug Logging On?” is set to on under Advanced Settings in the BI Fusion settings, open a browser with the Live Logging Page of the SmartThings API, and then go back into settings, click “Done” to close them, wait 30 seconds or so, then tap refresh on the BI Server device tile, and then go to a camera and tap record? Then grab screenshots (or copy and paste) of the logs for BI Fusion, the BI Server device, and the camera you used, and PM them to me and I’ll take a look? Please line out your IP, Username, and password in those logs so they don’t get posted.

Seems like you have Blue Iris set up properly if you can see the page on another device, and it sounds like your settings are good in BI Fusion too, so I hope I can see what is happening exactly when you get those errors.

@JMZ , I am not following how to setup Motion Alert or what it is intended for. Do you have any material you can refer me to? Can you also provide me a bit more information regarding the BI Fusion Custom Camera Trigger and what it is typically used for. Much appreciated.

The install instructions and readme information is all on Github now, I hit the edit limit of these forums to keep the top thread current.

The motion alert is to have Blue Iris cameras act as motion sensors for SmartThings. Once you have the cameras set up in Blue Iris for motion detection, which you would use to have Blue Iris record the event’s video locally, BI Fusion can take that motion detection and treat it like a motion sensor in SmartThings. So anything you’d use a motion sensor for, you could instead use a camera connected via Blue Iris and BI Fusion.

The Camera Trigger is the same idea in reverse. Normally you’d just have cameras see motion and then record it. With BI Fusion’s Camera Trigger, you can have SmartThings tell Blue Iris when to record. For example, if you have a contact sensor on your front door, and a camera overlooking your front porch, then you can use BI Fusion to have the camera record whenever that door opens.

The whole idea is to integrate Blue Iris and SmartThings (hence “fusion”). The cameras can boost the number of motion sensors in your SmartThings environment, and SmartThings can aide the camera’s detection and recording.

Some other examples are whenever my alarm is triggered or whenever the panic button is pressed all the cameras are triggered to record. So even if “the bad guy” (more like my robot vacuum) or whatever didn’t trigger the camera to record, SmartThings will make all the cameras record so I don’t miss anything. I have all my front cameras record whenever the garage door or front door open, same thing for rear cameras when the back door opens. I don’t use the Motion alert function much myself, because I haven’t fine-tuned the camera’s motion settings so I’d get a lot of false alarms. But I have them connected, just not connected to any other automation, so I can at least see the event history in SmartThings as I slowly mature my system.

Hope that helps. The directions on github should walk you through it, although I haven’t updated them for the new version 5 of Blue Iris. But it’s mostly the same.

hey @JMZ

I wonder if you can help please

I am struggling to get BI Fusion to work as I am always getting 401 errors from BI. Looking at my BI Logs, it appears that BI Fusion trys to log in but without transmitting the username/password. I can tell this because in the BI logs the username just displays a “?”. I also tried (testing) with an Anonymous account, although this time BI Fusion logged in, it was unable to change profiles as an example.

Here are some of the errors I am seeing from the ST side:

parsing results: profile is number ‘null’ (‘null’), signal is ‘null’, lock is ‘null’ (‘null’), triggered camera is ‘null’

error 3: msg.status returned 401

Retrieving Current Status
Polling. Time since last contact is 0.0011166667 minutes
initializeServer() called, debug logging is false, serverResponseThreshold is 5
Polling. Time since last contact is 8.5E-4 minutes
initializeServer() called, debug logging is false, serverResponseThreshold is 5

Thanks

You have the OAuth for the “BI Fusion” smartapp enabled and the “Use secure session keys…” disabled in the BI settings?

I do indeed. I can see Client ID and Client Secret in OAuth so I presume its enabled correct? Is there any other way to check?

Yes Secure session keys are def disabled in BI.

For clarity I am using ST Classics App

Also the user name your using is setup as an admin in the BI settings? and the url you have setup in the BI fusion app works when typed into a web browser? So if you have http://192.168.1.2 in the BI Webserver Host field and 81 in the BI Webserver Port field the URL to try in a web browser would be http://192.168.1.2:81 and the credentials you have setup in the BI settings work to access this site?

Yes the user is setup as Admin, and yes and on a browser it works as well (http://192.168.1.9) Ive configured a different port than 81 - that works in the browser

putting http://192.168.1.9 in the BI Fusion Smart app, and trying to save just gives me “An unexpected Error occurred” and I have to take the “http” out for it to save

Its strange as I can see the Smart App try to auth against BI as the number of logins in increasing

Any ideas @Terk?

What did you mean by

I also tried (testing) with an Anonymous account, although this time BI Fusion logged in, it was unable to change profiles as an example

How did you set that up to get BI Fusion to connect?

Just enabled the anonymous account to rule out any BI account issues. Did this through requiring no authentication on the webserver

Sounds like you had the URL and port and other settings correct at that time and the only thing that isn’t working are the credentials, I’d try changing the credentials if they have any special characters just to rule out an issue with the URL parsing those as URL characters.

It works! It was the special characters in the username/password

Thanks so much

2 Likes

Glad you got it working!

Hi, I’m trying to set up the motion alerts in blue iris. I’ve inputted the url, but I cannot find where to input the “wait at least xxx min between requests” option. I am using Blue Iris 5. Can anyone help? Thank you

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.