SmartThings Community

[RELEASE] BI Fusion v3.0 - Adds: Blue Iris Device Type Handler, Blue Iris Camera DTH, Motion Sensing

Hi JMZ, first apologies for the long post, I’ve tried to diagnose this myself so have included some relevant log entries.
I’m trying to get Profile Switching working but it doesn’t seem to work consistently.
My setup in BI Fusion is:
Auto Sync Profile to Mode: Enabled
Mode Home: 0
Mode Away: 1
ST Mode for BI Inactive: Home

I have 2 Routines, named Home and Away with the “Mode” set respectively.

I can manually trigger profile changes within Blue Iris Server and triggering my Away routine in the Smartthings App leads to BI Server changing the profile but triggering Home does not change the profile.
If I go into BI Server and “Sync BI to ST” then it detects the change in mode and switches the profile to inactive.

From my debug logs I get this (relevant logs only, oldest at the top):
Triggering Away routine when BI Profile is Inactive and BI Server is in sync:
4:44:25 PM: info HH execute(true, null, null), newMode: Away
4:44:25 PM: trace prefix(): Goodbye.
4:44:25 PM: debug getprofileName got 1
4:44:25 PM: debug getprofileName returning Away
4:44:25 PM: info Changing Blue Iris Profile to ‘1’, named 'Away’
4:49:23 PM: debug GET /admin?profile=1&lock=2&user=**&pw= HTTP/1.1
Accept: /
User-Agent: Linux UPnP/1.0 SmartThings
HOST: 192.168.2.207:81
4:44:25 PM: info BI_modeChange detected mode now: Away
4:44:25 PM: debug BI_modeChange matched to Away
4:44:25 PM: debug BI_Found profile 1
4:44:26 PM: debug Blue Iris Profile set to Away

But, when I execute the “Home” routine, with BI profile confirmed to be “1” and BI Server app in sync with profile.
4:47:55 PM: info HH execute(true, null, null), newMode: Home
4:47:55 PM: trace prefix(): Welcome Home!
4:47:55 PM: info BI_modeChange detected mode now: Home
4:47:55 PM: debug BI_modeChange matched to Home

and that’s it. There doesn’t seem to be a http request to the server to trigger the profile change.

It has worked fantastic, allowed me to remove the other PTZ and the other motion detection (via BI) app that I had which was a different oath per camera as opposed to 1 for BI. Thank you!

1 Like

I can’t for the life of me get the video feeds to work. Motion is working great, and the record trigger is functioning just fine. Also changing everything with the Blue Iris server part works fine. Every time I try to connect to the stream i get this error in logging:

physicalgraph.app.exception.SmartAppException: Not Found

I’ve verified the URLs from the Device in a browser and they are working fine. I’ve tried it externally and locally. Any ideas?

No special characters in User/Pass or short name.

Yep, I can’t figure it out, put it in there hoping it’d work for other folks. Just tried a bunch of other things and still couldn’t make it work out. I really only included it because some folks want it; I prefer to just use the Blue Iris app because of all it’s other capabilities, and let BI Fusion do all the ST<>BI integration. I’ll pull the code if I can’t figure it out.

Any one have any luck with this or know more?

I just started setting this up today. Still going through it all and haven’t tested Motion triggers. I was able to setup a camera to show up in my device list and the video does work. Here is a screenshot. (disregard cam name, that’s obviously not my kitchen, lol)

2 Likes

@JMZ Hello, I noticed I got an error on one of my camera profiles a few minutes ago. Is this anything to be concerned about? Also, when trying to save in a profile it is giving an error as well.

image

I got this all setup last night. It’s working well! Live streaming is working on my LAN. It looks like i did mess up one camera’s config in BI. it’s stuck on motion active. But the other two are working correctly. A couple suggestions for easier setup:

  1. Can you output the web address for the motion events to the live log? This way you can just open live logging and then copy/paste and change the short name. I believe i’ve seen another smart app do this (maybe alexa helper?)
  2. The secure only web server check box terminology isn’t quite right. It has a different description in my blue iris.
1 Like

one more suggestion: allow re-naming profiles even is they are tied to a mode. I have one profile that is tied to two modes and i don’t like the label that was auto-assigned.

1 Like

I installed BI Fusion 3 over my old Bi Fusion 2. Installed as directed using the BI server setup on my LAN, and created one BI camera device . The profile integration works, as well as the live video stream, but I cannot get a camera trigger to work. The setup seems to go well with no errors, but when I execute the trigger, the camera does not trigger, and I get an error in ST api logging that says “‎4‎:‎13‎:‎25‎ ‎PM: error groovy.lang.MissingPropertyException: No such property: actionname for class: script_app_Blue_Iris__54acf991_499d_44bf_bdfe_0195ac2200f3_ver_0_5” . Can someone offer some help in resolving this. I had triggers working fine in the ver 2 BI Fusion. I have tried removing the app and reinstalling to no avail.
Thanks for any replies.

Thank you for releasing this code, it is great with cameras that cannot directly work with ST!

It took me awhile, but I was able to configure the Fusion, Server, Cameras, and Motions; however, setting to notify me on motion does not work. It is set correctly and I even added my phone number for SMS Alerts to no avail.

Not sure if it is related, but I see this error in the log:

7:12:28 PM: error groovy.lang.MissingPropertyException: No such property: actionname for class: script_app_Blue_Iris__22a77c88_e956_4508_9647_4faa31bc6f9f_ver_0_8

Any ideas?

I am getting the Could not adjust the blue iris profile. Any ideas

Maybe this would help: Blue Iris - profile trigger

Sorry for the delay in responses, life got real busy on me. Bunch of replies all together here, plus I did some feature adds and bug fixes, so please update to the latest code:

Reply 1:

Does everything else work? If nothing is working, double check your username/password/IP/port, and make sure your Blue Iris web server settings are set up per step 4 in the Install directions in the initial post ('Use secure session keys…" unchecked, etc). If it is the only thing not working, my guess is there is a trailing space behind a name or something, so double check your inputs there. If none of that helps, turn on debugging and PM me a screenshot of the logging so I can help you find the source of the problem. Hope you get it!

That code is part of the original idea that built BI Fusion (Fusion’s BI<>ST integration section does everything it does). So if Fusion isn’t working for you, it likely won’t either, they work the same way.

Reply 2:
@PashaF, @garhun, and @jasonrwise77: I found the bug that caused that error and prevented the Trigger from working correctly. I had a bad variable name. Looks like it’s fixed now. @jasonrwise77, I’m not sure I understand your two errors though, please let me know if you still have them both after the update.

Reply 3:
Video does work! Once I got home and could test it I had no issues, and others have it working as well!! I can’t seem to make it work over my VPN, but I think that’s a VPN issue because it’s perfect when I am on the local network. @riccanet, did you ever get your video to work?

Reply 4:
@plane you’ve been waiting the longest for a reply, are you still having the problem? From what you posted, the app is getting hung up once it tries to find a mode named “Home” in your settings for BI Fusion. My guess is there is a space or something where you typed it in BI Fusion, making it "Home " or something like that. Your settings are all correct otherwise since Away works. Just double check your Home entry (e.g. if you used iOS autofill for Home, it puts a space in to allow you to type the next word, so if you click the “Home” suggestion when typing, you’d have to delete the space).

Reply 5:
@prjct92eh2 thanks for the inputs!

  • I added an option to display the URLs for motion events. It doesn’t seem to display all your cameras in the log (if you have a lot anyway), but you’ll get the idea and should save most of the effort. (If anyone has a way to ensure all the “log.info” events are displayed within a for loop, let me know!)
  • Thanks for the update on the Secure Only dialog! I haven’t looked at it in a while. I updated everything.
  • I’m not following what you mean, “allow re-naming profiles even is they are tied to a mode. I have one profile that is tied to two modes and i don’t like the label that was auto-assigned.” You have one Blue Iris Profile you use for two different SmartThings Modes? That should work fine, and the name is just whatever you have the mode called in SmartThings…
1 Like

Thanks for the changes! I use BI Profile 1 for both my Home and Night mode in SmartThings. The app chose to label the profile 1 button as Night. I would rather name it Home, but there is no option to change it.

Gotcha! After a quick look, it’d take a complete overhaul I think to make let you choose which one, sorry. I’m glad it is all working for you otherwise though. The app is just looking for the first mode name in the list for each profile number, so it’s however SmartThings decided to list your modes when you were setting up BI Fusion (I just looked, mine is not in the order of modes in the SmartThings settings, nor is is alphabetical. Seems to be random so I don’t know how you’d control it.)

1 Like

I HAD things working very well. I added a bunch more cameras and changed some names around. 3 of the 5 cameras I have installed still work fine. 2 I can’t get them to work at all including being able to delete them. Also when I try to “Save” in the smartapp I now always get “Error Saving Page” and in the logs to correspond with that I get: “physicalgraph.exception.ConflictException: Device still in use. Remove from any SmartApps or Dashboards, then try again”

I’m really stuck. Any assistance?

@jmz nope. I actually just reinstalled everything today. I’ve tried downsizing the resolution of the streams from the cameras in the webserver portion of Blue Iris and still no change. I still get: physicalgraph.app.exception.SmartAppException: Not Found

Other people are getting video working so I must be doing something wrong.

Hi. I received a few notifications from the Smartthings app saying new releases were available and I should “Update in IDE”. Do I need to go and paste in new code in a similar fashion to the way I originally set things up in the IDE or is there an easier way?

Thanks,
D

EDIT: Never mind, figured out how to add Github as per the opening instructions and updated the device handlers and the smartapp. Once updated, do I need to do anything else or are they immediately working?

@JMZ here is what I found. I have an older Foscam PTZ camera and I configured it in Blue Iris to test and it works fine with video. So for some reason the Reolink 4MP cameras I have are not able to display the video feed. Any ideas? Resolution too high maybe?

Shouldn’t need to do anything else. If I change anything that would require more action I’ll definitely make it obvious. But if you have any issues, usually going into the smartapp settings and then clicking done will clear it up (it’ll re-initialize all the variables and settings, which could get screwed up in the update. I haven’t seen any issues like that though in all the smartapps I’ve used.)

I would email/call Support. I’ve had stuck device/app iterations before and they can go in and remove them with their admin controls. Just like any other device, you should just need to go to that device’s settings and click remove device (from the SmartThings App). The app will also show you what apps are using the device, so you can edit each app first (or you should also be able to force it). But if that isn’t working, talk to support. BI Fusion uses the shortname as part of the device ID, so if you just rename a camera, it’ll treat it like a whole new camera, creating it and removing the old name’s device ID. So now that I think it through, you can’t rename cameras. You’d have to first delete the camera whose name you’re changing, then go back in and add the name as if it were new. That is something I can fix though, I’ll take a look!

EDIT - It is literally 1 line of code to fix, but if I change it, everyone will have to delete their cameras and reset them up again. So I think it’s best for now to just say there is no way to change the shortname once it’s created without deleting it and then making a new camera with the updated shortname.

Of note, to work around this to some degree, just keep the shortnames the same and change the Display Name in the camera device’s settings page (not in BI Fusion, changing the display name there after the device is already made won’t change anything). The display name is used for messages and everything else, so the only thing that would be weird is your shortname could be very different from the display name if you are looking at the settings in either Blue Iris or SmartThings. But both use the Display Name/Long Name for everything except behind the scenes stuff.

Sorry for the mess. This is a coding oversight, wish I would’ve thought of it way earlier…

LAST EDIT - Correction, I’d recommend creating a new camera device for the new shortname from within BI Fusion, THEN go back and delete the old camera device. That way you can click through each of the smartapps the old camera device used, adding the new one as you remove the old one. It’d prevent you from having to remember the whole setup at least.

NICE!!

1 Like