SmartThings Community

[RELEASE] BI Fusion v3.0 - Adds: Blue Iris Device Type Handler, Blue Iris Camera DTH, Motion Sensing

smartapp_cameras
dth_security
smartapp_security
dth_cameras
project_cameras

(WIlliam) #309

Think I got it working, SOmehow I didn’t self-publish the most recent smart app.


(Tristyn Russelo) #310

never mind… figured it out


(Mark) #311

@JMZ, I friggin love BI Fusion. You are the bomb.

For the last week or so, I have been trying unsuccessfully to add Stunnel to my setup so that I can access my camera feeds via HTTPS. And then I happened on your awesome instructions on Github. Two specific questions in the SSL Certificate Generation section:

  1. In step 6 of the Initial Setup, it says to logon to No-ip.com and then click manage domains > Modify > Advanced Records > TXT. I wonder if No-ip.com changed their UI because I don’t see those menu options. I poked around and saw something similar under My Services > DNS Records > Modify > Advanced Records > TXT. Is that what you’re referring to? If so, you might want to update the instructions for those that follow me.

  2. Secondly, and way more importantly, also in step 6, the instructions say to “copy the TXT record into (the field)”. Except, through that point of the process, there have been two TXT files – domain-csr and account-key. Are the instructions referring to one of those or something completely different?

Sorry if these are noob questions. But I am, er, a noob at this part. Thanks in advance.

EDIT: @JMZ, it just dawned on me that #2 above refers to this TXT record (below), not domain-csr or account.
Guess it’s impossible to make these instructions fully dummy proof! :grin: So…where the instruction says to copy the TXT record into the Noip.com field, does that refer to the “Domain TXT Record” or the “Value” in the screen capture below? Or maybe it’s something else yet again?


(Mark) #312

Hmmm, this is a continuation of the drama describes in the post immediately above.

Facing the above mentioned challenge, I reached out to noip.com support (ugh). After telling me that the TXT record in the instruction was called a DMARC TXT record, they went on to explain…

to clarify things a little bit, for the most part you cannot get an SSL certificate issued to a hostname created using No-IP domains. Whether they are Enhanced or free. This is actually more so based off of our SSL provider and how our SSL provider verifies ownership of domains. They do not verify ownership by hostname, they verify by sending a message to a domain registrant email address or through a DMARC TXT record. Both of these options are not possible for hostnames created using No-IP domains. You would need to own the root domain for the domain/hostname you are requesting the SSL certificate for, or have a service that allows you to modify different record types (like Plus Managed DNS on your own personal domain).

Other SSL providers verify things differently, but most verify ownership of domains through email or some sort of DNS records. So while it is not possible to obtain an SSL certificate through us, it MAY be possible through other SSL providers. It just depends on how they verify things.

That said, it is strongly recommend that you obtain SSL certificates for domains that you personally own and have registered. You do not necessarily need Plus Managed DNS, but it certainly does help, especially if you are in need of DDNS services along with an SSL certificate.

What am I missing? I was rigorous about following ever step in @JMZ’s Stunnel writeup, yet noip.com is suggesting that what I’m trying to do is not possible.

Anybody have any ideas? Thanks in advance.


#313

whew! Thanks for the good writeups. I’ll try figure this out, but you’re right, my instructions are about 2 years old… I switched to VPNs last summer. So first:

Pretty sure, yes. The point is to use the zerossl verification on No-IP.com. What you’re referring to looks right. Your edit to that post regarding what TXT record to use is correct. I would stick with the words record and not copy into value, but it’s been so long I guess I didn’t’ capture that step as well as I thought. I assume it didn’t work though, because you then posted about contacting support. I’m not sure what they are talking about. I had no issues using the Domain TXT record verification. I would imagine there was some communication gap between you and their customer support about it. You aren’t getting an SSL from them, you are just verifying that you own the domain with the place you are getting the SSL from (Let’s Encrypt in this case, using zerossl). If I remember right, I had to do the verification twice, and the second time it still seemed to not work, but then magically worked the next day.

Sorry, I’m not much more help. I just copied that verification txt record into the No-IP domain txt record and it all worked. I do have a plus managed DNS level service and purchased a domain name with no-ip though, so if you are trying to use their free domains (like noip.com/mydomain) that could be the issue.


(Mark) #314

That’s pretty funny – you’re thanking me for my write-ups when you’re the one who wrote those amazing instructions on Stunnel BI Fusion? Umm, yeah right.

Good news… I worked on this most of the day yesterday and finally got it cracked. Mostly the problem was my own ignorance, but there are a couple places where your instructions need to be updated given changes at noip or zerossl. If you want me to edit your github instructions for you (just a few tweaks), let me know how/where, and I’m happy to help. Anything so those that follow don’t have to experience what I did the last week or two!


#315

Recently Amazon Echo has been enabled to allow Alexa to respond to Smartthings triggers by switches and motion sensors. Using Alexa routines, you can have Alexa speak a custom message in response to a motion sensor activation, and select which one of your Echo devices does the speaking. When I set it up using a BI Fusion motion device as the motion sensor trigger, the trigger is recognized by Alexa, activates the routine to speak, speaks the selected message to the designated Echo device, but also broadcasts an unwanted generic motion senor active message across all 5 of my echo devices. This does not happen when I use a regular motion sensor as the trigger. I was just wondering why it only happens with BI Fusion motion sensors, and if it can be fixed. I have sent an inquiry to Echo support, and it may be their issue to fix, but does anyone here have any ideas? I would like to use my BI Fusion sensors for this purpose. I appreciate any reply you might have.


#316

@JMZ I’m having an issue with getting the camera feeds going. I decided to move from unsecured HTTP to HTTPS using stunnel. Everything was working with the unsecured way, but now I can’t get the camera streams working. Everything is working from a browser just fine. Any help would be greatly appreciated.


#317

I’m trying to install this using the instructions. Got the App and Trigger to install. Don’t see the DTHs on the github repository to execute. So tried creating a new smartapp From Code and copying, but then get this error:

No signature of method: script_app_metadata_090e2e2f_f6a3_4d51_9ae5_8a76326170d6.metadata() is applicable for argument types: (script_app_metadata_090e2e2f_f6a3_4d51_9ae5_8a76326170d6$_run_closure1) values: [script_app_metadata_090e2e2f_f6a3_4d51_9ae5_8a76326170d6$_run_closure1@6a176f3f] Possible solutions: getMetadata(), getState(), setState(java.lang.Object), metaClass(groovy.lang.Closure)

help please? Thanks!


#318

@garhun after configuring a routine on my BI Fusion camera in Amazon Alexa, I am getting no announcements at all, although I see SmartThings register motion for the device. My other motion sensors trigger an announcement just fine. Did you have any luck with this issue?


#319

Yes, I get Alexa to respond with announcement to the activation of Bi Fusion motion sensor devices just fine… Only problem I have is that the targeted Echo device will respond with my custom message, but all of my other echos will at the same time announce as a broadcast that the particular Bi motion sensor activated. This does not occur when I set it up using a normal Smartthings motion sensor. I think it must have to do with the Alexa
system, and how it is getting the Bi Fusion notification and processing it. It may take an Alexa update to cure my problem. I just don’t know.( I do love the Bi Fusion app though.) I tried reaching out to the Amazon Alexa support people and have not heard back yet.


#320

I just thought of something that might address your issue. You need to make sure your Bi Fusion motion device is permitted by Smartthings to be used by Alexa, and have alexa discover your devices again. Hope this helps.


#321

In the Amazon Alexa SmartApp, I had it set to “Allow Alexa to access all devices, Scenes, and Routines” – do I need to turn that off and specify the devices individually? I did try a discover devices. i even deleted the device and rediscovered.


#322

It sounds like you have it set up right. You don’t have to select devices individually. I do because I dont want all devices to be used until I fix my problem with Alexa reporting on Bi motion activations, so I have the Bi motion sensors disallowed for Alexa. If I think of anything else Ill let you know._


#323

@garhun, good news, I think I figured out both our problems. I went into SmartThings and disabled, re-enabled “Allow Alexa to access all devices…” and saved out. Then BI Fusion motion was recognized by Alexa. However, all my speakers were announcing “motion detected” in addition to running the routine I set.

This is caused by the “Motion” switch in the Announcements section of the device. When you turn it off, only the routine runs. If you have no routine, this swtich setting just enables a basic broadcast announcement to all echo devices. Counter intuitive – would think that disabling the Motion switch in the device disables motion detection, but it just enables/disables the broadcast announcement!

Try it, let me know if it works the same way for you.


#324

That"s exciting. Can you be more detailed about where I see the motion switch in the announcement section of the device. I can’t seem to find it.


#325

Never mind, I found it. I’ll test it tomorrow. Thanks for the help.


#326

Cool, yes you go to Devices and open the BI Fusion device and un-check Motion. Let me know if that solves it.


#327

Tested, and it definitely solved my issue. Thanks for the help.


#328

If you want, I think you can edit it directly in Github. It should allow you to make an edit, lemme know. I’m glad you got it going!