SmartThings Community

[RELEASE] BI Fusion v3.0 - Adds: Blue Iris Device Type Handler, Blue Iris Camera DTH, Motion Sensing

Yes that did the trick! Thanks for the support. Yeah that question did stump me a little, but it make sense to me now that you explained it. Great App JMZ!

You sure can! That’s how I use it. The Smarthings app is so slow to load
and use sometimes, plus adding the video load wait time… so I just use BI
Fusion to get the mode integration so I don’t have to do separate geofences
for both Blue Iris and Smartthings, and don’t need to set up any schedules
in Blue Iris either. Plus the BI Fusion triggers and now camera devices so
I can use Smartthings events to trigger recording (in case Blue Iris fails
to see motion for something, or more often, a contact sensors has an error
and says it’s opened when it isn’t, then it’ll still trigger a recording so
I can double check it). But for all the live feed viewing and looking at
alert recordings and camera control I use the Blue Iris app. It costs I
think $10, which is more than I usually spend on an app, but they keep it
current and it works great. You also set up different URLs in it, so it
tries both to connect so you don’t have to manually do anything different
if you’re home or away (something I’m working on including in BI Fusion for
big video viewing and as a failover option if you have external access
too).

1 Like

Thank you for the info! I had the BI app all set up, then I must have broken something when I set up BI Fusion, as I can’t get BI working with BI Fusion. That’s why I wanted to check. Now that I know they both CAN work, I can poke around until I figure out what I broke!

Much appreciated!

Just pushed v2.5 of the server, @kramttocs asked for and Ken from BI helped out: lock status (hold vs temporary profile changes) is now available to confirm. V2.5 ensures BI Fusion will run, and after work today I’ll finish the tweaks to make it fully featured. (Thanks for the heads up! Everything is ready, just need time to uncomment and double check the code works.)

Hoping I don’t overstay my welcome here… but my brain is entirely learned out… and I’m hoping for some sort of hint

Bunch of research and work later, I got the stunnel all configured and working for BI. Thought I was good to go and went back into ST to update the server and that’s when I saw that I need a real cert for stunnel, such as letsencrypt. Bummer, cuz now my integration is broken that I’d just figured out! Everytime I learn something, I break something else

Coincidentally, I’ve spent the last 2 days upgrading my server on Google (GCE)… with the last step being to get SSL working all around with certs/auto-renewals from letsencrpyt. So I am recently familiar with the service.

What I don’t know… is how to use letsencrpyt with stunnel. An hour of Google-fu hasn’t helped. Know of any resources where I can figure out how to proceed? I’l love to know how to manage the cert (install/renew)

Thanks kindly!

I have a how-to in the old BI Fusion Thread:

Just scroll down to the end of the initial post (below updates). I use the zerossl site to generate the letsencryptit certs. All free, works well. Hopefully the how-to is good. I stopped using it this past summer, but it was current then (I actually read the how-to each time I had to renew because I could never remember how to do it). Let me know if I need to fix anything. My long-term goal is to put that and some other how-to’s onto Github and then link to them within BI Fusion so you can find them easier.

Turns out the BI update had a little bug in it, I’ll wait to push the new server until that is fixed and also I’m working with @kramttocs to update the UI, so it may be a little bit with the holidays too! If anyone experiences any issues please let me know so I can work fixes in, thanks!

Man, you’ve been a huge help to me, thanks! I’m so close now. Followed your how-to and actually, I have a bunch of domains on Google and discovered their DDNS. So I used a subdomain through them and I think everything worked. But maybe it didn’t?

Through a browser and the BI app, I’m all good. I can get in to my server and I don’t get the security warning anymore, so it looks like the cert worked. But I removed the BI Server device so that I could route WAN. Now when my mode tries to change, I get push notification “Blue Iris Fusion failed to change Profiles, it is in Away (#2)? Check your user permissions.”

So hopefully I’m on my last hurdle. Is there some lingering data/connection that could be in my BI Fusion setup from originally having it all setup on LAN? I’m wondering if I should pull it all apart and fresh install… or if it could be a problem related to my cert setup?

Thank you!

I’m glad the SSL tutorial worked out! I didn’t know google had DDNS, I’ll have to look into it to see if it’s better than no-ip.

For your error, can you log into the API and pull up live logging, then change your mode, and paste the error message you get in the logs? I looked at the code, and there are two ways for you to get that message. Unfortunately the push message is the same, but the error messages that will show up in the log are different for each case (you don’t need to have debug on). Depending on which case it is, I can help narrow down the issue. Since you can log in with the app and website, it sounds like something else is happening.

You say you removed the server device, did you delete it from the device’s page in the app or did you go into BI Fusion’s setting and de-select “Use/Install Blue Iris Server?”? Make sure you turned that setting off, click “done” until you’re out of the settings, and then go back into the settings and look through everything making sure they are all good. That selection changes what options are available, and changes some of the notes, so it’s a good place to start.

Other things to check are to make sure your address is entered correctly (include https:// in it) and that the port is the correct one you have forwarded through your router.

Try that and let me know. It could also be that the updates to Blue Iris that just came out changed some things in how BI Fusion interacts with it, and I’m waiting on one more update to push out a new BI Fusion, so there could be some weirdness in there.

There we have the message for a couple mode changes. When I removed the server, I just turned off the toggle and clicked done. URL and port look good. Now, I was trying to uninstall BI Fusion to set it up fresh… is there any trick to that? I figured I’d uninstall the cameras first and then the main app. But the cameras won’t uninstall. I did that by setting installed cameras to 0 and hitting the toggle. The cameras don’t go away, the app won’t let me uninstall at all. I cleared out all the settings and re-entered them, but I don’t know if I have something muddled up now with the failed attempt to uninstall…

It looks like everything is fine, maybe a bug on my end? Looking at the
logs, it is saying it’s going to change to profile 1, then the error says
it couldn’t change it but that it is in profile 1, so it actually did
change it and the error message is just wrong. Is the profile in Blue Iris
changing?

I don’t think you need to reinstall it all yet, there may be a bug. I’ll
look at the code tonight for that specific error, let me know if Blue Iris
is actually being updated or not.

If you did reinstall, the trick is just to make sure you removed all the
camera devices from smart apps first (just look at the smartapps tab of the
device to see what it has been added too). Once that is empty you’ll be
able to uninstall them. And you can just go into BI Fusion settings and
change the “number of cameras to install” to 0. It’ll delete them then.

It is changing modes on BI!

I tried testing earlier but didn’t actually look at BI while changing modes, I would just check the log on BI after changing modes a few times. I just opened the BI app and watched the profiles and they actually do change. For some reason … BI almost never logs profile changes? I just did about 15 tests, and 2 changes showed up.

So BI Fusion seems to be working, it’s just the loggin in my BI that doesn’t. And yeah, I guess the error message is strange! When I was running local previously, I was getting the proper push notifications telling me profile had changed in BI… so it must just be when I switched over to WAN

But thanks for sticking with me, everything works!!

I am not able to delete cameras though… it seems. I can’t get the smartapps section clear as each camera lists Blue Iris Fusion in the smartapps. If I try to delete anyway, sometimes I get a success message, sometimes a fail message, but the camera doesn’t delete either way. If I try to just delete from within the BI fusion app, I can set to 0 installed and click the toggle… but all the cameras stay installed.

Finally figured out my one camera that wouldn’t change the motion to inactive. I think I had the inactive alert set to Http instead of https :man_facepalming:

@RVoodoo make sure “Do not delete old camera devices” is off (it’s below all the cameras), that should do it. It may not though, I tested it but that was a while back so there could be a bug there too. Also, why are you trying to delete them? Shouldn’t have to because it definitely looks like there is a bug in the code since Blue Iris is getting the new profiles, you’re just getting an erroneous error. Regarding the logging profile changes, Blue Iris just logs the user logins I think (I’m not at my computer, trying to remember), and as long as it hasn’t logged you out all your changes will show up as just one login, so seeing only a couple after a bunch of quick changes is normal.

@prjct92eh2 :+1:

That option is definitely off, there just seems to be no way to delete cameras for me.

I don’t actually need to anymore, with things working. I’m just passing the info along now for development purposes, in case it’s relevant. When I was trying to uninstall everything to start over, I was unable to, so there doesn’t seem to be any way to get the app uninstalled if I wanted to.

I don’t want to, I’m super happy it works now! Like I said, more about providing the info now in case it’s a bug.

Thanks very much for the help!!

Blue Iris just pushed an update that fixes the bug, and I just posted the new BI Server DTH and BI Fusion smartapp to accommodate that update. Once you install, you may get some errors saying that it didn’t change from hold to temporary (or vice versa). To clear that out, just cycle the Hold/Temporary button and cycle the mode to something else and back again. It should be working fine, just need to reinitialize some variables…

Can you explain this a bit? I don’t think I understand the issue here.

Thank you for all the efforts!
I am new to Smartthings and Blue Iris App. After quite some reading, I am finally able to understand every line of the instruction. However, I can’t get live camera feed at Smartthings App. The live video is only working in the native app (Blue Iris).
Please advise.

Never mind my question. I figured it out. It’s because I put in the wrong web server address (thought it’s the camera’s IP address, lol)

One more request for the device handler: add the capability sensor. I think most smart apps use this for all sensor devices to find them quickly.

I’m not sure what you’re asking here. Those are the steps to setup the BI cameras as motion devices in ST (i.e. so when a BI camera detects motion, a ST camera device shows motion ‘active’ and can be subscribed to by other ST smartapps for notification/siren/switches/etc.

What smartapps do you mean? I didn’t want to put a bunch of extra capabilities in the DTH without making sure that all the standard commands for each of those capabilities was in there. But for the camera DTH that should be no problem.