[RELEASE] AWAIR (SmartApp / DTH)

I added a way to connect the Awair locally to the SmartThings in the body.
you have to install DTH which was revealed to github by ktj1312 (Korean SmartThings user)
you can use a local connection with a smart app.

1 Like

@OhJungTae
I tried it, but I can’t get it to work.
I put the IP address of my awair element in the settings.
although it asks for ip:port and I don’t know what port they communicate on.

Try 80 port

1 Like

This works, thanks!

Is there a way for this to display the Score instead of humidity in the new Smarthings app?

Not unless you make a custom vid

This is FANTASTIC!!!

I was able to use the Awair Element PM2.5 sensor as a trigger for turning off and on a $20 box fan with a $15 20x20x1 MERV 13 filter taped to it as a cheap smart air purifier.

I’m so pleased with the device handler and smart app. THANKS SO MUCH!!

1 Like

Even better, I was able to use the Awair Element PM2.5 sensor to switch the fan mode of my HVAC system between “auto” and “on” automatically. By using a MERV 13 filter in my HVAC system, I can control the particulate level in my entire home automatically!! This is FANTASTIC!!! No need for an air purifier of any kind.

I would be careful using such a filter in your HVAC system as it can cause strain on your AC due to the reduced airflow.

Can somebody please help me understand why the main Tile is showing the Humidity % (47) ?

In the code —> main([“airQuality”])
Doesn’t it suppose to show the score on the Things view?

That’s because the new app does not respect the code for the tile view from the old app.

However, I’ve created a device configuration which replaces the dashboard view with the current awair score.

Edit the DTH to include the following (replace the existing vid and add the mnmn)

“vid”: “5f1a0db2-5ba5-31bf-abe5-230735eabf08”,
“mnmn”: “SmartThingsCommunity”

You’ll need to either delete and re-add the device or switch it to a different DTH and back to refresh the cache.

Screenshot_20201013-222311_SmartThings

Does this 5f1a0db2-5ba5-31bf-abe5-230735eabf08 VID still work? I have the Awair-R2 DHT working, but it won’t show me the Air Score and the tile in the new SmartThings app shows the temp (in C). The device in the IDE shows the score, but it does not in the new app and WebCore can’t access the score either. :frowning:

Also, the Smart App from @swamplynx won’t load. It says there is a network error. I fear Awair has finally pulled the plug on SmartThings. Hesitant to buy another Element.

UPDATE: Well, it is working now. It looks like I had to use the Awair-R2 DHT with the uypdated vid and mnmn (mnmn: “SmartThingsCommunity”, vid: “5f1a0db2-5ba5-31bf-abe5-230735eabf08”,) and then delete an old version of the device that was stuck in the IDE.

I hope it continues to work. The new smartthings app (not smart app) now sees the score and displays the temp in F.

Hey all!
We love the amazing work and contribution to the air aware community. Let us know if you ever have any feedback or would love to see a feature added.
Keep doing awesome things <3

  • Dean (Awair)

@deanlyoung I thought your official integration was discontinued? It never worked for me.
How about fixing it?

1 Like

We fixed it and added Awair Element. We haven’t submitted it to be included on the “Supported Devices” list in the SmartThings app, but it works.

edit: IMO “local” is the way to go for home automation (more reliable than being at the mercy of your ISP and a dozen others), but the cloud integration method is easier/simpler. Anything we can do to support either, let us know.

Yes, I use the local option with one of the community device handlers.

1 Like

I’m currently using the default Awair data handler (not custom DTH), and its been working fine. But the main tile display temperature in Celsius instead of Fehrenheit? Will this be fixed in the next update? if so when?

Good question. We are aware of this, but SmartThings handles temperature units differently than other platforms, like Google/Amazon/etc. so we still need to look into a way to handle this.

I wrote a conversion hack somewhere up thread that fixes that.

1 Like

The default DTH seems to be broken. Trying to use the custom DTH, but when I try to add Awair device, the Element model is not listed (only Glow/Mint/2ndEd). If I continue with “Link Account”, I get to a screen that asks “Awair would like to:” with 2 dropdown lists:

Dropdown - Install your device profiles: The only option is “all device profiles”
Dropdown - Control your devices: All Devices

Is this because Element is not officially supported? I’m not inclined to give such broad permission for cloud integration?