[Release] Assistant Relay V3 - Google Home Audio Notifications!

Whew! Ok, I’m at Step 2 Adding Client Secrets. With your client secrets, you can import them into Assistant Relay below: And it’s asking for a “Users Name” with a select file button after that box.

I don’t understand what that means.

(EDIT) Ok, I think that’s the file I downloaded, and doing some looking at the Assistant Relay readme, it looks like I need to rename it to “Your chosen User Name”. And then make a copy and place it in server\configuration\secrets.

Ok, so “your chosen user name”. Is that just my name, is it my google email address before the “@”, or is it a name i can make up?

Next, where is server/configuration/secrets ?

You’re reading the wrong version:

I’m really sorry. I’m trying to get this. I feel really stupid, but this is like nothing I’ve ever done, and I really want to succeed.

Terminal popped up with a website to go to, which I did. Has “Step 1, setting up your project” and there are 8 bullet steps, which I did, then a next button. So, according to what you linked, I do not go ON to step 2. I now have to Visit the configuration tab on Dashboard to Configure.

Edit: I’m on the Google APIs Dashboard, but i don’t see a “Configuration tab”.

WHAT DASHBOARD???

What version have you downloaded? You need to be on version 3. Sounds like you’re reading instructions for V3 and running V2

I went into the assistant relay folder and looked at the readme file, it says V 3

Meanwhile in Terminal - all this is happening:

0|www | Assistant Relay Server Initialized
0|www | Visit http://192.168.1.22:3000 in a browser to configure
0|www | GET / 200 28.789 ms - 3159
0|www | GET /static/js/main.a3431f03.chunk.js 200 158.115 ms - 60122
0|www | GET /static/css/2.3a86971d.chunk.css 200 153.408 ms - 259521
0|www | GET /static/js/2.1e09be87.chunk.js 200 157.664 ms - 1755595
0|www | OPTIONS /server/userCount 204 0.471 ms - 0
0|www | POST /server/userCount 200 246.320 ms - 10
0|www | GET /favicon-16x16.png 200 12.792 ms - 1152
0|www | GET /android-icon-192x192.png 200 15.931 ms - 3331
0|www | GET /favicon.ico 200 3.981 ms - 1150
0|www | GET / 304 0.678 ms - -
0|www | GET /static/js/2.1e09be87.chunk.js 304 0.547 ms - -
0|www | GET /static/js/main.a3431f03.chunk.js 200 3.863 ms - 60122
0|www | GET /static/css/2.3a86971d.chunk.css 200 6.202 ms - 259521
0|www | OPTIONS /server/userCount 204 0.099 ms - 0
0|www | POST /server/userCount 200 7.010 ms - 10
0|www | GET /android-icon-192x192.png - - ms - -
0|www | GET /favicon-16x16.png 200 2.141 ms - 1152
0|www | GET / 304 0.304 ms - -
0|www | GET /static/js/2.1e09be87.chunk.js 304 0.419 ms - -
0|www | GET /static/js/main.a3431f03.chunk.js 200 1.100 ms - 60122
0|www | GET /static/css/2.3a86971d.chunk.css 200 1.462 ms - 259521
0|www | OPTIONS /server/userCount 204 0.169 ms - 0
0|www | POST /server/userCount 200 12.738 ms - 10
0|www | GET /favicon-16x16.png - - ms - -
0|www | GET /android-icon-192x192.png - - ms - -

LOL Still there this morning. So I see on Google’s site the “Dashboard” but there is definitely no Configuration tab. Or am I looking at a wrong dashboard?

^^ 10 char.

Ok, maybe I should give this up and write off as something I’m just not able to do.

I visited that in my browser.

I followed to step 5 and went back to that first setup page.

I finished all of those bullet points. Remember? I clicked “next” to go to the second page when I shouldn’t have (the client secrets thing), but I didn’t do anything.

I downloaded an OAuth2 JSON file from Google. It’s sitting in my downloads folder. It’s called "Client_Secrets… " with a whole bunch of letters and numbers after that, .json.

I DO. NOT. SEE. A configuration tab on the Dashboard of the API’s & Services webpage.

Is there a different way you can explain how screwed up I am, or am I just beyond understanding this?

So you can see - when I go to that link in a browser, here’s what I’m looking at - the stuff I did already:

Untitled

I tried entering that web address (192.168 etc) without the “setup” but it always goes to the website with the “setup” there and the screen you see above.

Got it all set up and running as a test. Created a piston to turn off my living room tv when a switch turns to off and it worked! this is awesome.

1 Like

Follow the wizard. Click next and then add your user and you should be good to go

Ohhh. Click next. I definitely misunderstood you earlier. Thanks I’ll do it!

So I am proud of myself. This is the first time I did anything like this. I installed it on my computer and it worked fine in the sandbox. It took me a while to figure out why it wasn’t working from webcore, until I remembered that when I installed json on my computer, the firewall asked what should be done for public profiles and I said to block it. By allowing this connection, I got it to work. Maybe you can add to your instructions to ensure the firewall allows all for json. Furthermore, my test piston says "Broadcast from Joey… [text I specified]. How can I just say the text without it saying “broadcast from Joey”?

Complain to Google until they remove it :laughing:

It’s coming from their side not mine unfortunately

OK. Thanks! I also noticed that I can send commands (like turn off lights) and it still works even though all google devices have been unplugged! This is great for devices that don’t have smartthings integration, but only Google home!

Before I do this - I want to check on a few things with you…

  1. I have a “client secret” json file in my downloads folder. it’s got lots of letters/numbers after client_secret" in its name. Is it in the right place, or does it need to be in the assistant-relay folder? And - do I rename it?

  2. When I hit “next” as you instructed, I have:
    Setting up your account
    With your client secrets, you can import them into Assistant Relay below
    Users Name"
    I’m not quite sure what to put here. Do I just make up a name that I want to use for assistant-relay? Do I need to rename that client secret json and use that name here? Or is it my user name for my google account? Or something else I’m not thinking of?

  3. For the “select file” button after the user names field, I’m guessing it’s that client secrets json file they want, correct?

  4. Just curious, why is it userS name, not user? Hmmm.

No and no

The name for the user your setting up in AR

Yes

(post withdrawn by author, will be automatically deleted in 24 hours unless flagged)

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.