[Release] Assistant Relay V3.3 Beta

I’ve tried to install this on windows 10,

I believe I followed all the steps in the setup correctly, but when I try to run npm start run I get these errors repeating themselves.

0|www  | Error: Cannot find module 'shelljs'
0|www  | Require stack:
0|www  | - C:\assistant-relay\helpers\cast.js
0|www  | - C:\assistant-relay\routes\server.js
0|www  | - C:\assistant-relay\app.js
0|www  | - C:\assistant-relay\bin\www
0|www  |     at Function.Module._resolveFilename (internal/modules/cjs/loader.js:966:15)
0|www  |     at Module.Hook._require.Module.require (C:\assistant-relay\node_modules\require-in-the-middle\index.js:61:29)
0|www  |     at require (internal/modules/cjs/helpers.js:72:18)
0|www  |     at Object.<anonymous> (C:\assistant-relay\helpers\cast.js:1:11)
0|www  |     at Module._compile (internal/modules/cjs/loader.js:1138:30)
0|www  |     at Object.Module._extensions..js (internal/modules/cjs/loader.js:1158:10)
0|www  |     at Module.load (internal/modules/cjs/loader.js:986:32)
0|www  |     at Function.Module._load (internal/modules/cjs/loader.js:879:14)
0|www  |     at Module.require (internal/modules/cjs/loader.js:1026:19)
0|www  |     at Module.Hook._require.Module.require (C:\assistant-relay\node_modules\require-in-the-middle\index.js:80:39) {
0|www  |   code: 'MODULE_NOT_FOUND',
0|www  |   requireStack: [
0|www  |     'C:\\assistant-relay\\helpers\\cast.js',
0|www  |     'C:\\assistant-relay\\routes\\server.js',
0|www  |     'C:\\assistant-relay\\app.js',
0|www  |     'C:\\assistant-relay\\bin\\www'
0|www  |   ]
0|www  | }

I’m not sure what to do next. Hoping for some help. So glad you all are here!

Im not sure why it keeps doing this, I thought shelljs was in the package.json :confused:

Just do npm i --save shelljs

That looks like it did it! Thank you!

Hate to bother you again, I went through the config. Actions has changed quite a bit it seems since the walk through was created. But I created credentials, downloaded the file, created a user and uploaded the credentials file, then on the next screen pasted the secret code from the credentials file. Now I’m getting this on run.

0|www | Assistant Relay Server Initialized
0|www | Visit or http://ar.local:3000 in a browser to configure
0|www | TypeError: Cannot read property ‘getRequestHeaders’ of undefined
0|www | at getAuthorizationHeaderFromGoogleCredential (C:\assistant-relay\node_modules\grpc\src\credentials.js:188:32)
0|www | at C:\assistant-relay\node_modules\grpc\src\credentials.js:219:5
0|www | at C:\assistant-relay\node_modules\grpc\src\credentials.js:166:5
0|www | Update check failed. You’ve probably been rate limited by GitHub
0|www | TypeError: Cannot read property ‘0’ of undefined
0|www | at exports.setCredentials (C:\assistant-relay\helpers\auth.js:41:97)
0|www | at processTicksAndRejections (internal/process/task_queues.js:97:5)
0|www | at async C:\assistant-relay\helpers\server.js:64:40

What application type did you select in the Google project? Needs to be TV and limited input device

Ah ok, that’s where I screwed up. Thanks, I’ll delete the project and try again.

Is anyone having issues where the text response is blank? For example, I ask what the time is, I get no text response, but I do get an audio response.
If this is you, please could you go to this issue, give it a +1 and comment on it. https://github.com/googlesamples/assistant-sdk-nodejs/issues/13

I’ve reached out to Google but they’re unable to find the issue so far. The more users we get +1’ing that issue, the better

What questions should it give a text response? I saw it really rarely, I thought that is an SDK limitation.

Not really, most things it should give a text response. What’s the weather? What’s the time?

They should give text responses

Ok, I see. I used before, is the garage door open, and that’s what I’ve got:

No text response given, click play to hear the audio

But I see, what is the time gives zero text response, not even the one above.

I tried one of the examples from the issue, but that actually works.

Who is the president of the united states
United States, President: Donald Trump.

Hmm, im not sure for you, unless its intermittent. For me, nothing gives a proper response :frowning:

I did a fresh installation yesterday (July 11) and everything worked fine. After seeing your comment and try it again, I am having the same problem now.

Then I try removing user then adding it back, it starts working again for an about hour. Then stops working.

Are you running in a Docker container?

I am not running docker.

What “stops working” exactly?

1 Like

In /bin/config.json

Can you screenshot just the responses section and edit your comment here: https://github.com/googlesamples/assistant-sdk-nodejs/issues/13

Just add a comment with the image to say that sometime you get no response, sometimes you get an actual response, and then sometimes you get a space as the response

1 Like

I came here to ask another question, and saw your comments so I tried some jokes from mine. All responded.

  "command": "Tell me a joke",
  "response": "Did you hear about the two antennas that got married?\nThe ceremony was okay, but the reception was great! 📺 ❤️",
  "timestamp": 1594854059912
  "command": "Tell me a joke",
  "response": "Why can't a bicycle stand on its own?\nIt's two tired 😴 🚲",
  "timestamp": 1594854753123
  "command": "Tell me a joke",
  "response": "What do cats eat for breakfast?\nMice crispies",
  "timestamp": 1594854768629
  "command": "Tell me a joke",
  "response": "Why does a duck have tail feathers?\nTo cover its butt quack",
  "timestamp": 1594854809478

As far as a question goes, is there anyway to send more than one command to google assistant in a piston? I’ve been trying to figure it out, but it seems like you can only use variables on the web request and the only variable that works is command. Is that correct?

1 Like

I think I’ve figured out how to have multiple commands for GAR in one piston. The command variable can use an expression which can use another variable that changes based on what I need it to change. That way I only have one command variable but the content changes depending on what the variable it’s calling in the expression calls for.


Something to note, I’m getting responses from jokes, but not my commands.

  "responses": [
      "command": "Set living room tv to hdmi 1",
      "response": "",
      "timestamp": 1595048147938
      "command": "Turn on the xbox",
      "response": "",
      "timestamp": 1595062801045
      "command": "Set living room tv to hdmi 1",
      "response": "",
      "timestamp": 1595062813748
      "command": "broadcast Broadcasts delayed for 1 hour",
      "response": "",
      "timestamp": 1595097657781
      "command": "Tell me a joke",
      "response": "Why shouldn't you write with a broken pencil?\nBecause it’s pointless! ✏️",
      "timestamp": 1595130980168