[Release] Assistant Relay V3.3 Beta

So you can see - when I go to that link in a browser, here’s what I’m looking at - the stuff I did already:

Untitled

I tried entering that web address (192.168 etc) without the “setup” but it always goes to the website with the “setup” there and the screen you see above.

Got it all set up and running as a test. Created a piston to turn off my living room tv when a switch turns to off and it worked! this is awesome.

1 Like

Follow the wizard. Click next and then add your user and you should be good to go

Ohhh. Click next. I definitely misunderstood you earlier. Thanks I’ll do it!

So I am proud of myself. This is the first time I did anything like this. I installed it on my computer and it worked fine in the sandbox. It took me a while to figure out why it wasn’t working from webcore, until I remembered that when I installed json on my computer, the firewall asked what should be done for public profiles and I said to block it. By allowing this connection, I got it to work. Maybe you can add to your instructions to ensure the firewall allows all for json. Furthermore, my test piston says "Broadcast from Joey… [text I specified]. How can I just say the text without it saying “broadcast from Joey”?

Complain to Google until they remove it :laughing:

It’s coming from their side not mine unfortunately

OK. Thanks! I also noticed that I can send commands (like turn off lights) and it still works even though all google devices have been unplugged! This is great for devices that don’t have smartthings integration, but only Google home!

Before I do this - I want to check on a few things with you…

  1. I have a “client secret” json file in my downloads folder. it’s got lots of letters/numbers after client_secret" in its name. Is it in the right place, or does it need to be in the assistant-relay folder? And - do I rename it?

  2. When I hit “next” as you instructed, I have:
    Setting up your account
    With your client secrets, you can import them into Assistant Relay below
    Users Name"
    I’m not quite sure what to put here. Do I just make up a name that I want to use for assistant-relay? Do I need to rename that client secret json and use that name here? Or is it my user name for my google account? Or something else I’m not thinking of?

  3. For the “select file” button after the user names field, I’m guessing it’s that client secrets json file they want, correct?

  4. Just curious, why is it userS name, not user? Hmmm.

No and no

The name for the user your setting up in AR

Yes

@ghesp
Can this be run on Linux?
If so, it would be real easy for me to spin up another Linux VM for this on my primary vSphere ESXi Server.

Yes, should be fine.
You can check compatability here
https://developers.google.com/assistant/sdk/guides/service/python

1 Like

OK, great! Thank you! :slight_smile:

Hello,

First I want to thank the author for such a great piece of software. I’m relatively new to the raspberry Pi ecosystem but was able to get everything installed and it is running (I think).

However I am having an issue and was wondering if you could assist me in fixing it. While I hate to bother you I really would like to get this to work. Any assistance you could give me would be greatly appreciated!

With that here is my issue-

I cloned the git repository which contained the V3.0.4 version. I followed the install and created the OAuth secret file etc.

I got the initialized announcement from my Google Home device when I finished the “Relay” configuration.

However when I try to send ANY commands for broadcast (sandbox, webcore, etc.) I get the following announcement “Broadcast from user Assistant Relay Initialized” and that is the only message it announces. The terminal also shows the following when anything is sent for broadcast:

> 0|www | [Error: ENOENT: no such file or directory, open ‘bin/audio-responses/1573763246229.wav’] {
> 0|www | errno: -2,
> 0|www | code: ‘ENOENT’,
> 0|www | syscall: ‘open’,
> 0|www | path: ‘bin/audio-responses/1573763246229.wav’
> 0|www | }

What could be causing this and how to fix?

Another issue is that the client start (npm run start) produces the following error:

Failed to compile.
./node_modules/lottie-react-web/dist/index.js
Module not found: Can’t resolve ‘lottie-api/dist/lottie_api’ in ‘/home/pi/assistant-relay/client/node_modules/lottie-react-web/dist’

When I installed both the relay and client I used “sudo npm i” which after doing some research I found I shouldn’t have probably done that. Additionally I can only start the relay with sudo (which makes sense of coure) Could this be my issue?

While I hope I don’t have to do a re-install what would be the best method? From what I have read would deleting the “assistant-relay” directory (minus the OAuth file) and recloning the git repository be sufficient? I of course would need to run through the setup process again without going through the OAuth process and just reusing the file previously created.

Thanks again for any assistance and have a great day!

Hi - did you download the release.zip or the source?
You need this:
https://github.com/greghesp/assistant-relay/releases/download/v3.0.4/release.zip

I used the following Terminal CMD.

git clone https://github.com/greghesp/assistant-relay.git

Just to clarify here. I installed PM using the “Beginner’s Guide…” and the command was:

“curl -sL https://deb.nodesource.com/setup_12.x | sudo -E bash -”
“sudo apt install -y nodejs”

Is that correct?

I also guessing clonning the git repository was incorrect and I should download the “releases” version and install it??

Last question (and I’m sorry I’m being a pain). To re-install do I simply delete the assistant-relay directory (minus the OAuth file), download the “releases” version and start the install “npm i”? without sudo?

Thanks again.

When you’ve got Node installed, you can install PM2 by doing ‘npm i pm2 --g’

That will install it globally

Download the release.zip and extract into a folder of your choice. Navigate to that folder using the terminal and then run ‘npm i’

Hello,

Did setup node.js and assistant relay server. In the dashbord url of assistant relay, the sandbox testing was working good. I was able to hear broadcast message in google home. However, the curl command was not working from laptop cmd. Thought may be port issue, in the dashboard configure tab i changed port to 3005 and updated the config file also in bin folder. Then did pm2 kill and npm run start. But after this, the dashboard window is not coming up, I get message network error. What could went wrong? Anywhere else to change port?

Anyway, When i do npm start run, google home is broadcasting “Assistant Relay initialized”.