[RELEASE] Ask Alexa


(Micheal ) #1263

Try adding the .toLowerCase() to the param variable on 978. shouldn’t matter, but let me know if that helps.


(Chris) #1264

I set up my first macro, named “I’m leaving”, and added the name “i’m leaving” to the LIST_OF_MACROS in ASK. When I say “Alexa, tell smartthings I’m leaving”, she responds with “I could not find a macro named I’m leaving. Please check the name and try again.” Did I miss a step?

**edit, I renamed the macro to “I am leaving” and it works, maybe it’s not recognizing the contraction.


(Chris) #1265

Ok another weird thing…I have my garage door added, named “garage door”. I can open it through the “I am leaving” macro I referenced above, I can ask Alexa for the status and she replies with the correct status, but if I say “tell smartthings to close the garage door”, the response I get is “Sorry, I couldn’t find a device or group named garage door in Chris’s profile”. I tried deleting and re-adding it as a Door in the smartapp and I removed and re-added under LIST_OF_DEVICES in ASK, and still the same.

If I say “tell smartthings to turn on the garage door”, she replies with “for the garage door, you must give an open or close command”. I follow up immediately with “tell smartthings to close the garage door” and Alexa response with the same “Sorry, I couldn’t find a device or group named garage door in Chris’s profile.”

Any ideas?

**edit again, open and close were missing from LIST_OF_OPERATORS. Added and now it’s working correctly.


(Greg) #1266

well now I don’t have the new error. It is back to just going silent.


(Micheal ) #1267

Sorry for the checklist here, but I can no longer reproduce what you are seeing:

  1. Make sure there is no punctuation in your routine
  2. Make sure you have routines turned on in the main interface
  3. Make sure you do the setup via the app, get the address, then copy (and save) the SHPARM

Worst case is do this:
Go back to base 2.0.1a code

Change line 941 to:

     if (phrases.find{it.replaceAll("[^a-zA-Z0-9 ]", "").toLowerCase()==param.toLowerCase()}) cmd = "routine"

change line 978 to

    def runRoutine = phrases.find{it.replaceAll("[^a-zA-Z0-9 ]", "").toLowerCase()==param.toLowerCase()}

Worst case, let’s go PM and we can work on this together. But honestly, with “I AM BACK” this didn’t work until I did the above


(Micheal ) #1268

The issue below that @Greg is having is the exact same issue. You wait until the weekend to get the new version I am sending out, or follow the directions directly above…


GE Ceiling Fan Switch Custom Device Type - Low, Med, High buttons w/no slider!
(Micheal ) #1269

Open and close should be part of the main list of items that should be (be default) in your List of operators…are you saying it didn’t show up, or you didn’t copy them all?


(Chris) #1270

Got it, sorry I hadn’t seen his posts. For what it’s worth, now that the macro is named “I am leaving”, I can still say “I’m leaving” and it seems to work fine. I’m ok with leaving my macro named this way.


(Chris) #1271

At the time I copied in the code I didn’t have any doors added in ST. I assumed that open/close weren’t in the list that I copied from since I didn’t have any of that device type added. It’s possible that I missed them since they were at the bottom of the list but I thought I was pretty careful to follow the directions exactly as written.

This app is fantastic BTW, opens up many possibilities that aren’t there with the stock Alexa/ST integration.


(Micheal ) #1272

Yeah…but I might as well bite the bullet and have that included instead of just waiting for a door to be added :slight_smile:


(Greg) #1273

No problem. I ended up just going with “Good to be back” and it works fine. I would have preferred “welcome back” but since routines still sort alphabetically in the app view I’d prefer to not have to scroll in the routine list if/when I need to do the routine manually. Thanks again for this great app!


(Micheal ) #1274

No problem…I am committed to testing this whole lower case thing tonight to ensure it gets covered. Surprised I only noticed it now!


(Jason "The Enabler" as deemed so by @Smart) #1275

I have a macro called “I am going to bed”

I have to clearly say I Am Going To Bed, and it runs great.

I tried naming it “I’m going to bed”… Wouldn’t work for nothing…


(Micheal ) #1276

Macros didn’t have the lower case issue…and I think I fixed the lower cased routines.


(Micheal ) #1277

All,

Version 2.0.2 will be released this weekend (probably Sunday). You WILL need to update your intents, utterances, and Lambda code, and the SmartApp, along with running setup again to get some new commands in their slots.

Just FYI in case someone was contemplating installing it today…I would wait until the weekend.

Enjoy!


(I got a hair cut from Alexa) #1278

SmartThings had these up on their outage board this morning…did any of you using Ask Alexa experience this when using Ask Smarthings (or whatever)? I’m curious whether the outage was everything coming from Amazon, or just the smartthings basic home “switch” integration. I personally didn’t experience any slowness.

Jun 16, 06:28 EDT Investigating - Some users may
experience elevated error rates when attempting to execute commands
through the Amazon Echo. The SmartThings engineering team is working on
the issue and will update as new information becomes available.

Jun 16, 09:55 EDT Update - Amazon Echo timeouts have
substantially subsided. The engineering team is continuing to
investigate longer than usual Echo execution times. We will update as
more information is available.


(Michael Hess) #1279

I hate to say it but I actually haven’t used this for a bit over a week now…I’ve gotten too automated. That’s my excuse, the reality is I don’t think I have seen enough use cases to find something that I would use.

Did I miss a post or maybe thread with a list of peoples use cases? I’m getting overwhelmed between this, CoRE, and life, stupid life, always getting in the way of the fun stuff…


(Micheal ) #1280

I think this is the native integration…however, the App was REALLY slow this morning.


#1281

I had certainly noticed some problems and had to increase timeout on AskAlexa. Both this and standard ST Echo integration seems improved this evening.


#1282

I’m was a real stumbling block for me too.
Found that phrases like ‘its bedtime’ (deliberately no apostrophe) worked much more reliably.