SmartThings Community

[RELEASE] ArloPilot - Enhanced Arlo System Integration

smartapp_cameras
arlo
project_cameras
(Derek) #471

Just FYI, in case it is helpful at all to @Mavrrick58, I setup a virtual switch with IFTTT that would arm/disarm Arlo based on Smartthings modes. The virtual switch worked as expected by turning on/off based on ST modes. It also always worked initially to arm the cameras when the switch was turned on, but very shorty would go back to disarmed even though the virtual switch was still on. It seems with this setup Arlo would default back to disarmed regardless of the status of the virtual switch. I’m not nearly as well versed with the nitty gritty of ST as many of you guys here are, so I did not do any logging in my IDE as I wouldn’t really understand what it spit out anyway. I ended up completely removing Arlo Pilot from my IDE, Arlo Connect from my IDE, the virtual switch and IFTTT and am just using Arlo as stand alone for now.

(Richard Greenall) #472

Derek.
I tried to do what you did… completely back out of the Arlo integration but no
matter what I do I can’t delete Arlo connect out of smartthings. I’ve removed all apps… deleted the cameras. but still the damn delete tells me there is something in use. I finally had to change my Arlo password and reset my credentials to get my Arlo cameras back connected to smarthings to at least get my cameras working at least some times. smarthings or something now keeps disarming my cameras at regular intervals.

sigh.

(Derek) #473

I had the same issue @Richard_Greenall . What I ended up doing was deleting all cameras in my ST app and deleting all webcore pistons that included the cameras. I was still getting the same error you’re referencing. What I failed to delete was my Arlo hub (siren) that gets integrated along with the cameras. You can find it under things in your ST app. It’ll be named whatever you named your Arlo hub when you initially set it up. Once I deleted that from things in my ST app, I was able to finally successfully remove Arlo Connect from my smart apps. Maybe you missed the hub/siren removal as I did?

And yes, before doing all of this I was also experiencing my cameras being disarmed. They are working fine now, but obviously I’m missing the ST integration.

(Mavrrick) #474

@Richard_Greenall

Smartthings doesn’t have a way to disarm your cameras. It does have an option to turn them off like a switch though. Simply remove arlo pilot and then setup the rule in smart things with the smart app I listed above. You should get allot of the control back modes gave you.

@BigTerp
The app I linked above still uses the Arlo connect integration but would not use IFTTT. Did you try it?

1 Like
(Derek) #475

I have not. But will give it a try when I get the chance. Thanks for working on this!! Hopefully we can get back some of the controls using ST modes, which seems like what most people are interested in.

(Richard Greenall) #476

Derek.
Bingo… your right… I did everything you did but forgot the damn siren.

1 Like
(Mavrrick) #477

I have created another thread for discussions for the Arlo Assistant Smartapp. It is at Arlo Assistant. I will keep updating that thread as I progress with development. I have already updated a few things for bugs that I have found today.

1 Like
(Derek) #478

HA!!! Glad you got it figured it. It was driving me nuts as well!!!

(Austin) #479

So, to be clear - is there basically 0% chance that ArloPilot will start working again?

The best feature in my use case was being able to set custom modes based on ST triggers, something it’s still inconceivable that IFTTT can’t do. I like having the system ‘Armed’ when we’re away, and in a custom ‘No-Notification’ mode when we’re home, so we still capture recordings but the wife doesn’t get barraged with notifications. Are there any other solutions that people know of that can do this?

Thanks

1 Like
(Mavrrick) #480

A 0% chance is not correct. There are ways to make it work if you have your own always on server on the internet and are willing to update the Arlo Pilot code. It basically means pointing the Arlo Pilot app to your own server that will forward the traffic to the Arlo Servers. Not really the best way to do it.

The Arlo Assistant app linked above which now has it’s own thread here, can also manage it in a way. Basically what Arlo Assistant will do is allow you to use a generic mode in the Arlo cloud and then move the triggers for recording and notifications to Smartthings. Your use case is exactly what i am trying to solve for myself as that is how I used Arlo pilot, and so at the very least that functionality will be present in Arlo Assitant

(SmartThings) #481

Hi Everyone,

SmartThings encourages an open model and welcomes our Community Developers extending the capabilities of our platform. However, there is an expectation that developers will use only SmartThings (and our servers) to connect with partners’ official APIs.

We acknowledge that the Arlo outage and subsequent changes to the community integration resulted in a chaotic sequence with limited communications. To ensure everyone has some visibility, here is a summary of what happened:

  1. Arlo started receiving a high volume of traffic from SmartThings servers.

  2. To ensure their platform health (rightfully so), Arlo blocked traffic with SmartThings IP addresses. This broke official and community SmartThings <> Arlo integrations.

  3. After discussing with the Arlo team (shout out to their patience and hard work!), they restored the connection with a formal request that SmartThings only allow use of the official API with approved integrations

  4. In order to ensure the continued availability for all SmartThings<>Arlo integrations, we started restricting all traffic from all community SmartApps hitting the Arlo APIs. This effectively terminated all running ArloPilot SmartApps.

We also recognize that we did not communicate the changes in a timely manner. We were working hard to ensure platform health and did not pause to communicate. This is something we will try to be more attentive to in the future.

Thanks,
SmartThings Team

#482

If they would only address the issue of mode changes that their customers have been waiting on for 3+ years, no one would have had to write a “work around” to be able to use the cameras as advertised. (Their own geolocation services are the most abysmal implementation I have ever seen) ’

I would add that the timing is EXTREMELY suspicious as that is about the same time that someone posted about using ST as a workaround to making their Arlo Systems work.

I would hardly give them kudos for being patient as their platform is one of the worst I have ever experienced for something I paid that much money for. You can see from the above links, that appreciation for patience goes to the customers that are still with them.

In my own case, this was the final nail in that coffin. They have lost my business permanently.

I am also not very pleased with the smartthings response to this issue. I am 90% sure that the mode change capability could have been retained as it was likely the image caching in the app causing issues (if there was actually ever anything truly flooding their servers). The mode changes were only occurring as a result of specific triggers whereas the image caching was on set intervals.

1 Like
(Steve White) #483

I’ll probably get banned from here for what I am about to say…

Arlo doesn’t want any kind of external control that may even remotely impact their ability to demand subscription revenue from you. Thats one reason why the “official” integration has remained a steaming pile of crap ever since it was released. SmartThings certainly doesn’t want to damage that relationship and ultimately jeopardize access to that data.

Neither Arlo nor SmartThings gives two sh*ts about their customers. This is proof. Both companies are nothing more than greedy, untrustworthy corporate turds. This decision is all about control of your data that boils down to money.

Think SmartThings cares about you? Just look at how long it took them to admit this deception to the community? They weren’t working hard to maintain the stability of the platform, they were trying to come up with BS excuse that they hope people people won’t question.

My ST hub was trashed a long time ago. Time to dump the Arlos next.

3 Likes
(Joe m. ) #484

Yup goodbye word of mouth recommendations, this was one of the best integrations going, now it’s trash again. Getting fed up

(Mavrrick) #485

This is my concern. Does this mean the only thing that can interface with the Arlo cameras is SHM?

#486

There is IFTTT. I have played with arming/disarming. However, that is arming/disarming the WHOLE SYSTEM. Since I have specialized rules that also run on a schedule, I need to have it access the “Schedule” mode. This is NOT a custom mode and there is NO reason that they cannot do this. I am looking at the code in Arlo Pilot to see if there is a way I can’t use a piston to trigger modes. Otherwise, I am going to look at Wyze. If I have to put all the effort into individual camera controls, I may as well do it with a camera that costs 1/4 of the Arlos, has continuous recording (and local), and less lag.

3 Likes
(Mavrrick) #487

@tweason

I will work on adding a time component to Arlo Assistant.

(Mavrrick) #488

Is there a new problem with Arlo integration. I am seeing no motion events from the cameras since around 2:50pm this afternoon?

(Steve White) #489

Arlo probably blocked SmartThings again.

1 Like
(Jean May Jr) #490

Looks like Arlo is having issues - From https://status.arlo.com/
" 24th May 2019

*Video Recording Missing videos *
4 hours ago

We are aware of a potential issue with notifications and video recordings that is impacting some customers. Our team is actively investigating this and will provide an update as soon as possible. We appreciate your patience and apologize for the inconvenience.

Thank you,

Arlo Team"