SmartThings Community

[RELEASE] ArloPilot - Enhanced Arlo System Integration

smartapp_cameras
arlo
project_cameras

(Travis) #329

So it seems my mode3 didn’t want to work. I made the same settings in mode4 and it is now working again!


(Justingeorge67) #330

Hi, real novice here. I followed all the Installation Instructions - Github Integration all the way to No. 11 “Click ‘Execute Update’ but DO NOT click ‘Publish’” … but when I go to the next step, No. 12 - “Open the SmartThings mobil app, go to Marketplace” and go to Step No. 13, there is no “ArloPilot” app under the “MyApps” category on my SmartThings Classic app. Nothing to install. Anyone know what step I missed or why it isn’t showing up? Please and thank you.


(Justingeorge67) #331

Scratch that, re: last post. … I got it installed. Thanks.


#332

Having trouble with the Custom Mode Management. There’s no Done button showing on my phone, so I can’t save the additions I made. Any idea why?


#333

Never mind. It popped up this morning. Still not sure what happened.


(Karl) #334

I’m stuck. When I view a camera in the browser (in the ArloPilot app), all I get is the world False.

I can see my cameras the ArloPilot app. I’m connected to Smart Things. The ArloPilot is showing in My Apps… external access is authorized… otherwise… ???

What am I missing?


#335

I had this. When you enable the public image URL make sure you hit save or done or whatever.


(Karl) #336

I did that. Thank you. But didn’t solve the issue.

But here is what I found that sort of helped, but not really… if I open the Arlo website and view the camera live and then stop it. THEN it sends the image to the action tile and the False goes away.

BUT… it doesn’t send the most recent image to the action tile when there has been any recent activity and it’s recorded something. Only the most recent image I viewed live on the Arlo website… strange

So not sure how to get it to “update” the tile when something has recorded.


(Chad Cole) #337

I have been having a similar situation. If I do a live view in Arlo I will get a new ArloPilot image. But even though my ST is detecting motion, recording clips I don’t get an updated image. To make matters worse I no longer am able to do a live view from within ST. Yesterday I defaulted the Arlo system and started over. I do have the Arlo Pro 2 with base station.


#338

I’m having the same issue. Get “false” when trying to view in browser.


(Karl) #339

Mollyrh… Viewing the camera live temporarily on the arlo website and then stopping the camera should get the false to go away… but I still can’t figure out how to get the most recent captured image to appear in an action tile.


#340

Thanks for the reply. I tried that but it did not work for me. The small picture for each camera updates in Arlo Pilot, but when I try to view link in browser, it still returns “false”.


#341

I only did OAuth on the ArloPilot smart app in Smartthings IDE, i.e. not the two added automations. Is that correct or do the automations need to be externally authorized too?


(Chad Cole) #342

Now that you have it setup try to reset the OAuth token. That seemed to fix my tile getting the false setting. But still not getting the last image updated unless I view the camera live via Arlo app or website. The live view is inop from within Smartthings.


(Amauri Viguera) #343

Just keep in mind the Arlo folks have been having issues dinner last week. I think the 11/21 update seems to have introduced all kinds of problems, to the point that the cameras even stop recording in some cases.

There was an update to the Android app this morning, but I haven’t seen any improvement in the reliability of my system.


#344

Good thought…but didn’t work either. I reset the OAuth token and then went back into Arlo to view/stop live feed. Then tries to access ArloPilot view in browser - still returned “false”.


#345

I’m still having issues with getting “false” when trying to view still picture in viewer. I have confirmed OAuth in IDE, viewed live video in Arlo then hit stop, refreshed link address.

I’m sure its something I’m doing wrong - just can’t figure it out. Any other suggestions would be appreciated!


#346

Still hoping someone might be able to help me with my “cluelessness”. Still can not get the public image URL to work. I’ve deleted and reinstalled the app and device handlers. Refreshed the link several times. “Stopped” the live feed in Arlo app. Logged out of Arlo app several times.

If I do not activate the external link portion of ArloPilot, I get updated pictures from each of my cameras fine. As soon as I enable “external link”, I no longer see the larger camera image in ArloPilot and the link returns an “error”.

I have “Published” the ArloPilot app in My SmartApps but not the Device or Mode Automations. Nor have I “Published” the Device Automation under My Device Handlers.

I enabled OAuth for the ArloPilot app only under My SmartApps.

No errors were returned during operation when reviewing SmartThing logs.

Suggestions??? Please…


#347

Really good job.
I copied url of tiles image but it looks like they expire everyday, so it worked yesterday but today all image are broken.


(Mavrrick) #348

Do you have enough activity on the cameras to get new images daily.