SmartThings Community

[RELEASE] ArloPilot - Enhanced Arlo System Integration

smartapp_cameras
arlo
project_cameras

(Richard Greenall) #244

Yep… Same boat here as well. Arlo Pilot seems to have stopped after the update for me


(Eric V) #245

Quick fix for those that have a system unable to switch Arlo modes, here’s a solution until an official fix is out.

In the dev portal, in your “My SmartApps” section, in the ArloPilot Service Manager code (shackrat : ArloPilot), comment out line 1211 (add // to the beginning of the text on that line), save and publish. (See image below for what the updated code state should look like.)

Something appears to have changed on the Arlo side and including that param throws an error that prevents the mode switch from happening. With that commented out, all seems to work as expected.

Example


(might be my fake name?) #246

What do you what do you mean by “comment out”?

Is that lingo for just delete that whole line?


(Eric V) #247

Sorry about that. Yes, deleting the line works. I prefer to leave it there for reference so a //at the beginning of it as in my example will just make the system think it is a comment instead of code.


(might be my fake name?) #248

so put // before it and // after it?

or just before it?


(Eric V) #249

You’ll see the formatting change when you add the //


How to integrate Arlo Hub siren to my Smartthings system
(Eric V) #250

Just before it.


(might be my fake name?) #251

ok thanks a bunch…i’m glad someone on this thread knows how to read and edit code…By the way, do you know what’s up with @SteveWhite ? He hasn’t been on the forums in awhile…

Thanks again.


(Eric V) #252

No problem. Did that fix it for you?

And no, not sure what’s up with him. Likely real life keeping him busy. :slight_smile:


(might be my fake name?) #253

I like the idea of “commenting it out” so it remains there in case of future changes/needs.

That worked…thank you…Happy 4 year forum anniversary by the way.


(Richard Greenall) #254

Thanks evanbeek. Commenting out worked like a charm


(Eric V) #255

Yikes. Has it been 4 years? Man, time flies.


(Ryan Li) #256

Hi,

I tried to comment out the code in IDE. Saved and published but it still doesn’t work. Do I need to reboot the SmartThings hub?

FYI, i get the following in the logs.

6dd1a18a-9e16-4bd8-bde3-82e764f687ed 2:43:01 PM: warn Mode Change Events are Disabled!

Ryan


(Eric V) #257

Shouldn’t have to reboot anything. I’m not sure how your system is configured, but that sounds like you have something disabled in ArloPilot. I have mode change events enabled in the settings and use those events to change Arlo modes.


(Ryan Li) #258

My IOS version of the classic SmartThings app looks different. But, yes I have been using mode automation to synchronize my Arlo modes with my SmartThings mode (if SmartThings is in the home mode, Arlo will be disarmed; if SmartThings is in Away/night mode, Arlo will be armed). It has worked like a charm until the last two days.

So I tried to put your fix into the code. And for some reason it still doesn’t work.

!


(Ryan Li) #259

I figured out a hack/workaround.

Instead of synching modes between ST and Arlo, I used the Trigger Arlo modes.

Created a virtual switch to turn on when ST changes to certain modes and this will trigger Arlo to corresponding modes.


#260

This fixed it for me. Thank you!


(Eric V) #261

That’s odd. I’m glad you found a workaround, but if it was working previously, you shouldn’t have had to do that. The change that I outlined above simply removes a parameter from the mode change call that Arlo started erroring on.

Looking in the app code, the message that you noted above Mode Change Events are Disabled! should only happen if the mode change option is switched off. I’ve seen some options get out of sync in ST, so might be worth turning it off and back on just to make sure it’s all set properly (if you want to try and switch back to mode triggers).

Otherwise, if it’s working for you now, might as well leave it until it breaks and try and fix it then. :slight_smile:


(Brandon Reed) #262

Thank you SO much @evanbeek for your diligent work determining an interim fix here. I have been banging my head against the wall for weeks trying to patch together my own fix, and after I commented out that line…poof! Like magic it began working again :slight_smile:. Much appreciated man!


(damian666) #263

@evanbeek thank you for your help, you saved me a bunch of time. I commented out the code and got things working with the “Connected to SHM” mode. I could not get “Mode Automation Management” to work.

Does anyone know if any work (code available) is being done for the New Version of Smart Home Monitor?