[RELEASE] ArloPilot - Enhanced Arlo System Integration

I actually just checked my cameras and none of them changed mode when I left the house this morning.
Trying to manually change the mode via the Arlopilot smartapp didn’t work either

Ok. So it’s not just me. I Wonder if it has something to do with the firmware update on Thursday for the Smartthings hub.

Looks like I am in the same boat with modes not changing since firmware update.

@SteveWhite. Is there anything that we can do to help fix this? Do you know if it’s related to the firmware update on 10/11/18? @Brad_ST

ArloPilot is throwing an exception.

Caught exception [java.lang.NullPointerException: Cannot get property 'data' on null object] while attempting to set mode.

I’ll dig a little this afternoon and see if there’s a quick fix.

2 Likes

I made this small app that captures a quick video feed on every Mode Change because I initially thought the same way you did. However, after a few weeks I realized it didn’t matter… because if nothing triggered the cameras… there wasn’t anything important to see… so I’d rather have the extra battery life than the updated thumbnail. :slight_smile:

I’m going back to using stringify to arm and disarm my arlo hub. At least until arlo Pilot is fixed!:pray::pray:

Yep… Same boat here as well. Arlo Pilot seems to have stopped after the update for me

Quick fix for those that have a system unable to switch Arlo modes, here’s a solution until an official fix is out.

In the dev portal, in your “My SmartApps” section, in the ArloPilot Service Manager code (shackrat : ArloPilot), comment out line 1211 (add // to the beginning of the text on that line), save and publish. (See image below for what the updated code state should look like.)

Something appears to have changed on the Arlo side and including that param throws an error that prevents the mode switch from happening. With that commented out, all seems to work as expected.

Example

6 Likes

What do you what do you mean by “comment out”?

Is that lingo for just delete that whole line?

Sorry about that. Yes, deleting the line works. I prefer to leave it there for reference so a //at the beginning of it as in my example will just make the system think it is a comment instead of code.

so put // before it and // after it?

or just before it?

You’ll see the formatting change when you add the //

2 Likes

Just before it.

ok thanks a bunch…i’m glad someone on this thread knows how to read and edit code…By the way, do you know what’s up with @SteveWhite ? He hasn’t been on the forums in awhile…

Thanks again.

No problem. Did that fix it for you?

And no, not sure what’s up with him. Likely real life keeping him busy. :slight_smile:

I like the idea of “commenting it out” so it remains there in case of future changes/needs.

That worked…thank you…Happy 4 year forum anniversary by the way.

1 Like

Thanks evanbeek. Commenting out worked like a charm

1 Like

Yikes. Has it been 4 years? Man, time flies.

Hi,

I tried to comment out the code in IDE. Saved and published but it still doesn’t work. Do I need to reboot the SmartThings hub?

FYI, i get the following in the logs.

6dd1a18a-9e16-4bd8-bde3-82e764f687ed 2:43:01 PM: warn Mode Change Events are Disabled!

Ryan