[RELEASE] Alarm.com Z-Wave Thermostat ADC-T2000

Does this work at all with the new SmartThings app? I can get it to work in Classic, but I get no info in the new app, and thus the smartthings bar in android (on a Samsung). The device is there, but shows no info on the bar, and can only see current battery level, temp and humidity in the app itself, but with no control.

I added the VID to the device handler which seems to get it to work with the new app. You have to jump through hoops sometimes to get custom handlers to work. For example, after updating the handler you may have to click the gear icon and save for the device. You might have to switch to a different handler and then back. Also, you might have to kill the new SmartThings app after all of this (on your phone) and open it again.

My advice though is to not use the new app. It is a long ways from being a good replacement to the classic app.

I see the device handler and everything here but no where online can I find the instructions for pairing the device to ST. Do any of you have a link?

Google search result for the manual: https://www.myprotectamerica.com/uploads/documents/Smart_Thermostat_Product_Manual1.pdf

Hello,
VERY new to all this, I picked up 2x ADC-T2000 Thermosats, as well I have the Samsung Smartthings Hub V3. Trying to setup my Thermostat as a device z-Wave…

can someone IM me or post a nice step by step on getting this unit to show in my app?

Much appreciated!

Here is some info that will help you out:

Hi everyone
I have 2 of the ADC-T2000 units for sale, I have decided to go another route…

I am in Canada and will ship to you… I would like to ask 50 CDN for each…

One was used for testing, other never used (open box)…

My Nest died and I just replaced it with this thermostat. Seems like a nice replacement except I can’t seem to get the ability to put it into emergency heat, any recommendations?

It doesn’t seem to matter which HVAC Mode I put it in, I’ve tried all of the options with “emergency heat”, but I always get the same 4 to toggle from the interface, Off, Heat, Cool, Auto. I’ve never been able to put it into, or get my emergency heat running.

Does the thermostat support emergency heat? I don’t even know what that mode does. (excuse my ignorance).

Hi Eric and JW,

What device do you select in the ST to pair it? My phone doesnt seem to see thermostat…
I tried 2gig, generic z-wave device, tried searching etc…

Thank you!
Vince

If you are using the new app I believe you just click on the “Scan nearby” button and then do the inclusion process on the thermostat.

No need to select a specific device.

I tried with both apps and it doesnt find the thermostat :unamused:

During migration to the new SmartThings app, my SmartThings now has a “split unit” problem (don’t know what else to call it) - when I go to set the Thermostat temperatures in Scenes, it has Fahrenheit for cooling temp (accepts input between 32-104 F) and Celsius for heating temp (accepts input between 0-40 C). Any advice for how to troubleshoot?

Maybe it needs to be switched to heat mode and get some reports in that mode to correct itself.

That worked, thank you. I uncovered a new problem, though. Inside the new SmartThings app, I’m unable to change the Heat or Fan Modes. The options are listed but when I select a new one it attempts to make the change (spinning circle animation)… THEN nothing. Continues to list the previous Heat (or Fan) Mode.

EDIT - Error message “A network or server error occurred. Try again later”

Does it change the fan mode on the thermostat itself? If you back out of the device and go back into it does it show the correct mode.

Edit: Also, are there any error messages in the ide logging when it happens?

@erocm1231

Great work on the DH for the T2000. I having as slight problem that I’m hoping you can help me with. I’m using the new ST app and Platform with Home Assistant. All of my ZWave devices are on the ST HUB and I’ve setup ST integration with Home Assistant where it pulls all the ST data over and sets up devices to managed. Everything works except the thermostat. The thermostat shows up but there are no controls to set the temperature modes (example: Cool, Heat)

Here’s what it should show in Home Assistant.
image

One of the ST maintainers for helped me solve the issue before but the problem showed up again when I migrated to the new ST App and Platform.

Here’s a link to the github conversation for reference: https://github.com/home-assistant/core/issues/23936

Please let me know what additional information is needed to troubleshoot.

Thanks.

Hello Eric -
Just checking in to see if you can help with my issue?

Thanks

I updated the device handler a while ago to add some of the commands and attributes that have been added to the thermostat capability. You need to save preferences after the device handler is updated for some attributes to be populated. It should work after that according to the article you mentioned.

Thanks Eric. Updated the handler and the commands and attributes are now visbale.

1 Like