SmartThings Community

[RELEASE] Alarm.com Z-Wave Thermostat ADC-T2000


(Charland) #34

I just installed this kind of thermostat ADC T2000 and use the alarm.com application on my iPad. So far it works fine except if I want the fan to be on all the time it does not work even if I set it to recirculate. If I want it to work, I need to set it to 24 hrs and reset it after the timer is off. Any way to fix that?


(Joel R) #35

Dude! Thank you for all your effort.


(Bob) #36

’ Slide clip lip, 08s n ps to delete them


#37

Thanks for the work on this! Works it good but I did come across something. If the thermostat is set to auto cool/heat changing the temp in smartthings doesn’t do anything. It changes in smartthings but the thermostat stays whether it was. Changing to cool or heat will allow it to change.


(Eric M) #38

Thanks, I fixed the auto mode problem.


#39

Thanks a lot! Works great!


(Christian) #40

Eric, I have smartthings and previously had alarm.com w/ the adc t2000 smart thermostat. Trying to get it z-waved or wifi into the smartthings hub but hzving trouble. Any suggestions?


(Christian) #41

Okay got them to talk and on my smartthings app now, however I only get heat and eco mode not cool or A/C. Suggestions?


(Christian) #42

How do you install the handler?


(Troy S Barnette) #43

Eric,

thanks for all of your work setting this up.

I am new to Smartthings and have the alarm.com thermostat as well. I installed your handler and then installed the the thermostat. I have noticed that my screen does not resemble yours. I have also noticed that when I change from to and from Auto the icons do not change.


(Eric M) #44

I think SmartThings changed how the sliders appear since I originally posted those pictures. Also, the icons below do not change, but the text in the main tile should and there should be info in the “Recently” tab showing which mode it is in.

@cdouge, here is some information about custom code in SmartThings:


(Aleksey) #45

Is anyone else forking this or is the OP updating? Configure button still has an orange circle and the field next to the humidity shows “???” instead of the status of the thermostat.

Also, what does needUpdate check? Mine is yes, does it mean that my firmware needs to be updated?


(Eric M) #46

It might take time to populate the humidity.

In the logs, when you click on the configure tile, what parameter is it trying to update?


(Aleksey) #47

Maybe I’m not using the configure tile correctly, but I assumed a menu would pop-up if I clicked on that?


(Eric M) #48

The SmartThings app doesn’t allow that. That button will send the configuration options that you set in the preferences for the device (click the little gear icon in the upper right).


(Aleksey) #49

Ahh, okay, makes sense.


(Adam) #50

Hey Eric,

I wanted to thank you for all your efforts in making this thermostat work. As I dive into smart things more and more I’ve discovered I have a issue with the mode changes through automation/routines/smartapps. If I set up a Piston or the “smartapps” the command will not cause the thermostat to switch modes. The only thing I can get to work is adjustment on setpoints Heat/cool to change. I’ve tried various apps routines and now pistons to try to make it work. Any suggestions?

I installed your Dev handler a few months ago and have worked around it since. I might try reinstalling it just in case there was a update or I got the code messed up. Besides that I’m at a lost.

Once again I appreciate you taking the time to work on this thermostat. It is what got me interested in smartthings.


(Eric M) #51

The commands to change the mode from WebCoRE would be:

modeheat
modecool
modeauto
modeoff


(Othniel Badea) #52

Can this Thermostat be connected both to Alarm.com and to my Smarthings HUB at the same time?


(Russ) #53

Does this work at all with the new SmartThings app? I can get it to work in Classic, but I get no info in the new app, and thus the smartthings bar in android (on a Samsung). The device is there, but shows no info on the bar, and can only see current battery level, temp and humidity in the app itself, but with no control.