SmartThings Community

[RELEASE] Aeotec Water Sensor 6 ZW122

aeotec
zwave
dth_watersensor

(Robert Vandervoort) #21

no, there are no sensitivity settings. is it encountering a lot of condensation or something? bare metal will trigger it too.


(Robert Vandervoort) #22

there is a configuration to trigger on dry vs wet. I’d need to check on whether it can be done for one in one manner and the other in the other though. I haven’t had time to get back to the device handler unfortunately. I have been working on some new handlers for the nano motes about to drop though… I’ll take a look at this one again soon.


(Robert Vandervoort) #23

that sounds like it got paired as the wrong device type initially. Remove it and add it back… it should add properly the second time. I’m assuming you had joined it to ST prior to loading up my device handler yeah?


(jessica) #24

I’ve gotten my paired and the device handler installed. When I wake the sensor (button to the yellow light) and tried to tap on configure it doesn’t do anything. What should I be seeing on the configure screen? Thank you.


(Robert Vandervoort) #25

did you pair THEN add the device handler? If so it didn’t get configured properly. You need to add the device handler prior to pairing with ST. Sometimes using config after wake up will work, but depends on what device ST originally recognized it as whether it sent configuration parameters that my handler may or may not fix… If you paired to ST prior to adding my device handler, it’s best to do factory reset on the sensor (hold action button for about 20-30 second) and then re-pair it.

Sorry for the delay in reply. I don’t check here very often lately…


(jessica) #26

Thanks for the response. I tried pairing & then adding the device handler, then removed it and left the device handler installed. I paired it a second time and it recognized as the correct device handler. Tried removing & installing several times (both on & off the base - though Aeotec said that the base wouldn’t make any difference) tried factory reset. Gave up & talked to Aeotec, who said to return it. I’ll order a new one sometime in the future and see if it works differently.

Any timeline for making the probes read independently? I have actually come up with two uses for the multi probe now that I would love to have a device handler for - but its WAY above my skill level.


(Mark) #27

@Robert_Vandervoort, should we be able to tell which of the two leads are wet just by looking on ST or the IDE somewhere?


(Lucas) #28

I have the water sensor 6 along with the dock. The device type comes up but I can’t get any wet readings. It correctly identifies when it’s on battery or ac power and also the temperature. Thoughts? What do all the different led colours mean?


(Robert Vandervoort) #29

I haven’t done any work with the handler on the new app yet only the classic one. So if any of these questions pertain to the new one I have no idea. I can tell by lookingbthough that I have lots to do… that said you should be able to tell which probe by looking in the app in the details view of the device. In the lower left corner of the main tile it will display which probe is wet.

LED colors I can’t remember. I would look at the instructions. https://s3.amazonaws.com/cdn.freshdesk.com/data/helpdesk/attachments/production/6052990319/original/ES%20-%20Water%20Sensor%206.pdf?X-Amz-Algorithm=AWS4-HMAC-SHA256&X-Amz-Credential=AKIAJ2JSYZ7O3I4JO6DA%2F20180806%2Fus-east-1%2Fs3%2Faws4_request&X-Amz-Date=20180806T040142Z&X-Amz-Expires=300&X-Amz-Signature=a66e316c9be6806b3f61ae67eac185097b2794c7c3d50448b2d88bc1e1e55fe1&X-Amz-SignedHeaders=Host&response-content-type=application%2Fpdf


(Mark) #30

The device keeps reporting wet (using the Classic app), but then when I go into the details view, it shows this (below). I can’t tell from this which probe is sensing water. I’ve check both probes and they are bone dry. Any ideas?


(Robert Vandervoort) #31

@MLUCK looks like it isn’t getting all the events coming in. Have you tried purposefully triggering it by shorting the probe wires together with water or metal? Does it change state in the app and beep? Wondering if it got the configuration properly after pairing. That’s common. I need to rework all of my handler to use a verification model (state machine) for configs. Once I find time. Haha. Between Cisco and family I stay u we busy these days.


(Mark) #32

The probes are behind 2 dishwashers so they’re a PITA to access. I ended up deleting the device and re-adding. Then switched to your DH. Seems to be behaving now. Thanks.


(Kyle Mizell) #33

Thank you @Robert_Vandervoort for building this handler. My main purpose for this sensor is for temperature reading. I’ve been messing around with your handler, and trying to adjust the polling interval. I see 2 separate intervals, I’m assuming are relevant:

// Set the wakeup interval to 4 hours
zwave.wakeUpV1.wakeUpIntervalSet(seconds:4*3600, nodeid:zwaveHubNodeId),

// Set the interval time for sending the unsolicited report
zwave.configurationV1.configurationSet(parameterNumber: 0x6F, scaledConfigurationValue: 3600, size: 4),

Which one should I adjust to get the Smartthings app to poll the temperature every minute? I am trying to use this in conjunction with a Virtual Thermostat, so I know every minute might seem aggressive, but it’s on purpose. :slight_smile: Thanks for your help.


(Kyle Mizell) #34

I am also noticing over the last 24 hours, that the temperature only updates the Smartthings hub after I open the app on my phone. I don’t see temperature change history in between me viewing the temperature (more than 8 hours) in the app. I would expect the device to be communicating with the Smartthings hub regardless of me viewing the device in the app.


(Robert Vandervoort) #35

Are you running it off USB power? There are two parameters which control this behavior.

0x65 (101) To set what unsolicited report would be sent to the Lifeline group.
0 = Send Nothing.
1 = Battery Report.
2 = Multilevel sensor report for temperature.
3 = Battery Report and Multilevel sensor report for temperature.

0x6F (111) Set the interval time for sending the unsolicited report that configured
by parameter 0x65. (Valid values 0x05-0x28DE80)
Note:

  1. The unit of interval time is second if USB power.
  2. If battery power, the minimum interval time is equal to Wake Up
    interval set by the Wake Up CC.

For the 0x65 you need it set to either 2 or 3 so you get temp readings sent over. For 0x6F as you can see from the notes, USB powered makes the parameter value be in seconds, if on battery it will use the wakeup interval. So if you are on battery and you want the sensor reporting every minute (highly inadvisable due to short battery life) you’d need to set the wake up interval to one minute.


(Kyle Mizell) #36

Thanks for sharing the documentation. I found it online as well, but it was confusing how it described the two values, and when I finally got the right combination it works mostly (although it only polls ever 4-5 minutes, when I have it set to 60 seconds).

I have it running on USB power, so I’m not concerned with power consumption. I am fine with it updating it’s temperature every ~5 minutes, so I think I’m good for now.

Thank you for making this device handler. Is there anyway to have it automatically associate this device handler to this device type when it’s initially discovered? I still have to manually select the device type from the drop down (editing the device in the IDE) after I add the device to Smartthings.


(Robert Vandervoort) #37

in the IDE what does your RAW description say on that device?

mine is:

Raw Description zw:Ss type:0701 mfr:0086 prod:0102 model:007A ver:1.03 zwv:4.38 lib:03 cc:5E,86,84,72,98,5A sec:85,59,80,70,7A,71,73,31,60,8E role:06 ff:8C07 ui:8C07 epc:2 ep:[‘0701 71,5E,59’]

mfr:0086 prod:0102 model:007A - this is the part that is needed to match the device to the handler. if yous is diffeent fo some reason then that should be why it isn’t automatically detecting it.


(Kyle Mizell) #38

Interesting, all 3 values are ‘0000’. I will have to investigate that. Thanks for helping me troubleshoot.


#39

Robert thanks so much for making the DH. I’m having issues getting the config button to work. Originally I had paired with out your DH. I then read your directions added the DH, reset my sensor, and re-paired it. I get the other info, I just can’t click on on configure.

If you’re making any updates to it can you include options to turn off the sound, and maybe LEDs.

Again thanks a ton!


(Bill B) #40

I’ve got the same issue as NolaBob. can’t get the config button to work. I believe I followed all instructions properly. Also, when I try to put the sensor in configuration mode it just flashes yellow a few times and beeps 6 times with a short pause after every 2 beeps. the sensor will go into config mode immediately after it’s paired, but even then, the config button in the smartthings app doesn’t do anything.
Any help would be appreciated, thanks! Here’s an image of what I’m seeing on the app: