[RELEASE] Aeotec TriSensor

Placeholder means that the device is using a Driver so the only way to get the device to use my custom DTH is to remove the device and add it again.

I’ve tried that a few times. Just done it again, and this is how it appears once it has been deleted and re-added to the network:


Note, it is not associated to a Hub for some reason. It is the only device that isn’t.

I also just spotted this warning when I look at your device handler:

I’ve also tried deleting the device in the App, then going into the Hub in the App and deleting the Z-Wave Sensor driver. That deleted successfully, but when I added the device back again, it reinstalled the Z-Wave Sensor driver so I am back to square one. Only not it reported an error at the end of pairing about not being able to create a secure connection, and now none of the sensor states are reporting back.

The device was associated with your hub and functioning normally, but it’s using a driver so most of its information won’t be visible in the IDE and you can’t make any changes to it using the IDE or it will stop functioning.

SmartThings will be retiring Groovy DTHs and the IDE at some point which is why the IDE doesn’t support devices using drivers.

That message is shown for all custom DTHs

Aeotec manufacturers the SmartThings hub so the built-in drivers for their devices most likely have an exact fingerprint match and using custom DTHs with those devices might not be possible anymore.

The security failed last time you added it so you’ll need to remove the device and join it again, but if it joins successfully next time then just leave it on the driver that ST assigns it.

Thanks, but then I have no control over the settings which I why I wanted to use your driver. By default the Light sensor only reports in every hour, and I need it to be every minute. I also need to disable the LED’s to save the battery life. How can I do that with the built in driver?

If I can’t use your driver to set the default reporting intervals and disable LED’s, is there any software I can use to do that?

@JDRoberts do you have any suggestions?

I would start by contacting Aeotec support and asking them.

If they don’t have a solution, @Mariano_Colmenarejo is planning to do an edge driver version of the Z wave tweaker in August if it’s possible. That might mean it’s not ready until September, which I know is a ways off, but at least there’s a long-term possibility. :thinking:

1 Like

Ideally @SmartThings are working on a Z-Wave Tweaker, we can’t rely on just two community members to fill in all the gaps, or else at some point Samsung will be obliged to call it “Samsung, Mariano and Todd’s SmartThings”.

1 Like

@krlaframboise

Hi and thank you for creating this DTH.

The Aeotec is one of 5 multi-sensors in my ST network. However, it is the only one using the MultiSensor tile, the rest use the standard Motion Sensor.

Is there a way to shift the tile to the Motion Sensor icon?

If you recently added the device then it’s most likely using a built-in driver and not my custom DTH so there’s nothing I can do about the icon, but the custom DTH will most likely stop working in 4-12 months so you’re better off using a built-in handler either way.

I have had the device online for a while and have even played with the code a bit to change the tile myself before reaching out, so the DTH is definitely being used.

I am frustrated by how the slow roll on Edge is being done. They kill features with no replacement ready and as they do the functionality of the system slowly goes downhill. Some workarounds are possible, but are cumbersome at best and lose the nuances of what made the original version desirable.

I understand your position.

If you add the line below to the definition section near the top of the code it should change the icon to a motion sensor.

ocfDeviceType: "x.com.st.d.sensor.motion"

That type of change is impacted by caching so it might take a while to see the change, but sometimes you can force it to refresh by clearing the app’s cache in your phone’s settings or rebooting the phone…

Thanks, I appreciate it!