[RELEASE] Aeotec Doorbell 6

Aha! The problem appears to be the default siren tone 10, I switched to tone 1 and it is the volume I would expect although it’s a chime sounding tone, I’ll work through them and see if there is a siren sounding one other than default.


Many thanks for the help.
Pete

That’s a bug in my handler, the default siren tone should be 17.

17 works like a dream :blush: again many thanks for the help and for the handler.

Pete

I currently have the Aeotec Siren on its own DTH. I also purchased the Doorbell 6 with the button so I have two Sirens/Chimes. The Doorbell 6 is of course on this DTH, along with the child device for the included button which is about 10’ away from my v3 hub, totally clear line of sight.

I have noticed about twice a week, I wake up and notice my button is at 1% battery. Not sure what I did last time to fix it but it went back up to 100% as it is a brand new battery and stayed there for a couple weeks.

This morning I woke up and its at 1% percent again and I am sure that it is not at that level.

I tried resyncing the Doorbell 6 as well as the button, I think that fixed it last time for me but today it stays at 1% and the unit itself is flashing every few seconds. Everything is still working too. I’m stumped.

Any ideas on what is happening here? I solely use the classic app even though I have a v3 hub. Only one location, one hub. That was not fun to fix. If anyone needs anything from my logs, just let me know and I will post them up. I have insecure rejoin turned on too even though I shouldn’t. This is the only device out of about 40 that I am having issues with pretty regularly.

I have reset, excluded, re-paired. I am on firmware 1.0 according to SmartThings IDE as far as the button and as for the Doorbell 6 itself, I see this:

networkSecurityLevel: ZWAVE_S0_DOWNGRADE

zw:Ls type:0301 mfr:0371 prod:0103 model:00A2 ver:1.04 zwv:5.03 lib:03 cc:5E,55,98,9F,6C,72 sec:70,86,59,85,73,60,8E,5A,7A,71,79 role:05 ff:A200 ui:A200 epc:8

I can see the doorbell at button one, looks to be configured properly. The Doorbell is on v1.4

My doorbell rang yesterday as it should when someone was at my door but looking into the logs for the Doorbell. I took two snippets of the logs for the doorbell as well as the button. I am stumped.

If anyone has any idea what is going on here, I’m all ears. Should I also switch out the DTH for my old Aeotec Siren (still use), with the same one for the Doorbell 6? I think I read that on one of the pages in this channel. I went through it all and couldn’t find anyone else with the same issue. Keep in mind I am using the new V3 hub, which is about right in the middle of the doorbell and the chime. I would say about 15 feet max. I did get very cold last night but it didn’t freeze.

edit: wouldn’t let me post two photos. I ended up creating a new profile with Github so the outdoor button is what I uploaded. Sorry if it is hard to read. I went out and pushed the doorbell, magically it is at 96% battery. I shouldn’t have to push my own doorbell every morning to get it to refresh. I must be missing something important. The weird this is the Doorbell 6 flashing all night long for no reason.

This is a known issue with the Aeotec Doorbell 6, but it doesn’t happen for all users so you might want to contact Aeotec.

Pushing the physical button and/or pushing the refresh button in the app should get it to report the correct value.

I would also love the ability to have the small LED on the outdoor button on at sunset and off and sunrise. Shouldn’t drain the battery an incredibly amount faster, plus they are dirt cheap on Amazon. This way people can actually see that it’s a doorbell at night.

Having the ability to have the LED on solid from sunset to sunrise would be really helpful.

So am I doing something wrong or just my bad luck? brought a doorbell 6, got it working with the DH from here, a week later went to test it and seem the thing is dead… exchange with Amazon… got the second unit working, next day I move it to my bedroom and to make sure it is still working/connected I use the ST apps to lit up the strobe (plugged in) after a couple flashes (with some weird chirping noise, but I didn’t use both or chime, just strobe) the thing die and now no response, in the ST app it show/stuck as “Alarm/orange” and I can’t refresh or sync it. Both unit doesn’t do anything if i press and hold the action button for 20+ seconds. Amazon siren 6 also had a review that said 2 of 6 units die on that reviewer? anybody else? should I return this second one too and get a siren 5 instead?

Make sure you’re using the SmartThings Classic Mobile App and if you don’t see the settings when using that app then my handler wasn’t actually assigned to it and you’ll need to change the “Type” field in the IDE.

it was working fine with your handler (I could change tone and control on/off and other settings) with the classic app during install, but now it seem to be bricked. If i press and hold the action button for 20+ seconds to no response, it turned into a brick rigiht?

Holding it for at least 20 seconds factory resets it so after doing that you’ll need to force remove the device from SmartThings, if you didn’t remove it before resetting, and then join it again.

Hi Kevin,

first of all - thank you! Marvelous work, and so many DTHs, amazing support, really.

The Doorbell 6 just arrived and works perfectly with SmartThings thanks to your work, however what I really wanted is to have the Doorbell exposed to Home Assistant and run a few “complex” automation with it. The main blocker for me to setup HA with ST is the plethora of integrations it has, plus the fact SHM is quite limited and customizing a security system behavior works better for me…but don’t wanna digress more :slight_smile:

Let’s get to a question, the way Doorbell 6 is exposed to HA is the following:

  1. [binary_sensor.doorbell_tamper] device_class: problem states on=problem/off=OK
  2. [light.doorbell] supported_features:33 states on/off brightness is an input - triggers the switch on event
  3. [sensor.doorbell_alarm] status off/strobe/…untested but I guess siren/siren+strobe ecc
  4. [switch.aeotec_doorbell_6_button1] states on/off -triggers the button event

This is quite great for the setup, you can set it to ring when the Ring Pro button is pressed and it’s really effective, given its Chime is ridiculously low.
The question - finally
Does any of the functions you can input/set for the light modify the behavior of the switch on event as you mention SHM/ST does? With HA, this would allow you for example to require a specific sound/strobe for when the alarm is triggered but not sounding yet, and other things like a different alarm when the alarm is set to armed_home versus armed_away and triggers or sounds. I can see the item 2. from the list, the light, allows the following. Would you advise if anything here would have any specific behavior as with SHM?

Parameter Description Example
entity_id Name(s) of entities to turn on light.kitchen
transition Duration in seconds it takes to get to next state 60
rgb_color Color for the light in RGB-format. [255, 100, 100]
color_name A human readable color name. red
hs_color Color for the light in hue/sat format. Hue is 0-360 and Sat is 0-100. [300, 70]
xy_color Color for the light in XY-format. [0.52, 0.43]
color_temp Color temperature for the light in mireds. 250
kelvin Color temperature for the light in Kelvin. 4000
white_value Number between 0…255 indicating level of white. 250
brightness Number between 0…255 indicating brightness, where 0 turns the light off, 1 is the minimum brightness and 255 is the maximum brightness supported by the light. 120
brightness_pct Number between 0…100 indicating percentage of full brightness, where 0 turns the light off, 1 is the minimum brightness and 100 is the maximum brightness supported by the light. 47
profile Name of a light profile to use. relax
flash If the light should flash. Valid values are short and long. short
effect Light effect. random

Thank you so much!
Matteo

This topic and handler are for the Doorbell 6 so if you have the Siren 6 you should be using my Siren 6 handler. Except for the fingerprint those devices are the same so they’ll work fine with either handler, but the Doorbell handler has a lot of extra code and tiles that are only needed for the button so you’re better off using the Siren handler.

I have no idea why it’s being exposed like a bulb to HA because the handler doesn’t have any color related capabilities.

It supports on/off and there’s a setting that determines what happens when you turn it on and it supports dimming/setLevel, but all that does is play the chime # specified as the dimming level.

The DTH allows you to set a different light effect for the chime and the Siren, but you have to manually set them in the settings so you can’t change them on the fly.

It would probably be a lot easier to use WebCoRE in SmartThings to interact with the Siren and have HA control one or more virtual switches that WebCoRE piston(s) use as a trigger.

HA turns on the virtual switch and the WebCoRE piston using that switch as a trigger sends the alarm command or chime # to the Siren based on the conditions you configured for that piston.

Thanks for your prompt reply! I am still in the processing phase of it :slight_smile:
First of all, sorry, I’ve been messing with these two names and I had in fact written this post within the Siren thread and then moved it, but forgot to also revert my self-convincing session that I had a Siren rather than a Doorbell, but I have the latter, with its first button, so we’re good :slight_smile:

It was really strange to see HA sees a light, however it actually works well. Now, you actually answered as I hoped, as it could be confirmed that if I launch a service defining also the brightness I get exactly that, a different chime sound every percentage point of brightness which is exactly what I wanted! No brightness? It goes with the full alarm - perfect :slight_smile:

Good tip on WebCoRE also, I managed to get it installed and up and running, it seems pretty easy and interesting - it surely may come handy!

The only thing is…I somehow felt the responses are sometimes perfect, some other times they are either ignored or veery delayed, and currently the Doorbell 6 went completely dead after triggering a few different sounds one after another…no sign of life even one hour later+. It now shows as if it’s “chiming” all the time, but does nothing. Unsure what to do, the connect button does not seem to provide any response, the tampering setting is not respected, removing the handler and adding it again does nothing, well…night will tell…hopefully it’s gonna be back up and running :frowning:
[update]
Resolved the brick, even though it was a hard hack, had to open it and short the battery, it all worked again when connected.

It executes in the cloud and I believe it has to send 2 commands to the device in order to play the chimes so playing multiple sounds back to back won’t be perfect.

It could be a couple of things…

If you set the strobe setting to off and execute the strobe command or volume to 0 and execute the Siren command then the device will turn on which will override the ability to play chimes, ring the doorbell, and trigger the tamper alarm, but the device won’t appear to be doing anything. If this is the issue then Tapping off will fix it.

I doubt that’s the issue so if tapping off didn’t fix it you should try restarting the device. I think the only way to do that is to unplug it and wait until the battery dies which usually takes 5-8 hours.

If you plug it back in after it dies and it’s still not working then try factory resetting it by holding the button for 20 seconds, but after you do that you’ll have to forcefully remove it from ST and join it again.

Multiple users have reported this problem with Hubitat and ST and restarting the device completely solved it for some, but others had to contact Aeotec to get a replacement.

Kevin, thanks a lot for your replies, unfortunately while it started working again while plugged, the battery was completely dead after that and did not recover. I have already obtained a replacement unit and the defective is going back tomorrow.

Again, except maybe for the light control and the volume control by some sort of settings like setLevel or similar :slight_smile: , I am extremely happy of having achieved everything I wanted with HA and the Doorbell - surely thanks to your work so, cheers!!!

1 Like

I just downloaded the old app and find out that I only had 4% battery left in my doorbell button!

Any fix for this!?

Br
Thekholm

I haven’t had a chance to look through the built-in handlers to try and find a “vid” that supports switch and battery which is the only way to get both to appear in the new mobile app, but you could use a SmartApp like “Simple Device Viewer” to receive notifications when your batteries get low…

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.