SmartThings Community

[RELEASE] Aeon WallMote Dual & Quad - 2 & 4 Button

dth_remotes

#121

I had not realised we could now set direct associations.

What would be great would be to use this switch to dim Philips hue lights but they are zigbee…

Is anyone aware of a cheap zwave device, module or bulb that might work? For example something like a fibaro module (on a separate circuit to the bulbs - ideally it would not need to be hard wired but could be plugged in) which could receive the dim command, send it to the hub which then dims the hue bulbs.

I appreciate there may be a slight lag - I love hue lights but I am not so keen on the look of any zigbee switch.


(Changmang2003) #122

How can i use this tool to do it? Aeon WallMote can teach it?


(Deepak Krishnan) #123

Hey guys, how did you guys manage to do the long press dim up and down function? I’m using the button controller smartapp to configure the button on the quad more…


(Eric M) #124

Long press up & down are mapped to button 5 press / hold in SmartThings. The default button controller app only supports 4 button devices. Do a search for all the advanced button controller apps out there or use something like WebCoRE.


(Deepak Krishnan) #125

Thanks @erocm1231. What i mean is that i have a dimmer configured for button 1. What i would like to do is single tap to switch On/Off and long press (held) to toggle dim up and dim down. Can you recommend a smartapp that does this?


(Ron) #126

@erocm1231 Thanks for the DH for this device. I notice “Held” events happen really quickly and they are sent in rapid succession. Have you thought of ways to solve this? It would be nice if held events only got sent when you lifted your finger, or maybe just once within a given time. 1/5 seconds or something like that.

Do you still feel this way? Just bought mine and wondering if I made a mistake doing so. I am hoping latest firmware is better.


(Eric M) #127

The firmware update has helped out a TON. At least the device doesn’t randomly stop working or burn through its battery. The button pressing on it is a little finicky which I’m not a fan of, but the device is “OK” now. I prefer the Remotec ZRC-90 over this, but it isn’t as nice looking.

As for your other question, I have added a preference to either have a button “held” event register when the button is released, or when the device sends its “held” reports. You have to time the hold so that your finger lifts off the button shortly after you feel it vibrate and then it should vibrate again (finicky). Once you have it down it is easy.

@Deepak_Krishnan WebCore can probably do what you are wanting. You will have to set the preference mentioned above to “Yes” to send multiple “held” events. Core should give you an option to incrementally dim a device, +10 or -10 for example, on each received “held” event. It is going to be tough though with all the cloud processing that is going on. For example, you will likely lift your finger to stop the dimming and the dimming will continue for a few seconds as the cloud catches up.


(Deepak Krishnan) #128

@erocm1231
Thanks. Figured the hold and dim function but not really practical as it takes time. Your CDTH are awesome. Been using them for most of my stuff. Thanks a lot.


(Brent) #130

Hey guys, how many days would you say the battery lasts on this device now with new firmware? Is the device worth buying for the price or would one recommend something else?

Thanks


(Ron) #131

I have had mine installed for about two weeks now. We press the button about 2-3 times a day. Battery is at 95%

I like it, and surprisingly my wife likes it, so I have purchased a second.

That said I have two Fibaro Buttons which are junk. I thought I liked it based on 1 month use and bought second. Then they both stopped working. They are complete garbage!

One important note. This is from Aeotech support when I asked where to find firmware update.

Currently we have removed it as it causes issues if you firmware update from V1.07 to V1.08 firmware versions. The WallMote should come with either V1.07 or V1.08 which are both stable firmware versions.

If you get an older device than V1.07, i can only suggest exchanging it while you can try firmware updating to see if there are any issues present. Devices under V1.07 have specifically been recalled to be fixed and should come as V1.07 for the fixed versions, and V1.08 for the newly produced versions.

Update: Got a little more info. Changes between v1.07 and v1.08 (reported by DH as 1.7 and 1.8 BTW) are as follows, again from support contact.

These are the change logs from V1.07 to V1.08:

  1. Solves LED indicator issue when mute mode is enabled.
  2. Solves issue where OTA process is terminated unexpectedly.

They are typically non-issue mainly, but i consider them minor bugs as most will not use them.


(Brent) #132

Thanks Ron, I will likely pick a few up then. :smiley:


(Ron) #133

@erocm1231 I tried your update to allow for Held upon release. It was working when I first set up but we kept having issue. So I added some debugging to the CentralSceneNotification switch and found the Case 1 (released) doesn’t always happen for long press. Not sure why but I had to switch back to the method that floods you with held messages. I need to find another option for my AC unit because it beeps on every command so making too much noise at night to turn on/off. Did you find this behavior? I have 1.8 firmware.


(Eric M) #134

It could be possible to use SmartThings runIn() method, but it would delay the response. It would look something like this:

delayedButtonEvent1() {
    buttonEvent(1, "held")
}

and then in the Central Scene parse method you would call it like:

runIn(5, "delayedButtonEvent1")

The trick is that these calls overwrite each other. So only the last one would get sent, but it would be delayed by how many seconds you pass runIn. If you lower the seconds by too much though, more than one may get through because of cloud processing.


(Ron) #135

Cool idea, I may try playing with that. Thanks!


(Eric M) #136

I’ve implemented that idea here:

https://pastebin.com/jiZfMiQd

I am traveling at the moment and can’t test it, but you are more than welcome to. There might be errors or you might need to adjust the runIn calls to more than 2 seconds. I think 2 seconds should be good, but you never know when the SmartThings cloud is involved.

Also, I’m not sure if createEvent will return correctly from a runIn call. If that isn’t working you can just change the buttonEvent’s “createEvent” to a “sendEvent”.


#137

I have the latest firmware installed on my quad wallmote and have installed the device handler mentioned here, but my wallmote just will not work properly. I have used the Button Controller smartapp to assign 2 of the buttons to 2 fibaro dimmers (both using the up to date handlers). The switches seem to work ok for a little while, although cannot handle any kind quick presses, I need to wait a few seconds after switching a light on before I can turn if off again else the button presses do nothing apart from a beep. My main issue is that sometimes the unit just does not work at all, I press the switch and it just goes crazy and starts beeping pretty eratic for a while without turning the lights on at all. Has anyone else experienced this? It makes the switch pretty useless for me as it’s 50/50 whether it will work at all…
I’m wondering if there is a parameter set incorrect or maybe there is a better smartapp to use, I have also tried Smart Lighting which had similar issues.
Any help would be much appreciated as my wife is not best pleased with me at the moment, all I keep hearing is “why can’t we just have normal switches that work”… As it stands, she has a point!


(WideSmiler) #139

Thank you so much for the device handler! Got it working with my new WallMote Quad with no issues.


(WideSmiler) #140

I was wondering what that button #5 was that appeared in ST under the Wallmote button configuration options. I just stayed away from it because I had no clue what it was. Thanks for mentioning.


(Ron) #141

Answer is a few lines up in this thread. Button 5 is mapped to hold.


(WideSmiler) #142

Sorry Ron, my previous comment was trying to thank you for mentioning what button #5 was, but I now see my wording made it look like I was asking instead. Sorry, and thank you!!